所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置使用静态端口实现二层组播示例

配置使用静态端口实现二层组播示例

组网需求

图1-8所示组播网络中,路由器Router通过二层设备Switch连接用户网络,Router的用户侧三层VLANIF接口配置了225.1.1.1~225.1.1.5的IGMP静态组,没有运行IGMP协议。网络中有HostA、HostB、HostC、HostD四个接收者,其中HostA和HostB希望长期稳定接收225.1.1.1~225.1.1.3的数据,HostC和HostD希望长期稳定接收225.1.1.4~225.1.1.5的数据。

图1-8  配置静态端口实现二层组播组网图

配置思路

在二层设备上配置IGMP Snooping的静态路由器端口和静态成员端口,可以实现此需求。

  1. Switch上创建VLAN并将接口加入VLAN。
  2. 使能全局和VLAN的IGMP Snooping功能。
  3. 配置静态路由器端口。
  4. 配置静态成员端口。

操作步骤

  1. 创建VLAN,配置接口加入VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. 使能IGMP Snooping功能。

    # 使能全局的IGMP Snooping功能。

    [Switch] igmp-snooping enable

    # 使能VLAN10的IGMP Snooping功能。

    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    [Switch-vlan10] quit

  3. 配置静态路由器端口。

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] igmp-snooping static-router-port vlan 10
    [Switch-GigabitEthernet0/0/3] quit
    

  4. 配置静态成员端口。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] l2-multicast static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] l2-multicast static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    

  5. 验证配置结果。

    # 查看Switch上的路由器端口信息。

    [Switch] display igmp-snooping router-port vlan 10 
     Port Name                       UpTime        Expires       Flags
     ---------------------------------------------------------------------
     VLAN 10, 1 router-port(s)
     GE0/0/3                         00:20:09      --            STATIC

    由显示信息可知,GE0/0/3已成为静态路由器端口。

    # 查看Switch上的成员端口信息。

    [Switch] display igmp-snooping port-info vlan 10
     --------------------------------------------------------------------------------
                         (Source, Group)  Port                          Flag
      Flag: S:Static     D:Dynamic     M: Ssm-mapping                       
     --------------------------------------------------------------------------------
     VLAN 10, 5 Entry(s)
                          (*, 225.1.1.1)  GE0/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.2)  GE0/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.3)  GE0/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.4)  GE0/0/2                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.5)  GE0/0/2                        S--
                                                    1 port(s)
     --------------------------------------------------------------------------------

    由显示信息可知,组225.1.1.1~225.1.1.3在Switch上有静态成员端口GE0/0/1,组225.1.1.4~225.1.1.5在Switch上有静态成员端口GE0/0/2。

    # 查看Switch上二层组播转发表。

    [Switch] display l2-multicast forwarding-table vlan 10
    VLAN ID : 10, Forwarding Mode : IP                                         
    --------------------------------------------------------------------------------
                         (Source, Group)    Interface                  Out-Vlan
    --------------------------------------------------------------------------------
                             Router-port    GigabitEthernet0/0/3          10
                          (*, 225.1.1.1)    GigabitEthernet0/0/1          10
                                            GigabitEthernet0/0/3          10
                          (*, 225.1.1.2)    GigabitEthernet0/0/1          10
                                            GigabitEthernet0/0/3          10
                          (*, 225.1.1.3)    GigabitEthernet0/0/1          10
                                            GigabitEthernet0/0/3          10
                          (*, 225.1.1.4)    GigabitEthernet0/0/2          10
                                            GigabitEthernet0/0/3          10
                          (*, 225.1.1.5)    GigabitEthernet0/0/2          10
                                            GigabitEthernet0/0/3          10
    --------------------------------------------------------------------------------
    Total Group(s) : 5

    由显示信息可知,组225.1.1.1~225.1.1.5在Switch上已生成转发表。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10 
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10 
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     igmp-snooping static-router-port vlan 10 
    #
    return
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:7017

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页