所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

E600 V200R010C00 配置指南-IP组播

本文档介绍如何配置IP组播功能,主要包括IGMP/MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置、可控组播配置、组播网管配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD Snooping Proxy示例

配置MLD Snooping Proxy示例

组网需求

图2-9所示为一个IPv6组播网络,路由器Router通过二层设备Switch连接用户网络,Router运行MLDv1。网络中接收者主机较多,管理员希望主机能接收组播数据的同时,众多MLD报文交互不会对Router形成压力。

图2-9  配置MLD Snooping Proxy功能组网图

配置思路

Switch上配置MLD Snooping Proxy,可以实现此需求。

  1. 创建VLAN,配置接口加入VLAN。

  2. 使能全局和VLAN的MLD Snooping功能,实现用户接收组播数据。

  3. 配置MLD Snooping Proxy,实现MLD报文代理功能,减少Switch和Router之间报文交互。

操作步骤

  1. 创建VLAN,配置接口加入VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type hybrid
    [Switch-GigabitEthernet0/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. 使能MLD Snooping功能。

    # 使能全局的MLD Snooping功能。

    [Switch] mld-snooping enable

    # 使能VLAN10的MLD Snooping功能。

    [Switch] vlan 10
    [Switch-vlan10] mld-snooping enable
    

    # 配置MLD Snooping版本为v2,使设备可以处理所有版本的MLD报文。

    [Switch-vlan10] mld-snooping version 2
    

  3. 使能MLD Snooping Proxy功能。

    [Switch-vlan10] mld-snooping proxy
    [Switch-vlan10] quit

  4. 验证配置结果。

    # 查看Switch上MLD报文统计信息。

    [Switch] display mld-snooping statistics vlan 10
     MLD Snooping Packets Counter                                                   
       Statistics for VLAN 10                                                        
         Recv V1 Report  376                                                        
         Recv V2 Report  0                                                          
         Recv V1 Query   0                                                          
         Recv V2 Query   0                                                          
         Recv Done       2                                                          
         Recv Pim Hello  0                                                          
         Send Query(S=0) 1                                                          
         Send Query(S!=0)0                                                          
         Send General Query          398                                       
         Send Group-Specific Query        0                                         
         Send Group-Source-Specific Query 0                                         

    由显示信息可知,Switch作为Proxy发送了普遍组查询报文,MLD Snooping Proxy功能已生效。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    mld-snooping enable
    #
    vlan 10
     mld-snooping enable
     mld-snooping version 2
     mld-snooping proxy
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141355

浏览量:6895

下载量:31

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页