所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
E600 V200R010C00 配置指南-基础配置

本文档介绍了如何使用命令行接口、如何登录设备,以及文件操作、系统启动等功能的配置。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
通过Commander实现手动替换故障设备示例

通过Commander实现手动替换故障设备示例

组网需求

图2-19所示,在运行EasyDeploy功能的某企业网络中,SwitchA为Commander及DHCP中继,DHCP服务器和文件服务器与SwitchA之间路由可达。

现在网络中有一台设备Client5故障导致其下行业务中断。此时需要用新设备来替换Client5,并快速实现原来Client5的业务功能,将故障影响降至最小。

新Client的MAC地址是0200-0000-0000,在替换过程中还需要下载web_1.web.7z的网页文件。

图2-19  通过Commander实现手动替换故障设备组网图

配置思路

采用以下思路配置设备:
  1. 将web_1.web.7z文件保存至文件服务器。
  2. 在SwitchA上配置故障替换信息,使得新Client能够获取到原故障Client的备份配置文件。
说明:

故障替换功能的实现基于已部署EasyDeploy功能的网络,进行故障替换配置前已完成文件服务器、DHCP以及Commander的配置部署。

操作步骤

  1. 使用故障替换功能,应提前配置自动备份配置文件的功能,以确保新Client能获取到原故障设备的配置文件

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] easy-operation
    [SwitchA-easyoperation] backup configuration interval 72
    

  2. 在SwitchA上配置故障替换信息

    [SwitchA-easyoperation] client 5 replace mac-address 0200-0000-0000
    [SwitchA-easyoperation] client 5 replace web-file web_1.web.7z

  3. 检查配置结果

    # 查看Client替换信息库的信息。

    [SwitchA-easyoperation] display easy-operation client replace
    The total number of replacement information is :  1                             
                                                                                    
    -----------------------------------------------------------                     
      ID      Replaced Mac       Replaced Esn                                         
    -----------------------------------------------------------                     
      5       0200-0000-0000   -                                                    
    ----------------------------------------------------------- 

    # 在故障设备替换流程开始后,可以执行命令display easy-operation client 5查看新Client的状态。

    [SwitchA-easyoperation] display easy-operation client 5    
    ---------------------------------------------------------------------------     
     Client ID                    : 5                                               
     Host name                    : HUAWEI                                       
     Mac address                  : 0200-0000-0000                                  
     ESN                          : 210235182810C3001039                             
     IP address                   : 192.168.1.254                                   
     Model                        : E600 
     Device Type                  : E600 
     System-software file         : flash:/E600.cc
     System-software version      : V200R008C00                                     
     Configuration file           : -
     Patch file                   : -
     WEB file                     : -
     License file                 : -
     System CPU usage             : 55%
     System Memory usage          : 44%
     Backup configuration file    : vrpcfg-0300-0000-0000.zip
     Backup result                : Successful
     Last operation result        : -
     Last operation time          : 0000-00-00  00:00:00
     State                        : UPGRADING
     Aging time left (hours)      : -
    --------------------------------------------------------------------------- 
    # 还可以执行命令display easy-operation download-status查看新Client的下载状态。
    [SwitchA-easyoperation] display easy-operation download-status             
    The total number of client in downloading files is : 1                          
                                                                                    
    ------------------------------------------------------------------------------- 
     ID  Mac address      IP address           Method       Phase        Status     
    ------------------------------------------------------------------------------- 
     5   0200-0000-0000   192.168.1.254        Zero-touch   Web-file     Upgrading  

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20
#
dhcp enable
#
interface Vlanif10
 ip address 192.168.1.6 255.255.255.0
 dhcp select relay
 dhcp relay server-ip 192.168.3.2
#
interface Vlanif20
 ip address 192.168.4.2 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/3
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/4
 port link-type hybrid
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
#                                                                               
ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
#
easy-operation commander ip-address 192.168.1.6 
easy-operation commander enable 
# 
easy-operation
 sftp-server 192.168.2.2 username admin password %^%#=.X8C_TN##%&9P>3RK503O@w-=Fr%>naT#E3P4{0%^%#
 backup configuration interval 72 
 client 5 mac-address 0300-0000-0000
# 
return

SwitchB的配置文件

#
sysname SwitchB
#
vlan batch 30
#
dhcp enable
#
ip pool easy-operation
 gateway-list 192.168.1.6
 network 192.168.1.0 mask 255.255.255.0
 option 148 ascii ipaddr=192.168.1.6;
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
 dhcp select global
#                                                                               
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 30
 port hybrid untagged vlan 30 
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
#
return 
下载文档
更新时间:2018-10-24

文档编号:EDOC1000141359

浏览量:22654

下载量:49

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页