所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R010C00 配置指南-用户接入与认证

本文档介绍了用户接入与认证的相关特性,主要包括AAA、DAA、NAC、PPPoE、策略联动、IP Session。分别从特性原理、配置过程和配置举例等方面进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置对指定网络进行计费示例

配置对指定网络进行计费示例

组网需求

图2-4所示,校园网内802.1X用户通过Switch访问校园网络Network1(192.168.100.0/24)和Network2(10.102.64.0/24)的各种资源。Network1为国内网络资源,Network2为国外网络资源。

此时,可以在Switch上部署DAA功能,对用户访问Network1和Network2的流量分别进行计费,当用户访问Network1时,收取较低费用;当用户访问Network2时,收取较高费用。

图2-4  配置对指定网络进行计费组网图

配置思路

采用如下的思路配置DAA示例:

  1. 创建VLAN并配置接口允许通过的VLAN,保证网络通畅。
  2. 创建并配置RADIUS服务器模板、AAA方案以及域,并在域下绑定RADIUS服务器模板与AAA方案,保证设备与RADIUS服务器之间的信息交互。
  3. 配置802.1X认证,使用户终端能够通过802.1X认证方式接入网络。
  4. 配置DAA,根据用户访问的目的地址进行计费。
    1. 配置流量识别规则,针对两个不同网段,按照用户访问的目的地址的不同对流量进行分类。
    2. 配置流量的费率级别,为去往两个不同网段的流量指定不同的费率级别。其中,去往Network1流量的费率级别为1,去往Network2流量的费率级别为2。
    3. 根据费率级别分别配置流量的计费策略:
      • 对于费率级别1,统计流量并且计费。
      • 对于费率级别2,统计流量并且计费。
说明:

请确保RADIUS服务器模板内的RADIUS服务器的地址、端口号和共享密钥配置正确,并且和RADIUS服务器保持一致。

请确保Switch与RADIUS服务器路由可达,用户与Network1和Network2之间路由可达。

操作步骤

  1. 创建VLAN并配置接口允许通过的VLAN,保证网络通畅。

    # 在Switch上创建VLAN 11。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 11
    

    # 配置Switch连接用户的接口GE1/0/1加入VLAN11。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 11
    [Switch-GigabitEthernet1/0/1] quit

    # 创建VLANIF11,并为VLANIF11配置IP地址192.168.10.1/24。

    [Switch] interface vlanif 11
    [Switch-Vlanif11] ip address 192.168.10.1 24
    [Switch-Vlanif11] quit
    

  2. 配置AAA。

    # 配置RADIUS服务器模板shiva。RADIUS认证服务器的IP地址是10.7.66.66,端口为1812;RADIUS计费服务器的IP地址为10.7.66.66,端口为1813;共享密钥为Huawei@123。

    [Switch] radius-server template shiva
    [Switch-radius-shiva] radius-server authentication 10.7.66.66 1812
    [Switch-radius-shiva] radius-server accounting 10.7.66.66 1813
    [Switch-radius-shiva] radius-server shared-key cipher Huawei@123
    [Switch-radius-shiva] quit

    # 配置认证方案auth,认证模式为RADIUS认证。

    [Switch] aaa
    [Switch-aaa] authentication-scheme auth
    [Switch-aaa-authen-auth] authentication-mode radius
    [Switch-aaa-authen-auth] quit

    # 配置计费方案abc,计费模式为RADIUS计费。

    [Switch-aaa] accounting-scheme abc
    [Switch-aaa-accounting-abc] accounting-mode radius
    [Switch-aaa-accounting-abc] quit
    

    # 配置AAA域huawei,在域下应用认证方案auth、计费方案abc和RADIUS模板shiva。

    [Switch-aaa] domain huawei
    [Switch-aaa-domain-huawei] authentication-scheme auth
    [Switch-aaa-domain-huawei] accounting-scheme abc
    [Switch-aaa-domain-huawei] radius-server shiva
    [Switch-aaa-domain-huawei] quit
    [Switch-aaa] quit
    

    # 配置全局默认域为“huawei”。用户进行接入认证时,以格式“user@huawei”输入用户名即可在huawei域下进行aaa认证。如果用户名中不携带域名或携带的域名不存在,用户将会在默认域中进行认证。

    [Switch] domain huawei

  3. 配置802.1X认证。

    # 将NAC配置模式切换成统一模式。
    说明:

    设备默认为统一模式。传统模式与统一模式相互切换后,设备会自动重启。

    [Switch] authentication unified-mode
    # 配置802.1X接入模板“d1”。
    说明:

    802.1X接入模板默认采用EAP认证方式。请确保RADIUS服务器支持EAP协议,否则无法处理802.1X认证请求。

    [Switch] dot1x-access-profile name d1
    [Switch-dot1x-access-profile-d1] quit

    # 配置认证模板“p1”,并在其上绑定802.1X接入模板“d1”、指定用户接入模式为多用户单独认证接入模式、最大接入用户数为100。

    [Switch] authentication-profile name p1
    [Switch-authen-profile-p1] dot1x-access-profile d1
    [Switch-authen-profile-p1] authentication mode multi-authen max-user 100
    [Switch-authen-profile-p1] quit

    # 在接口GE1/0/1上绑定认证模板“p1”,使能802.1X认证。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] authentication-profile p1
    [Switch-GigabitEthernet1/0/1] quit
    

  4. 配置DAA。

    # 配置流量的识别规则ACL规则3000和ACL规则3001。

    [Switch] acl 3000
    [Switch-acl-adv-3000] rule 1 permit ip destination 192.168.100.0 0.0.0.255
    [Switch-acl-adv-3000] quit
    [Switch] acl 3001
    [Switch-acl-adv-3001] rule 1 permit ip destination 10.102.64.0 0.0.0.255
    [Switch-acl-adv-3001] quit
    

    # 配置流量的费率级别。其中,访问目的网络192.168.100.0/24的流量费率级别为1,访问目的网络10.102.64.00/24的流量费率级别为2。

    [Switch] traffic-group huawei
    [Switch-traffic-group-huawei] acl 3000 tariff-level 1
    [Switch-traffic-group-huawei] acl 3001 tariff-level 2
    [Switch-traffic-group-huawei] quit
    [Switch] traffic-group huawei enable
    

    # 配置流量计费。

    [Switch] qos-profile name huawei
    [Switch-qos-huawei] statistic enable
    [Switch-qos-huawei] quit
    [Switch] aaa
    [Switch-aaa] domain huawei
    [Switch-aaa-domain-huawei] tariff-level 1 qos-profile huawei accounting-on
    [Switch-aaa-domain-huawei] tariff-level 2 qos-profile huawei accounting-on
    [Switch-aaa-domain-huawei] quit
    [Switch-aaa] quit
    [Switch] quit
    

  5. 验证配置结果。

    执行命令display traffic-group name group-name,查看流量组huawei中的信息。

    <Switch> display traffic-group name huawei
      ----------------------------------------------------------------------------
      Acl-id                Tariff-level                             
      ----------------------------------------------------------------------------
      3000                      1                          
      3001                      2                     
      ----------------------------------------------------------------------------
      Total: 2  

    执行命令display traffic-group state,可以查看到流量组的应用状态为“success”。

    <Switch> display traffic-group state
      ----------------------------------------------------------------------------
      Slot-id                        State                        
      ----------------------------------------------------------------------------
      1                              success                 
      ----------------------------------------------------------------------------
      Total: 1 

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 11
#
authentication-profile name p1
 dot1x-access-profile d1
 authentication mode multi-authen max-user 100
#
domain huawei 
#
radius-server template shiva
 radius-server shared-key cipher %^%#4*SO-2u,Q.\1C~%[eiB77N/^2wME;6t%6U@qAJ9:%^%#
 radius-server authentication 10.7.66.66 1812 weight 80
 radius-server accounting 10.7.66.66 1813 weight 80
#
dot1x-access-profile name d1
#
acl number 3000
 rule 1 permit ip destination 192.168.100.0 0.0.0.255
acl number 3001
 rule 1 permit ip destination 10.102.64.0 0.0.0.255
#
qos-profile name huawei
 statistic enable 
#
aaa
 authentication-scheme auth
  authentication-mode radius
 accounting-scheme abc
  accounting-mode radius
 domain huawei
  authentication-scheme auth
  accounting-scheme abc
  radius-server shiva
  tariff-level 1 qos-profile huawei accounting-on
  tariff-level 2 qos-profile huawei accounting-on
#
interface Vlanif11
 ip address 192.168.10.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 11
 authentication-profile p1
#
traffic-group huawei
  acl 3000 tariff-level 1
  acl 3001 tariff-level 2
traffic-group huawei enable
#
return
翻译
下载文档
更新时间:2019-12-28

文档编号:EDOC1000141386

浏览量:20228

下载量:353

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页