所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R010C00 配置指南-用户接入与认证

本文档介绍了用户接入与认证的相关特性,主要包括AAA、DAA、NAC、PPPoE、策略联动、IP Session。分别从特性原理、配置过程和配置举例等方面进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置内网不计费、外网计费示例

配置内网不计费、外网计费示例

组网需求

图2-3所示,校园网内PPPoE用户通过Switch访问校园内网或校园外网的各种资源。内网由学校自主建设,包含有大量的学习资源;外网由学校租用运营商网络,需要按照流量向运营商支付相应费用。

此时,可以在Switch上部署DAA功能,当用户访问内网时,不收取费用;但当用户访问外网时,会按照访问的流量来收取费用。

图2-3  配置内网不计费、外网计费组网图

配置思路

采用如下的思路配置内网不计费、外网计费示例:

  1. 创建VLAN并配置接口允许通过的VLAN,保证网络通畅。
  2. 创建并配置RADIUS服务器模板、AAA方案以及域,并在域下绑定RADIUS服务器模板与AAA方案,保证设备与RADIUS服务器之间的信息交互。
  3. 配置PPPoE认证,使用户终端能够通过PPPoE认证方式接入网络。
  4. 配置DAA,根据用户访问的目的地址进行计费。
    1. 配置流量识别规则,识别出用户访问内网的流量。
    2. 配置流量的费率级别,指定去往内网网段的流量费率级别为1。
    3. 配置流量的计费策略:
      • 对于费率级别1,统计流量但不计费。
      • 对于其他流量信息,设备将流量信息进行统计后发送给RADIUS计费服务器。
说明:

请确保RADIUS服务器模板内的RADIUS服务器的地址、端口号和共享密钥配置正确,并且和RADIUS服务器保持一致。

操作步骤

  1. 创建VLAN并配置接口允许通过的VLAN,保证网络通畅。

    # 在Switch上创建VLAN 11。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 11
    

    # 配置Switch连接用户的接口GE1/0/1加入VLAN11。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 11
    [Switch-GigabitEthernet1/0/1] quit

  2. 配置AAA。

    # 配置RADIUS服务器模板shiva。RADIUS认证服务器的IP地址是10.7.66.66,端口为1812;RADIUS计费服务器的IP地址为10.7.66.66,端口为1813;共享密钥为Huawei@123。

    [Switch] radius-server template shiva
    [Switch-radius-shiva] radius-server authentication 10.7.66.66 1812
    [Switch-radius-shiva] radius-server accounting 10.7.66.66 1813
    [Switch-radius-shiva] radius-server shared-key cipher Huawei@123
    [Switch-radius-shiva] quit

    # 配置认证方案auth,认证模式为RADIUS认证。

    [Switch] aaa
    [Switch-aaa] authentication-scheme auth
    [Switch-aaa-authen-auth] authentication-mode radius
    [Switch-aaa-authen-auth] quit

    # 配置计费方案abc,计费模式为RADIUS计费。

    [Switch-aaa] accounting-scheme abc
    [Switch-aaa-accounting-abc] accounting-mode radius
    [Switch-aaa-accounting-abc] quit
    

    # 配置AAA域huawei,在域下应用认证方案auth、计费方案abc和RADIUS模板shiva。

    [Switch-aaa] domain huawei
    [Switch-aaa-domain-huawei] authentication-scheme auth
    [Switch-aaa-domain-huawei] accounting-scheme abc
    [Switch-aaa-domain-huawei] radius-server shiva
    [Switch-aaa-domain-huawei] quit
    [Switch-aaa] quit
    

  3. 配置PPPoE。

    # 配置设备作为PPPoE Server为主机动态分配IP地址。

    [Switch] ip pool test
    [Switch-ip-pool-test] network 192.168.10.0 mask 255.255.255.0 
    [Switch-ip-pool-test] gateway-list 192.168.10.1
    [Switch-ip-pool-test] quit
    [Switch] aaa
    [Switch-aaa] service-scheme test
    [Switch-aaa-service-test] ip-pool test
    [Switch-aaa-service-test] quit
    [Switch-aaa] domain huawei
    [Switch-aaa-domain-huawei] service-scheme test 
    [Switch-aaa-domain-huawei] quit
    [Switch-aaa] quit
    

    # 创建虚拟接口模板1,采用缺省PPPoE配置。

    [Switch] interface virtual-template 1
    [Switch-Virtual-Template1] ip address 192.168.10.1 24
    [Switch-Virtual-Template1] quit
    

    # 在VLANIF11接口下绑定虚拟接口模板。

    [Switch] interface vlanif 11
    [Switch-Vlanif11] pppoe-server bind virtual-template 1
    [Switch-Vlanif11] quit
    

  4. 配置DAA。

    # 配置流量的识别规则ACL 3000,对用户访问内网的流量进行识别,假设内网网段为192.168.100.0/24。

    [Switch] acl 3000
    [Switch-acl-adv-3000] rule 1 permit ip destination 192.168.100.0 0.0.0.255
    [Switch-acl-adv-3000] quit
    

    # 配置流量的费率级别为1。

    [Switch] traffic-group huawei
    [Switch-traffic-group-huawei] acl 3000 tariff-level 1
    [Switch-traffic-group-huawei] quit
    

    # 全局应用流量组。

    说明:

    如果用户对流量识别规则中的源地址或目的地址,流量组里流量的费率级别进行了更改,则只有重新执行命令traffic-group group-name enable,修改后的配置才会生效。

    [Switch] traffic-group huawei enable

    # 配置对除了匹配ACL 3000的所有流量进行计费。

    [Switch] qos-profile name huawei
    [Switch-qos-huawei] statistic enable
    [Switch-qos-huawei] quit
    [Switch] aaa
    [Switch-aaa] domain huawei
    [Switch-aaa-domain-huawei] tariff-level 1 qos-profile huawei
    [Switch-aaa-domain-huawei] statistic enable
    [Switch-aaa-domain-huawei] quit
    [Switch-aaa] quit
    [Switch] quit
    

  5. 验证配置结果。

    # 执行命令display traffic-group name group-name,查看流量组huawei中的信息。

    <Switch> display traffic-group name huawei
      ----------------------------------------------------------------------------
      Acl-id                Tariff-level                             
      ----------------------------------------------------------------------------
      3000                      1                          
      ----------------------------------------------------------------------------
      Total: 1  

    # 执行命令display traffic-group state,可以查看到流量组的应用状态为“success”。

    <Switch> display traffic-group state
      ----------------------------------------------------------------------------
      Slot-id                        State                        
      ----------------------------------------------------------------------------
      10                             success                 
      ----------------------------------------------------------------------------
      Total: 1 

    当用户成功上线后,可以通过display access-user命令查看不同费率级别对应的流量统计信息。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 11
#
radius-server template shiva
 radius-server shared-key cipher %^%#Q75cNQ6IF(e#L4WMxP~%^7'u17,]D87GO{"[o]`D%^%#
 radius-server authentication 10.7.66.66 1812 weight 80
 radius-server accounting 10.7.66.66 1813 weight 80
#
acl number 3000
 rule 1 permit ip destination 192.168.100.0 0.0.0.255
#
qos-profile name huawei
 statistic enable 
#
ip pool test
 gateway-list 192.168.10.1  
 network 192.168.10.0 mask 255.255.255.0  
#
aaa
 authentication-scheme auth
  authentication-mode radius
 accounting-scheme abc
  accounting-mode radius
 service-scheme test
  ip-pool test 
 domain huawei
  authentication-scheme auth
  accounting-scheme abc
  service-scheme test 
  radius-server shiva
  tariff-level 1 qos-profile huawei  
  statistic enable 
#
interface Vlanif11
 pppoe-server bind virtual-template 1
#
interface Virtual-Template1
 ip address 192.168.10.1 255.255.255.0 
# 
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 11
#
traffic-group huawei
  acl 3000 tariff-level 1
traffic-group huawei enable
#
return
翻译
下载文档
更新时间:2019-12-28

文档编号:EDOC1000141386

浏览量:20351

下载量:353

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页