所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S12700 V200R010C00 配置指南-用户接入与认证

本文档介绍了用户接入与认证的相关特性,主要包括AAA、DAA、NAC、PPPoE、策略联动、IP Session。分别从特性原理、配置过程和配置举例等方面进行介绍。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IP Session功能示例

配置IP Session功能示例

组网需求

图3-2所示,STB-A(数字机顶盒)与Switch的GE1/0/1.100相连,STB-B与Switch的GE1/0/2.100相连。

用户要求STB-A及STB-B开机即可以上线。

图3-2  IPTV组网图

配置思路

在Switch上进行IP Session配置,配置用户认证域与子接口绑定,实现STB-A及STB-B开机用户即可以上线。

说明:

本例只涉及IP Session相关配置,AAA配置、Radius配置、组播相关配置及Router相关配置在本例中不体现。

操作步骤

  1. 使能全局DHCP功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] dhcp enable

  2. 使能子接口的IP Session功能

    # 使能子接口GE1/0/1.100的IP Session功能。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/1.100
    [Switch-GigabitEthernet1/0/1.100] ip-session enable
    [Switch-GigabitEthernet1/0/1.100] quit

    # 使能子接口GE1/0/2.100的IP Session功能。

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/2.100
    [Switch-GigabitEthernet1/0/2.100] ip-session enable
    [Switch-GigabitEthernet1/0/2.100] quit

  3. 配置用户认证域与子接口绑定

    # 配置用户认证域stb-a与子接口GE1/0/1.100绑定。

    [Switch] aaa
    [Switch-aaa] domain stb-a
    [Switch-aaa-domain-stb-a] quit
    [Switch-aaa] quit
    [Switch] interface gigabitethernet 1/0/1.100
    [Switch-GigabitEthernet1/0/1.100] authentication-domain stb-a
    [Switch-GigabitEthernet1/0/1.100] quit

    # 配置用户认证域stb-b与子接口GE1/0/2.100绑定。

    [Switch] aaa
    [Switch-aaa] domain stb-b
    [Switch-aaa-domain-stb-b] quit
    [Switch-aaa] quit
    [Switch] interface gigabitethernet 1/0/2.100
    [Switch-GigabitEthernet1/0/2.100] authentication-domain stb-b
    [Switch-GigabitEthernet1/0/2.100] quit

  4. 在Switch上配置子接口相关参数

    # 配置子接口GE1/0/1.100的探测时间间隔为60秒,探测超时次数8次。

    [Switch] interface gigabitethernet 1/0/1.100
    [Switch-GigabitEthernet1/0/1.100] dot1q termination vid 100
    [Switch-GigabitEthernet1/0/1.100] dhcp user-detect retransmit 8 interval 60
    [Switch-GigabitEthernet1/0/1.100] quit

    # 配置子接口GE1/0/2.100的探测时间间隔为60秒,探测超时次数8次。

    [Switch] interface gigabitethernet 1/0/2.100
    [Switch-GigabitEthernet1/0/2.100] dot1q termination vid 100
    [Switch-GigabitEthernet1/0/2.100] dhcp user-detect retransmit 8 interval 60
    [Switch-GigabitEthernet1/0/2.100] quit

  5. 配置dhcp用户名组装方式为“mac-address”及密文密码“huawei@123”

    [Switch] dhcp user-name format-include mac-address
    [Switch] dhcp user-password cipher huawei@123

  6. 配置DHCP服务器组

    [Switch] dhcp server group dhcp-group
    [Switch-dhcp-server-group-dhcp-group] dhcp-server 10.10.10.10
    [Switch-dhcp-server-group-dhcp-group] gateway 10.20.20.20 
    [Switch-dhcp-server-group-dhcp-group] quit

  7. 配置出口网关

    [Switch] interface loopback 0
    [Switch-LoopBack0] ip address 10.20.20.20 32
    [Switch-LoopBack0] quit

  8. 配置静态路由

    [Switch] ip route-static 10.10.10.0 255.255.255.0 NULL 0
    [Switch] quit

  9. 验证配置结果

    # 查看子接口GE1/0/1.100下IP Session的配置。

    <Switch> display session-interface gigabitethernet 1/0/1.100
    
      Access type                            : Enable
      IPSessIF state                         : Updated
      Authentication default domain          : stb-a
      Nas port type                          : ethernet (15)
      Vpn Instance                           :
      User detect interval                   : 60 (s)
      User detect retransmit times           : 8
      Option82 policy                        : none (0)
      Service policy                         : default (0)

    # 查看子接口GE 1/0/2.100下IP Session的配置。

    <Switch> display session-interface gigabitethernet 1/0/2.100
    
      Access type                            : Enable
      IPSessIF state                         : Updated
      Authentication default domain          : stb-b
      Nas port type                          : ethernet (15)
      Vpn Instance                           :
      User detect interval                   : 60 (s)
      User detect retransmit times           : 8
      Option82 policy                        : none (0)
      Service policy                         : default (0)

配置文件

Switch的配置文件

#
sysname Switch
#
dhcp enable
#
dhcp user-name format-include mac-address
dhcp user-password cipher %^%#Ev7YUOKM=60]3g9h`+s1hG:V$iZ$`-V&aKWdFaY!%^%#
#
dhcp server group dhcp-group
 dhcp-server 10.10.10.10 0
 gateway 10.20.20.20
#
aaa
 domain stb-a
 domain stb-b
#
interface GigabitEthernet1/0/1                                                  
 port link-type hybrid                                                          
#
interface GigabitEthernet1/0/1.100
 dot1q termination vid 100
 ip-session enable
 authentication-domain stb-a
 dhcp user-detect retransmit 8 interval 60
#
interface GigabitEthernet1/0/2                                                  
 port link-type hybrid                                                          
#
interface GigabitEthernet1/0/2.100
 dot1q termination vid 100
 ip-session enable
 authentication-domain stb-b
 dhcp user-detect retransmit 8 interval 60
#
interface LoopBack0
 ip address 10.20.20.20 255.255.255.255
#
ip route-static 10.10.10.0 255.255.255.0 NULL0
#
return
翻译
下载文档
更新时间:2019-12-28

文档编号:EDOC1000141386

浏览量:20674

下载量:353

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页