所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4静态路由示例

配置IPv4静态路由示例

组网需求

图1所示,属于不同网段的主机通过几台Switch相连,要求不配置动态路由协议,使不同网段的任意两台主机之间能够互通。

图3-6  配置IP静态路由组网图

配置思路

采用如下的思路配置IPv4静态路由:

  1. 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址,实现相邻设备网络互通。
  2. 在各主机上配置IP缺省网关,在各台Switch上配置IPv4静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 30
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.4.1 30
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.1.1.1 24
    [SwitchA-Vlanif30] quit

  3. 配置主机

    配置主机PC1的缺省网关为10.1.1.1,主机PC2的缺省网关为10.1.2.1,主机PC3的缺省网关为10.1.3.1。

  4. 配置静态路由

    # 在SwitchA配置IP缺省路由。

    [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.1.4.2

    # 在SwitchB配置两条IP静态路由。

    [SwitchB] ip route-static 10.1.1.0 255.255.255.0 10.1.4.1
    [SwitchB] ip route-static 10.1.3.0 255.255.255.0 10.1.4.6

    # 在SwitchC配置IP缺省路由。

    [SwitchC] ip route-static 0.0.0.0 0.0.0.0 10.1.4.5

  5. 验证配置结果

    #查看SwitchA的IP路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
     
    Destination/Mask    Proto  Pre  Cost   Flags   NextHop      Interface
     
            0.0.0.0/0    Static 60   0        RD    10.1.4.2     Vlanif10
            10.1.1.0/24  Direct 0    0         D    10.1.1.1     Vlanif30
            10.1.1.1/32  Direct 0    0         D    127.0.0.1    Vlanif30
            10.1.4.0/30  Direct 0    0         D    10.1.4.1     Vlanif10
            10.1.4.1/32  Direct 0    0         D    127.0.0.1    Vlanif10
          127.0.0.0/8    Direct 0    0         D    127.0.0.1    InLoopBack0
          127.0.0.1/32   Direct 0    0         D    127.0.0.1    InLoopBack0
    

    # 使用ping命令验证连通性。

    [SwitchA] ping 10.1.3.1
      PING 10.1.3.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.3.1: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 10.1.3.1: bytes=56 Sequence=2 ttl=253 time=63 ms
        Reply from 10.1.3.1: bytes=56 Sequence=3 ttl=253 time=63 ms
        Reply from 10.1.3.1: bytes=56 Sequence=4 ttl=253 time=62 ms
        Reply from 10.1.3.1: bytes=56 Sequence=5 ttl=253 time=62 ms
    
      --- 10.1.3.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 62/62/63 ms

    # 使用Tracert命令验证连通性。

    [SwitchA] tracert 10.1.3.1
     traceroute to  10.1.3.1(10.1.3.1), max hops: 30 ,packet length: 40,press CTRL_C to break
     1 10.1.4.2 31 ms  32 ms  31 ms
     2 10.1.3.1 62 ms  63 ms  62 ms

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 10.1.4.1 255.255.255.252
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 30
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.4.2
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20 40
    #
    interface Vlanif10
     ip address 10.1.4.2 255.255.255.252
    #
    interface Vlanif20
     ip address 10.1.4.5 255.255.255.252
    #
    interface Vlanif40
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 40
    #
    ip route-static 10.1.1.0 255.255.255.0 10.1.4.1
    ip route-static 10.1.3.0 255.255.255.0 10.1.4.6
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 50
    #
    interface Vlanif20
     ip address 10.1.4.6 255.255.255.252
    #
    interface Vlanif50
     ip address 10.1.3.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 50
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.4.5
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:27245

下载量:1381

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页