所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置BGP与BFD联动功能示例

配置BGP与BFD联动功能示例

组网需求

图1所示,SwitchA属于AS100,SwitchB和SwitchC属于AS200,SwitchA和SwitchB,SwitchA和SwitchC建立非直连EBGP连接。业务流量在主链路SwitchA→SwitchB上传送,链路SwitchA→SwitchC→SwitchB作为备份链路。要求实现故障的快速感知,从而使得流量从主链路快速切换至备份链路转发。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图10-29  配置BFD for BGP组网图

配置思路

采用如下思路配置BFD for BGP功能:

  1. 在各Switch上配置BGP基本功能。

  2. 配置MED属性控制路由的选路功能。

  3. SwitchA和SwitchB上使能BFD检测机制。

说明:

如果两个交换机使用直连链路建立EBGP邻居,则无需配置BGP与BFD联动功能,因为BGP已经缺省配置了ebgp-interface-sensitive命令快速感知链路故障。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.2.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. 配置BGP基本功能,在SwitchA和SwitchB,SwitchA和SwitchC之间建立EBGP连接, SwitchB和SwitchC之间建立IBGP连接。

    # 配置SwitchA。

    [SwitchA] bgp 100
    [SwitchA-bgp] router-id 172.17.1.1
    [SwitchA-bgp] peer 192.168.1.2 as-number 200
    [SwitchA-bgp] peer 192.168.1.2 ebgp-max-hop
    [SwitchA-bgp] peer 192.168.2.2 as-number 200
    [SwitchA-bgp] peer 192.168.2.2 ebgp-max-hop
    [SwitchA-bgp] quit

    # 配置SwitchB。

    [SwitchB] bgp 200
    [SwitchB-bgp] router-id 172.17.2.2
    [SwitchB-bgp] peer 192.168.1.1 as-number 100
    [SwitchB-bgp] peer 192.168.1.1 ebgp-max-hop
    [SwitchB-bgp] peer 10.1.1.2 as-number 200
    [SwitchB-bgp] network 172.16.1.0 255.255.255.0
    [SwitchB-bgp] quit

    # 配置SwitchC。

    [SwitchC] bgp 200
    [SwitchC-bgp] router-id 172.17.3.3
    [SwitchC-bgp] peer 192.168.2.1 as-number 100
    [SwitchC-bgp] peer 192.168.2.1 ebgp-max-hop
    [SwitchC-bgp] peer 10.1.1.1 as-number 200
    [SwitchC-bgp] import-route direct
    [SwitchC-bgp] quit

    # 在SwitchA上查看,BGP邻居已经建立(Established)。

    [SwitchA] display bgp peer
     BGP local router ID : 172.17.1.1
     Local AS number : 100
     Total number of peers : 2                 Peers in established state : 2
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down         State PrefRcv
    
      192.168.1.2     4   200        2        5     0 00:01:25 Established       0
      192.168.2.2     4   200        2        4     0 00:00:55 Established       0

  4. 配置MED属性

    通过策略配置SwitchB和SwitchC送给SwitchA的MED值。

    # 配置SwitchB。

    [SwitchB] route-policy 10 permit node 10
    [SwitchB-route-policy] apply cost 100
    [SwitchB-route-policy] quit
    [SwitchB] bgp 200
    [SwitchB-bgp] peer 192.168.1.1 route-policy 10 export
    [SwitchB-bgp] quit

    # 配置SwitchC。

    [SwitchC] route-policy 10 permit node 10
    [SwitchC-route-policy] apply cost 150
    [SwitchC-route-policy] quit
    [SwitchC] bgp 200
    [SwitchC-bgp] peer 192.168.2.1 route-policy 10 export
    [SwitchC-bgp] quit

    # 查看SwitchA上BGP的所有路由信息。

    [SwitchA] display bgp routing-table
    
     BGP Local router ID is 172.17.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     Total Number of Routes: 5
    
         Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>  10.1.1.0/24        192.168.2.2     150                   0      200?
     *>  172.16.1.0/24      192.168.1.2     100                   0      200i
     *                      192.168.2.2     150                   0      200i
     *>  192.168.2.0        192.168.1.2     100                   0      200?
                            192.168.2.2     150                   0      200?

    从BGP路由表可以看出,去往172.16.1.0/24的路由下一跳地址为192.168.1.2,流量在主链路SwitchA、SwitchB上传输。

  5. 配置BFD检测功能、发送和接收间隔、本地检测时间倍数。

    # 在SwitchA上使能BFD功能,并指定最小发送和接收间隔为100ms,本地检测时间倍数为4。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bgp 100
    [SwitchA-bgp] peer 192.168.1.2 bfd enable
    [SwitchA-bgp] peer 192.168.1.2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [SwitchA-bgp] quit

    # 在SwitchB上使能BFD功能,并指定最小发送和接收间隔为100ms,本地检测时间倍数为4。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bgp 200
    [SwitchB-bgp] peer 192.168.1.1 bfd enable
    [SwitchB-bgp] peer 192.168.1.1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [SwitchB-bgp] quit

    # 在SwitchA上显示BGP建立的所有BFD会话。

    [SwitchA] display bgp bfd session all
      Local_Address      Peer_Address       LD/RD       Interface
      192.168.1.1        192.168.1.2        8201/8201   Vlanif20
      Tx-interval(ms)    Rx-interval(ms)    Multiplier  Session-State
      100                100                4           Up
      Wtr-interval(m)
      0

  6. 查看配置结果

    # 对SwitchB的VLANIF20接口执行shutdown命令,模拟主链路故障。

    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] shutdown

    # 在交换机SwitchA上,查看bgp路由表

    [SwitchA] display bgp routing-table
    
     BGP Local router ID is 172.17.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
     Total Number of Routes: 3
    
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
     *>  10.1.1.0/24         192.168.2.2     150                   0      200?
     *>  172.16.1.0/24       192.168.2.2     150                   0      200i       
         192.168.2.0         192.168.2.2     150                   0      200?

    从BGP路由表可以看出,在主链路失效后,备份链路SwitchA→SwitchC→SwitchB生效,去往172.16.1.0/24的路由下一跳地址为192.168.2.2。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 100
     router-id 172.17.1.1
     peer 192.168.1.2 as-number 200
     peer 192.168.1.2 ebgp-max-hop 255
     peer 192.168.1.2 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 192.168.1.2 bfd enable
     peer 192.168.2.2 as-number 200
     peer 192.168.2.2 ebgp-max-hop 255
     #
     ipv4-family unicast
      undo synchronization
      peer 192.168.1.2 enable
      peer 192.168.2.2 enable
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 30 40
    #
    bfd
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    bgp 200
     router-id 172.17.2.2
     peer 10.1.1.2 as-number 200
     peer 192.168.1.1 as-number 100
     peer 192.168.1.1 ebgp-max-hop 255
     peer 192.168.1.1 bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
     peer 192.168.1.1 bfd enable
     #
     ipv4-family unicast
      undo synchronization
      network 172.16.1.0 255.255.255.0
      peer 10.1.1.2 enable
      peer 192.168.1.1 enable
      peer 192.168.1.1 route-policy 10 export
    #
    route-policy 10 permit node 10
     apply cost 100
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 30
    #
    bfd
    #
    interface Vlanif10
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 200
     router-id 172.17.3.3
     peer 10.1.1.1 as-number 200
     peer 192.168.2.1 as-number 100
     peer 192.168.2.1 ebgp-max-hop 255
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.1 enable
      peer 192.168.2.1 enable
      peer 192.168.2.1 route-policy 10 export
    #
    route-policy 10 permit node 10
     apply cost 150
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:23200

下载量:1351

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页