所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态BFD for IS-IS特性示例

配置静态BFD for IS-IS特性示例

组网需求

图1所示,现网中有三台交换机通过IS-IS协议实现路由互通,且SwitchA与SwitchB之间通过一台二层交换机实现互连。现要求当SwitchA与SwitchB之间出现链路故障时,这两台交换机能快速对故障结果做出反应,重新建立邻居关系。

图8-38  配置静态BFD for IS-IS组网图

说明:

由于SwitchA和SwitchC之间不建立IS-IS邻居,所以BFD for IS-IS特性不能用于检测SwitchA到SwitchC的多跳链路。

配置思路

采用如下思路配置IS-IS与静态BFD联动:

  1. 配置各交换机的接口IP地址以及IS-IS路由协议,实现交换机之间路由可达。

  2. 在SwitchA和SwitchB上配置IS-IS与静态BFD联动,使得设备可以快速感知故障的状态变化。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchSwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置各交换机VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置IS-IS基本功能

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-2
    [SwitchA-isis-1] network-entity aa.1111.1111.1111.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] is-level level-2
    [SwitchB-isis-1] network-entity aa.2222.2222.2222.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis enable 1
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] isis enable 1
    [SwitchB-Vlanif30] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] is-level level-2
    [SwitchC-isis-1] network-entity aa.3333.3333.3333.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] isis enable 1
    [SwitchC-Vlanif30] quit

    配置完成后,可以看到SwitchA与SwitchB建立了邻居关系。

    [SwitchA] display isis peer
    
                              Peer information for ISIS(1)
    
      System Id     Interface          Circuit Id       State HoldTime Type     PRI
    -------------------------------------------------------------------------------
    2222.2222.2222 Vlanif10          1111.1111.1111.01 Up   23s      L2       64
    
    Total Peer(s): 1

    SwitchA的IS-IS路由表中有去往SwitchB和SwitchC的表项。

    [SwitchA] display isis route
    
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
    
     IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------------
     10.2.1.0/24         20        NULL    Vlanif10         10.1.1.2     A/-/L/-
     10.1.1.0/24         10        NULL    Vlanif10         Direct       D/-/L/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    

  4. 配置BFD

    # 在SwitchA上使能BFD,并配置BFD Session。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip 10.1.1.2 interface vlanif 10
    [SwitchA-bfd-session-atob] discriminator local 1
    [SwitchA-bfd-session-atob] discriminator remote 2
    [SwitchA-bfd-session-atob] commit
    [SwitchA-bfd-session-atob] quit

    # 在SwitchB上使能BFD,并配置BFD Session。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd btoa bind peer-ip 10.1.1.1 interface vlanif 10
    [SwitchB-bfd-session-btoa] discriminator local 2
    [SwitchB-bfd-session-btoa] discriminator remote 1
    [SwitchB-bfd-session-btoa] commit
    [SwitchB-bfd-session-btoa] quit

    配置完成后,在SwitchA或SwitchB上执行display bfd session all命令,可以看到BFD Session的状态为Up。

    SwitchA的显示为例。

    [SwitchA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName
    --------------------------------------------------------------------------------
    1     2     10.1.1.2         Up      S_IP_IF      Vlanif10          
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

  5. 使能IS-IS的快速感知特性

    # 配置SwitchA。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis bfd static
    [SwitchA-Vlanif10] quit

    # 配置SwitchB。

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis bfd static
    [SwitchB-Vlanif10] quit

  6. 检查配置结果

    # 在SwitchA上打开调试信息开关,使信息输出到VTY通道。

    [SwitchA] info-center source bfd channel 1 log level debugging state on
    [SwitchA] quit
    <SwitchA> debugging isis circuit-information
    <SwitchA> terminal debugging
    <SwitchA> terminal logging
    <SwitchA> terminal monitor

    # 对SwitchB的GigabitEthernet0/0/1接口执行shutdown命令,模拟链路故障。

    [SwitchB]interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] shutdown

    # 在SwitchA上可以看到以下日志信息和调试信息,表明IS-IS根据BFD报告的故障删除了与SwitchB的邻居关系。

    May 19 2013 09:34:49+08:00 SwitchB %%01ISIS/4/PEER_DOWN_BFDDOWN(l)[2]:ISIS 1 ne
    ighbor 2222.2222.2222 was Down on interface Vlanif2710 because the BFD node was d
    own. 
     The Hello packet was received at 09:29:39 last time; the maximum interval for se
     nding Hello packets was 8944; the local router sent 392 Hello packets and receiv
     ed 2 packets; the type of the Hello packet was Lan Level-2.

    SwitchA上执行display isis routedisplay isis peer命令,不显示任何信息,SwitchA与SwitchB之间的IS-IS邻居关系已经拆除。

    # 检查配置结果完成以后,在SwitchA上关闭调试信息开关。

    <SwitchA> undo debugging isis circuit-information
    <SwitchA> undo terminal debugging
    <SwitchA> undo terminal logging
    <SwitchA> undo terminal monitor

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    info-center source BFD channel 1 log level debugging
    #
    vlan batch 10
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.1111.1111.1111.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    bfd atob bind peer-ip 10.1.1.2 interface Vlanif10
     discriminator local 1
     discriminator remote 2
     commit
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 30
    #
    bfd
    #
    isis 1
     is-level level-2
     network-entity aa.2222.2222.2222.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface Vlanif30
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    bfd btoa bind peer-ip 10.1.1.1 interface Vlanif10
     discriminator local 2
     discriminator remote 1
     commit
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30
    #
    isis 1
     is-level level-2
     network-entity aa.3333.3333.3333.00
    #
    interface Vlanif30
     ip address 10.2.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:26700

下载量:1373

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页