所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RIP基本功能示例

配置RIP基本功能示例

组网需求

图1所示,在小型网络中有4台交换机,要求在SwitchA、SwitchB、SwitchC和SwitchD上实现网络互连。

图4-11  配置RIP基本功能组网图

配置思路

由于要在小型网络中实现设备的网络互连,所以推荐配置RIP-2路由协议。

  1. 配置各接口所属VLAN和IP地址,使网络可达。

  2. 在各交换机上使能RIP,基本实现网络互连。

  3. 在各交换机上配置RIP-2版本,提升RIP路由扩展性能。

操作步骤

  1. 配置各接口所属的VLAN。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置各VLANIF接口的IP地址。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置RIP基本功能

    # 配置SwitchA。

    [SwitchA] rip
    [SwitchA-rip-1] network 192.168.1.0
    [SwitchA-rip-1] quit

    # 配置SwitchB。

    [SwitchB] rip
    [SwitchB-rip-1] network 192.168.1.0
    [SwitchB-rip-1] network 172.16.0.0
    [SwitchB-rip-1] network 10.0.0.0
    [SwitchB-rip-1] quit

    # 配置SwitchC。

    [SwitchC] rip
    [SwitchC-rip-1] network 172.16.0.0
    [SwitchC-rip-1] quit

    # 配置SwitchD。

    [SwitchD] rip
    [SwitchD-rip-1] network 10.0.0.0
    [SwitchD-rip-1] quit

    # 查看SwitchA的RIP路由表。

    [SwitchA] display rip 1 route
     Route Flags : R - RIP 
                  A - Aging, G - Garbage-collect
    ----------------------------------------------------------------------------
     Peer 192.168.1.2  on Vlanif10
          Destination/Mask        Nexthop     Cost   Tag     Flags   Sec
           172.16.0.0/16       192.168.1.2      1    0        RA      14
             10.0.0.0/8        192.168.1.2      1    0        RA      14

    从路由表中可以看出,RIP-1发布的路由使用的是自然掩码。

  4. 配置RIP的版本号

    # 在SwitchA上配置RIP-2。

    [SwitchA] rip
    [SwitchA-rip-1] version 2
    [SwitchA-rip-1] quit

    # 在SwitchB上配置RIP-2。

    [SwitchB] rip
    [SwitchB-rip-1] version 2
    [SwitchB-rip-1] quit

    # 在SwitchC上配置RIP-2。

    [SwitchC] rip
    [SwitchC-rip-1] version 2
    [SwitchC-rip-1] quit

    # 在SwitchD上配置RIP-2。

    [SwitchD] rip
    [SwitchD-rip-1] version 2
    [SwitchD-rip-1] quit

  5. 验证配置结果

    # 查看SwitchA的RIP路由表。

    [SwitchA] display rip 1 route
    Route Flags : R - RIP
                 A - Aging, G - Garbage-collect 
    ----------------------------------------------------------------------------
     Peer 192.168.1.2  on Vlanif10
          Destination/Mask        Nexthop       Cost   Tag     Flags   Sec
           172.16.1.0/24         192.168.1.2      1    0        RA      32
             10.1.1.0/24         192.168.1.2      1    0        RA      32
    

    从路由表中可以看出,RIP-2发布的路由中带有更为精确的子网掩码信息。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 1
     version 2
     network 192.168.1.0
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20 30
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 172.16.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    rip 1
     version 2
     network 192.168.1.0
     network 172.16.0.0
     network 10.0.0.0
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 172.16.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1
     version 2
     network 172.16.0.0
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30
    #
    interface Vlanif30
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    rip 1
     version 2
     network 10.0.0.0
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:21957

下载量:1340

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页