所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4静态路由与NQA联动示例

配置IPv4静态路由与NQA联动示例

组网需求

图1所示为某公司网络,接入层设备SwitchD和SwtichE通过静态路由与汇聚层设备SwtichB和SwitchC互联,网络设计成冗余备份结构。用户希望实现如下需求:
  • 为静态路由部署检测机制,使静态路由能够感知到链路故障,保证在链路出现故障时能及时进行链路切换,避免造成业务较长时间中断;
  • 正常情况下,要求业务流量使用主用链路SwitchB→SwitchD进行传输;
  • 当主用链路出现故障后,业务流量切换到备用链路SwitchC→SwitchD。
说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图3-10  IPv4静态路由与NQA联动组网图

设备名称

接口

IP地址

SwitchA

VLANIF 30

192.168.3.1/24

VLANIF 40

192.168.4.1/24

SwitchB

VLANIF 30

192.168.3.2/24

VLANIF 50

192.168.5.1/24

VLANIF 10

192.168.1.1/24

SwitchC

VLANIF 40

192.168.4.2/24

VLANIF 60

192.168.6.1/24

VLANIF 20

192.168.2.1/24

SwitchD

VLANIF 10

192.168.1.2/24

VLANIF 60

192.168.6.2/24

VLANIF 70

192.168.7.1/24

SwitchE

VLANIF 20

192.168.2.2/24

VLANIF 50

192.168.5.2/24

VLANIF 80

192.168.8.1/24

配置思路

  1. 创建ICMP类型的NQA测试例,用来检测主用链路的故障。

    在NQA测试例客户端SwitchB与被测试设备SwitchD之间建立ICMP类型的NQA测试例,检测主用链路SwitchB→SwitchD是否正常。

  2. 配置静态路由,并绑定NQA测试例。

    在汇聚层交换机SwitchB和SwitchC上配置静态路由,其中在SwitchB上配置静态路由与NQA联动,当NQA测试例检测到链路故障时,通知路由管理模块把静态路由从IP路由表中删除。

  3. 配置动态路由协议。在汇聚层交换机SwitchA、SwitchB和SwitchC上配置动态路由协议,使他们之间可以相互学习路由。

  4. OSPF协议引入静态路由,并为主用链路设置较低的开销值,实现主备两条链路冗余备份。

    在汇聚层交换机SwitchB和SwitchC上配置OSPF协议引入静态路由,并且为SwitchC引入的静态路由设置较高的开销值。SwitchA从SwitchB和SwitchC学习到通往同一目的地址的路由时,会优先选择开销值较低的链路SwitchB→SwitchD。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 30 40
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 40
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA类似。

    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 192.168.3.1 24
    [SwitchA-Vlanif30] quit
    [SwitchA] interface vlanif 40
    [SwitchA-Vlanif40] ip address 192.168.4.1 24
    [SwitchA-Vlanif40] quit

  3. SwitchB上配置SwitchB和SwitchD之间的NQA测试例

    [SwitchB] nqa test-instance user test
    [SwitchB-nqa-user-test] test-type icmp
    [SwitchB-nqa-user-test] destination-address ipv4 192.168.1.2
    [SwitchB-nqa-user-test] frequency 20
    [SwitchB-nqa-user-test] probe-count 2
    [SwitchB-nqa-user-test] interval seconds 5
    [SwitchB-nqa-user-test] timeout 4
    [SwitchB-nqa-user-test] start now
    [SwitchB-nqa-user-test] quit
    

  4. 配置静态路由

    # 在SwitchB上配置与NQA测试例联动的静态路由。

    [SwitchB] ip route-static 192.168.7.0 255.255.255.0 Vlanif 10 192.168.1.2 track nqa user test

    # 在SwitchC上配置静态路由。

    [SwitchC] ip route-static 192.168.7.0 255.255.255.0 Vlanif 60 192.168.6.2

  5. SwitchA、SwitchB和SwitchC上配置动态路由协议。本例选择OSPF动态路由协议。

    # 在SwitchA上配置OSPF协议。

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    

    # 在SwitchB上配置OSPF协议。

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit
    

    # 在SwitchC上配置OSPF协议。

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit
    

  6. SwitchB和SwitchC上配置OSPF动态路由协议引入静态路由

    # 在SwitchB上配置OSPF动态路由协议引入静态路由,并且把路由开销值设置为10。

    [SwitchB] ospf 1
    [SwitchB-ospf-1] import-route static cost 10
    [SwitchB-ospf-1] quit
    

    # 在SwitchC上配置OSPF动态路由协议引入静态路由,并且把路由开销值设置为20。

    [SwitchC] ospf 1
    [SwitchC-ospf-1] import-route static cost 20
    [SwitchC-ospf-1] quit
    

  7. 查看配置结果

    配置完成后,在系统视图下,在汇聚层交换机SwitchB上执行display current-configuration | include nqa命令,可以看到静态路由已经绑定NQA测试例。执行display nqa results命令,可以看到NQA测试例已经建立。

    # 查看NQA for静态路由的配置。

    [SwitchB] display current-configuration | include nqa
    ip route-static 192.168.7.0 255.255.255.0 Vlanif10 192.168.1.2 track nqa user test
    nqa test-instance user test
    

    # 查看NQA测试结果。

    [SwitchB] display nqa results test-instance user test
    
     NQA entry(user, test) :testflag is active ,testtype is icmp 
      1 . Test 288 result   The test is finished
       Send operation times: 2              Receive response times: 2          
       Completion:success                RTD OverThresholds number: 0       
       Attempts number:1                    Drop operation number:0            
       Disconnect operation number:0        Operation timeout number:0         
       System busy operation number:0       Connection fail number:0           
       Operation sequence errors number:0   RTT Status errors number:0         
       Destination ip address:192.168.1.2                                    
       Min/Max/Average Completion Time: 3/4/3                                
       Sum/Square-Sum  Completion Time: 7/25                                 
       Last Good Probe Time: 2014-09-09 09:55:38.2                           
       Lost packet ratio: 0 %
    

    可以看到“Lost packet ratio: 0 %”,这说明链路状态完好。

    # 查看SwitchB的路由表,可以看到静态路由存在于路由表中。

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 10       Routes : 10       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.3.0/24  Direct  0    0           D   192.168.3.2     Vlanif30
        192.168.3.2/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  OSPF    10   2           D   192.168.3.1     Vlanif30
        192.168.5.0/24  Direct  0    0           D   192.168.5.1     Vlanif50
        192.168.5.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
        192.168.7.0/24  Static  60   0           D   192.168.1.2     Vlanif10

    # 查看汇聚层交换机SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     Vlanif30
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  Direct  0    0           D   192.168.4.1     Vlanif40
        192.168.4.1/32  Direct  0    0           D   127.0.0.1       Vlanif40
        192.168.7.0/24  O_ASE   150  10          D   192.168.3.2     Vlanif30

    可以看到有一条到192.168.7.0/24的路由,下一跳指向192.168.3.2,cost值为10,因此业务流量会优先走链路SwitchB→SwitchD。

    # 关闭SwitchB的GigabitEthernet0/0/3 接口,模拟链路故障。

    [SwitchB] interface GigabitEthernet0/0/3
    [SwitchB-GigabitEthernet0/0/3] shutdown
    [SwitchB-GigabitEthernet0/0/3] quit

    # 查看NQA测试结果。

    [SwitchB] display nqa results test-instance user test
    
     NQA entry(user, test) :testflag is active ,testtype is icmp 
      1 . Test 309 result   The test is finished
       Send operation times: 2              Receive response times: 0          
       Completion:failed                 RTD OverThresholds number: 0       
       Attempts number:1                    Drop operation number:2            
       Disconnect operation number:0        Operation timeout number:0         
       System busy operation number:0       Connection fail number:0           
       Operation sequence errors number:0   RTT Status errors number:0         
       Destination ip address:192.168.1.2                                   
       Min/Max/Average Completion Time: 0/0/0                                
       Sum/Square-Sum  Completion Time: 0/0                                  
       Last Good Probe Time: 0000-00-00 00:00:00.0                           
       Lost packet ratio: 100 %

    可以看到“Completion:failed”、“Lost packet ratio: 100 %”,这说明链路发生了故障。

    # 查看SwitchB的路由表,可以看到静态路由消失。

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 8        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.2     Vlanif30
        192.168.3.2/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  OSPF    10   2           D   192.168.3.1     Vlanif30
        192.168.5.0/24  Direct  0    0           D   192.168.5.1     Vlanif50
        192.168.5.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
        192.168.7.0/24  O_ASE   150  20          D   192.168.3.1     Vlanif30

    # 查看SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     Vlanif30
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  Direct  0    0           D   192.168.4.1     Vlanif40
        192.168.4.1/32  Direct  0    0           D   127.0.0.1       Vlanif40
        192.168.7.0/24  O_ASE   150  20          D   192.168.4.2     Vlanif40
    

    因为SwitchB上的NQA测试例与静态路由是联动的,当NQA检测到链路故障后,就迅速通知SwitchB与其绑定的静态路由不可用,SwitchA也不能从SwitchB处学到通往192.168.7.0/24的路由。但是SwitchA可以从SwitchC处学到通往192.168.7.0/24的路由,因此可以看到通往192.168.7.0/24的路由下一跳指向192.168.4.2,cost值为20。业务流量切换到链路SwitchC→SwitchD。

配置文件

  • 汇聚层交换机SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    return
  • 汇聚层交换机SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 30 50
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.5.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     import-route static cost 10
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    ip route-static 192.168.7.0 255.255.255.0 Vlanif10 192.168.1.2 track nqa user test
    #
    nqa test-instance user test
     test-type icmp
     destination-address ipv4 192.168.1.2
     frequency 20
     interval seconds 5
     timeout 4
     probe-count 2
     start now
    #
    return
  • 汇聚层交换机SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 40 60
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
    #
    interface Vlanif60
     ip address 192.168.6.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     import-route static cost 20
     area 0.0.0.0
      network 192.168.4.0 0.0.0.255
    #
    ip route-static 192.168.7.0 255.255.255.0 Vlanif60 192.168.6.2
    #
    return
  • 接入层交换机SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10 60 70
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif60
     ip address 192.168.6.2 255.255.255.0
    #
    interface Vlanif70
     ip address 192.168.7.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    return
  • 接入层交换机SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 20 50 80
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.5.2 255.255.255.0
    #
    interface Vlanif80
     ip address 192.168.8.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:27811

下载量:1384

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页