所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RIPng对接收的路由进行过滤示例

配置RIPng对接收的路由进行过滤示例

组网需求

图1所示,图中所有IPv6地址的前缀长度都为64,且相邻Switch之间的VLANIF接口使用IPv6链路本地地址连接。

要求所有Switch通过RIPng来学习网络中的IPv6路由信息,并且在SwitchB上对接收的SwitchC路由(FC00:0:0:3::/64)进行过滤,使其不加入到SwitchB的路由表中,也不发布给SwitchA。

图5-1  配置RIPng对接收的路由进行过滤组网图

配置思路

采用如下的思路配置RIPng对接收的路由进行过滤:

  1. 在各Switch上使能RIPng基本功能,使各Switch互通。

  2. SwitchB配置ACL,对接收的路由进行过滤。

操作步骤

  1. 配置接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] vlan 20
    [SwitchA-vlan20] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1/64
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ipv6 enable
    [SwitchA-Vlanif20] ipv6 address auto link-local
    [SwitchA-Vlanif20] quit

  3. 配置RIPng的基本功能

    # 配置SwitchA。

    [SwitchA] ripng 1
    [SwitchA-ripng-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ripng 1 enable
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ripng 1 enable
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    [SwitchB] ripng 1
    [SwitchB-ripng-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ripng 1 enable
    [SwitchB-Vlanif20] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] ripng 1 enable
    [SwitchB-Vlanif30] quit

    # 配置SwitchC。

    [SwitchC] ripng 1
    [SwitchC-ripng-1] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] ripng 1 enable
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] ripng 1 enable
    [SwitchC-Vlanif40] quit
    [SwitchC] interface vlanif 50
    [SwitchC-Vlanif50] ripng 1 enable
    [SwitchC-Vlanif50] quit

    # 查看SwitchB的RIPng路由表。

    [SwitchB] display ripng 1 route
       Route Flags: R - RIPng
                    A - Aging, G - Garbage-collect
     ----------------------------------------------------------------
     Peer FE80::D472:0:3C23:1  on Vlanif20
     Dest FC00:0:0:1::/64,
         via FE80::D472:0:3C23:1, cost  1, tag 0, RA, 4 Sec
     Peer FE80::F54C:0:9FDB:1  on Vlanif30
     Dest FC00:0:0:2::/64,
         via FE80::F54C:0:9FDB:1, cost  1, tag 0, RA, 3 Sec
     Dest FC00:0:0:3::/64,
         via FE80::F54C:0:9FDB:1, cost  1, tag 0, RA, 3 Sec
    

    从以上显示信息看出,SwitchB的RIPng路由表中含有FC00:0:0:3::/64网段的路由

    # 查看SwitchA的RIPng路由表。

    [SwitchA] display ripng 1 route
       Route Flags:  R - RIPng
                    A - Aging, G - Garbage-collect
     ----------------------------------------------------------------
    
     Peer FE80::476:0:3624:1  on Vlanif20
     Dest FC00:0:0:2::/64,
         via FE80::476:0:3624:1, cost  2, tag 0, RA, 21 Sec
     Dest FC00:0:0:3::/64,
         via FE80::476:0:3624:1, cost  2, tag 0, RA, 21 Sec

    从以上显示信息看出,SwitchA的RIPng路由表中含有由SwitchB布的FC00:0:0:3::/64网段的路由

  4. 配置SwitchB对接收的路由进行过滤

    [SwitchB] acl ipv6 number 2000
    [SwitchB-acl6-basic-2000] rule deny source fc00:0:0:3:: 64
    [SwitchB-acl6-basic-2000] rule permit
    [SwitchB-acl6-basic-2000] quit
    [SwitchB] ripng 1
    [SwitchB-ripng-1] filter-policy 2000 import
    [SwitchB-ripng-1] quit

  5. 验证配置结果

    说明:

    查看结果时需要等待被过滤的路由表项老化定时器超时(缺省情况下,老化定时器超时时间为180秒)。

    # 查看SwitchB RIPng路由表,表中不再有FC00:0:0:3::/64网段的路由。

    [SwitchB] display ripng 1 route
       Route Flags: R - RIPng
                    A - Aging, G - Garbage-collect
     ----------------------------------------------------------------
     Peer FE80::D472:0:3C23:1  on Vlanif20
     Dest FC00:0:0:1::/64,
         via FE80::D472:0:3C23:1, cost  1, tag 0, RA, 25 Sec
     Peer FE80::F54C:0:9FDB:1  on Vlanif30
     Dest FC00:0:0:2::/64,
         via FE80::F54C:0:9FDB:1, cost  1, tag 0, RA, 14 Sec
    

    # 查看SwitchA的RIPng路由表,表中不再有FC00:0:0:3::/64网段的路由。

    [SwitchA] display ripng 1 route
       Route Flags: R - RIPng
                    A - Aging, G - Garbage-collect
     ----------------------------------------------------------------
    
     Peer FE80::476:0:3624:1  on Vlanif20
     Dest FC00:0:0:2::/64,
         via FE80::476:0:3624:1, cost  2, tag 0, RA, 7 Sec

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     ripng 1 enable
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address auto link-local
     ripng 1 enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ripng 1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 20 30
    #
    acl ipv6 number 2000
     rule 0 deny source FC00:0:0:3::/64
     rule 1 permit
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address auto link-local
     ripng 1 enable
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address auto link-local
     ripng 1 enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ripng 1
     filter-policy 2000 import
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 30 40 50
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address auto link-local
     ripng 1 enable
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     ripng 1 enable
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     ripng 1 enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ripng 1
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22152

下载量:1343

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页