所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RIP与动态BFD联动特性示例

配置RIP与动态BFD联动特性示例

组网需求

图1所示,在小型网络中有4台交换机通过RIP协议实现网络互通。其中业务流量经过主链路SwitchA→ SwitchB→SwitchD进行传输。要求提高从SwitchA到SwitchB数据转发的可靠性,当主链路发生故障时,业务流量会快速切换到另一条路径进行传输。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图4-14  配置RIP与动态BFD联动特性示例

配置思路

采用如下配置思路配置RIP与动态BFD联动:

  1. 在各接口上配置IP地址,使网络可达。

  2. 在各交换机上使能RIP,基本实现网络互连。

  3. SwitchA和SwitchB上配置RIP与动态BFD联动,通过BFD快速检测链路的状态,从而提高RIP的收敛速度,实现链路的快速切换。

操作步骤

  1. 配置各接口所属的VLAN。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit
    

  2. 配置各VLANIF接口的IP地址。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.2.2.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.3.3.1 24
    [SwitchA-Vlanif20] quit

  3. 配置RIP的基本功能

    # 配置SwitchA。

    [SwitchA] rip 1
    [SwitchA-rip-1] version 2
    [SwitchA-rip-1] network 10.0.0.0
    [SwitchA-rip-1] quit

    # 配置SwitchB。

    [SwitchB] rip 1
    [SwitchB-rip-1] version 2
    [SwitchB-rip-1] network 10.0.0.0
    [SwitchB-rip-1] network 172.16.0.0
    [SwitchB-rip-1] quit

    # 配置SwitchC。

    [SwitchC] rip 1
    [SwitchC-rip-1] version 2
    [SwitchC-rip-1] network 10.0.0.0
    [SwitchC-rip-1] quit

    # 配置SwitchD。

    [SwitchD] rip 1
    [SwitchD-rip-1] version 2
    [SwitchD-rip-1] network 172.16.0.0
    [SwitchD-rip-1] quit

    # 完成上述操作之后,执行命令display rip neighbor,可以查看到SwitchA、SwitchB以及SwitchC之间已经建立了邻居关系。以SwitchA的显示为例。

    [SwitchA] display rip 1 neighbor
    ---------------------------------------------------------------------           
     IP Address      Interface                   Type   Last-Heard-Time             
    ---------------------------------------------------------------------           
     10.2.2.2        Vlanif10                    RIP    0:0:14                      
     Number of RIP routes  : 2                                                      
     10.3.3.2        Vlanif20                    RIP    0:0:19                      
     Number of RIP routes  : 1

    # 执行命令display ip routing-table,可以查看到完成配置的交换机之间可以互相引入路由,以SwitchA的显示为例。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 8        Routes : 9                                     
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
           10.2.2.0/24  Direct  0    0           D   10.2.2.1        Vlanif10       
           10.2.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
           10.3.3.0/24  Direct  0    0           D   10.3.3.1        Vlanif20       
           10.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
           10.4.4.0/24  RIP     100  1           D   10.3.3.2        Vlanif20       
                        RIP     100  1           D   10.2.2.2        Vlanif10       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  1           D   10.2.2.2        Vlanif10       

    由路由表可以看出,去往目的地172.16.1.0/24的下一跳地址是10.2.2.2,出接口是VLANIF10,流量在主链路SwitchA→SwitchB上进行传输。

  4. 配置RIP进程的BFD特性

    # 配置SwitchA上所有接口的BFD特性。SwitchB的配置与SwitchA相同,不再赘述。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] rip 1
    [SwitchA-rip-1] bfd all-interfaces enable
    [SwitchA-rip-1] bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    [SwitchA-rip-1] quit

    # 完成上述配置之后,在交换机上执行命令display rip bfd session可以看到SwitchA与SwitchB之间已经建立起BFD会话,BFDState字段显示为Up。以SwitchA的显示为例。

    [SwitchA] display rip 1 bfd session all
     LocalIp       : 10.2.2.1        RemoteIp  : 10.2.2.2        BFDState   : Up        
     TX            : 100             RX        : 100             Multiplier : 10         
     BFD Local Dis : 8192            Interface : Vlanif10                             
     Diagnostic Info : No diagnostic information                                      
                                                                                    
     LocalIp       : 10.3.3.1        RemoteIp  : 10.3.3.2        BFDState   : Down      
     TX            : 2800            RX        : 2800            Multiplier : 0         
     BFD Local Dis : 8193            Interface : Vlanif20                             
     Diagnostic Info : No diagnostic information 

  5. 检查配置结果

    # 在SwitchB的接口GigabitEthernet0/0/1上执行shutdown命令,模拟主链路故障。

    说明:

    模拟链路故障为验证需要,在实际应用中不需要执行此操作。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] shutdown

    # 查看SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 6        Routes : 6                                     
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
           10.3.3.0/24  Direct  0    0           D   10.3.3.1        Vlanif20       
           10.3.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif20       
           10.4.4.0/24  RIP     100  1           D   10.3.3.2        Vlanif20       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
         172.16.1.0/24  RIP     100  2           D   10.3.3.2        Vlanif20       

    由路由表可以看出,在主链路发生故障之后备份链路SwitchA→SwitchC→SwitchB被启用,去往172.16.1.0/24的路由下一跳地址是10.3.3.2,出接口为VLANIF20。

配置文件

  • SwitchA的配置文件。

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 10.2.2.1 255.255.255.0
    #
    interface Vlanif20
     ip address 10.3.3.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1 
     version 2 
     network 10.0.0.0
     bfd all-interfaces enable 
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    #
    return
  • SwitchB的配置文件。

    #
    sysname SwitchB
    #
    vlan batch 10 30 40
    #
    bfd
    #
    interface Vlanif10
     ip address 10.2.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.4.4.1 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 10.0.0.0
     network 172.16.0.0
     bfd all-interfaces enable 
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    #
    return
  • SwitchC的配置文件。

    #
    sysname SwitchC
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 10.3.3.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.4.4.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    rip 1 
     version 2 
     network 10.0.0.0
    #
    return
  • SwitchD的配置文件。

    #
    sysname SwitchD
    #
    vlan batch 40
    #
    interface Vlanif40
     ip address 172.16.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 1 
     version 2 
     network 172.16.0.0
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:28107

下载量:1386

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页