所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4静态路由与EFM联动示例

配置IPv4静态路由与EFM联动示例

组网需求

图1所示,SwitchA通过SwitchB和NMS跨网段相连,SwitchA通过静态路由与NMS进行正常通信。现希望在SwitchA和SwitchB间实时检测链路质量,在链路出现问题时将对应的静态路由从IP路由表删除,使业务流量切换到无链路故障的路由,提高网络的可靠性。

图3-11  配置IPv4静态路由与EFM联动组网图

配置思路

采用如下思路配置IPv4静态路由与EFM联动:

  1. SwitchA和SwitchB上使能EFM OAM功能(全局和接口下使能),实现对链路质量的实时检测。

  2. 配置SwitchA到NMS的静态路由并绑定efm-state,实现IPv4静态路由与EFM联动,在链路出现问题时,及时切换到无链路故障的路由。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置SwitchA和SwitchB间的EFM会话

    # 在SwitchA上使能EFM OAM功能。

    [SwitchA] efm enable
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] efm enable
    [SwitchA-GigabitEthernet0/0/1] quit
    

    # 在SwitchB上使能EFM OAM功能。

    [SwitchB] efm enable
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] efm enable
    [SwitchB-GigabitEthernet0/0/1] quit

  4. 配置静态路由并绑定efm-state

    # 在SwitchA配置到外部网络的静态路由,并绑定GigabitEthernet0/0/1接口的efm-state。

    [SwitchA] ip route-static 192.168.2.0 24 192.168.1.2 track efm-state gigabitethernet0/0/1

  5. 验证配置结果

    # 配置完成后,在SwitchA和SwitchB上执行display efm session all命令,可以看到EFM会话已经建立,且状态为detect,即接口处于握手状态,SwitchA上的显示为例。

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet0/0/1      detect                      --

    # 在SwitchA查看IP路由表,静态路由存在于路由表中。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5       Routes : 5       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.2.0/24  Static  60   0          RD   192.168.1.2     Vlanif10

    # 在SwitchB接口GigabitEthernet0/0/1视图下执行undo efm enable命令模拟链路故障。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] undo efm enable

    # 在SwitchA上执行display efm session all命令,可以看到EFM OAM协议状态为discovery,即接口处于对端发现状态。

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet0/0/1      discovery                   --

    # 查看SwitchA的路由表,发现静态路由192.168.2.0/24也不存在了。因为静态路由绑定了efm-state,当EFM OAM检测到链路故障后,就会迅速通知所绑定的静态路由不可用。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 4       Routes : 4       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
    

    # 在SwitchB接口GigabitEthernet0/0/1视图下执行efm enable命令模拟链路恢复正常。

    [SwitchB-GigabitEthernet0/0/1]efm enable

    # 在SwitchA上执行display efm session all命令,可以看到EFM OAM协议状态恢复为detect,即接口处于握手状态。

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet0/0/1      detect                      --

    # 查看SwitchA的路由表,发现静态路由192.168.2.0/24重新出现在路由表中。因为当EFM OAM检测到链路恢复正常后,就会迅速通知所绑定的静态路由重新生效。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5       Routes : 5       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.2.0/24  Static  60   0          RD   192.168.1.2     Vlanif10

配置文件

  • SwitchA的配置文件

    # 
    sysname SwitchA
    #
    vlan batch 10
    #
    efm enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     efm enable
    #
    ip route-static 192.168.2.0 255.255.255.0 192.168.1.2 track efm-state GigabitEthernet0/0/1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    efm enable
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     efm enable
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:21948

下载量:1340

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页