所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置动态BFD for IS-IS特性示例

配置动态BFD for IS-IS特性示例

组网需求

图1所示,现网中有三台交换机通过IS-IS协议实现路由互通,且SwitchA与SwitchB之间通过一台二层交换机实现互连。现要求当SwitchA与SwitchB之间链路出现故障时,这两台交换机能快速对故障结果做出反应,并把流量切换至经SwitchC链路转发。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图8-39  配置动态BFD for IS-IS组网图

配置思路

采用如下思路配置IS-IS与动态BFD联动特性:

  1. 配置各交换机的接口IP地址以及IS-IS路由协议,实现交换机之间路由可达。

  2. 配置IS-IS接口开销值控制路由的选路功能,使得SwitchA到SwitchB经交换机链路为主链路,经SwitchC链路为备份链路。

  3. 在SwitchA、SwitchB和SwitchC上配置IS-IS与动态BFD联动,实现快速感知链路故障,从而将流量切换至备份链路转发。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchSwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各交换机VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.3.3.1 24
    [SwitchA-Vlanif20] quit

  3. 配置IS-IS基本功能

    # 配置SwitchA。

    [SwitchA] isis
    [SwitchA-isis-1] is-level level-2
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] isis enable 1
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    [SwitchB] isis
    [SwitchB-isis-1] is-level level-2
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 50
    [SwitchB-Vlanif50] isis enable 1
    [SwitchB-Vlanif50] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis enable 1
    [SwitchB-Vlanif20] quit
    [SwitchB] interface vlanif 40
    [SwitchB-Vlanif40] isis enable 1
    [SwitchB-Vlanif40] quit

    # 配置SwitchC。

    [SwitchC] isis
    [SwitchC-isis-1] is-level level-2
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 50
    [SwitchC-Vlanif50] isis enable 1
    [SwitchC-Vlanif50] quit

    # 配置完成后,使用display isis peer命令,可以查看SwitchA和SwitchB、SwitchA和SwitchC建立了邻居关系。以SwitchA为例。

    [SwitchA] display isis peer
    
                              Peer information for ISIS(1)
    
      System Id     Interface          Circuit Id       State HoldTime Type     PRI
    -------------------------------------------------------------------------------
    0000.0000.0003  Vlanif10          0000.0000.0001.02 Up    21s      L2       64
    0000.0000.0002  Vlanif20          0000.0000.0002.01 Up    9s       L2       64
    
    Total Peer(s): 2

    # 交换机之间已经互相学到路由。以查看SwitchA的路由表为例。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 9
    
    Destination/Mask    Proto   Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct  0    0          D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0          D   127.0.0.1       Vlanif10
           10.2.2.0/24  ISIS-L2 15   20         D   10.3.3.2        Vlanif20
                        ISIS-L2 15   20         D   10.1.1.2        Vlanif10
           10.3.3.0/24  Direct  0    0          D   10.3.3.1        Vlanif20
           10.3.3.1/32  Direct  0    0          D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct  0    0          D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0          D   127.0.0.1       InLoopBack0
         172.16.1.0/24  ISIS-L2 15   20         D   10.3.3.2        Vlanif20

    从路由表可以看出,去往172.16.1.0/24的路由下一跳地址为10.3.3.2,流量在主链路SwitchA→SwitchB上传输。

  4. 配置接口开销值

    # 配置SwitchA。

    [SwitchA]  interface vlanif 20
    [SwitchA-Vlanif20] isis cost 5
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    [SwitchB]  interface vlanif 20
    [SwitchB-Vlanif20] isis cost 5
    [SwitchB-Vlanif20] quit

  5. 配置IS-IS进程的BFD特性

    # 在SwitchA上使能IS-IS的BFD特性。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] isis
    [SwitchA-isis-1] bfd all-interfaces enable
    [SwitchA-isis-1] quit

    # 在SwitchB上使能IS-IS的BFD特性。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] isis
    [SwitchB-isis-1] bfd all-interfaces enable
    [SwitchB-isis-1] quit

    # 在SwitchC上使能IS-IS的BFD特性。

    [SwitchC] bfd
    [SwitchC-bfd] quit
    [SwitchC] isis
    [SwitchC-isis-1] bfd all-interfaces enable
    [SwitchC-isis-1] quit

    # 配置完成后,在SwitchA、SwitchB或SwitchC上执行display isis bfd session all命令,可以看到BFD State的状态为Up。

    SwitchA的显示为例。

    [SwitchA] display isis bfd session all
    
                          BFD session information for ISIS(1)
                          -----------------------------------
    
    Peer System ID : 0000.0000.0003        Interface : Vlanif10    
    TX : 1000          BFD State : up      Peer IP Address : 10.1.1.2 
    RX : 1000          LocDis : 8193       Local IP Address: 10.1.1.1 
    Multiplier : 3     RemDis : 8193       Type : L2
    Diag : No diagnostic information
    
    Peer System ID : 0000.0000.0002        Interface : Vlanif20    
    TX : 1000          BFD State : up      Peer IP Address : 10.3.3.2 
    RX : 1000          LocDis : 8192       Local IP Address: 10.3.3.1 
    Multiplier : 3     RemDis : 8192       Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 2
    

    从上面信息可以看出,SwitchA与SwitchB、SwitchC的BFD会话状态为Up。

  6. 配置接口的BFD特性

    # 在SwitchA的VLANIF20接口上配置BFD特性,并指定最小发送和接收间隔为100ms本地检测时间倍数为4。

    [SwitchA]  interface vlanif 20
    [SwitchA-Vlanif20] isis bfd enable
    [SwitchA-Vlanif20] isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [SwitchA-Vlanif20] quit

    # 在SwitchB的VLANIF20接口上配置BFD特性,并指定最小发送和接收间隔为100ms本地检测时间倍数为4。

    [SwitchB]  interface vlanif 20
    [SwitchB-Vlanif20] isis bfd enable
    [SwitchB-Vlanif20] isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    [SwitchB-Vlanif20] quit

    # 配置完成后,在SwitchA或SwitchB上执行display isis bfd session all命令,可以看到BFD参数已生效。以SwitchB的显示为例。

    [SwitchB] display isis bfd session all
    
                          BFD session information for ISIS(1)
                          -----------------------------------
    
    Peer System ID : 0000.0000.0003        Interface : Vlanif50
    TX : 1000          BFD State : up      Peer IP Address : 10.2.2.1
    RX : 1000          LocDis : 8192       Local IP Address: 10.2.2.2
    Multiplier : 3     RemDis : 8193       Type : L2
    Diag : No diagnostic information
    
    Peer System ID : 0000.0000.0001        Interface : Vlanif20
    TX : 100           BFD State : up      Peer IP Address : 10.3.3.1
    RX : 100           LocDis : 8192       Local IP Address: 10.3.3.2
    Multiplier : 4     RemDis : 8192       Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 2

  7. 检查配置结果

    # 对SwitchB的GigabitEthernet0/0/2接口执行shutdown命令,模拟主链路故障。

    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] shutdown

  8. # 在交换机SwitchA上,查看路由表

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 8
    
    Destination/Mask    Proto       Pre  Cost     Flags NextHop         Interface
    
           10.1.1.0/24  Direct      0    0          D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct      0    0          D   127.0.0.1       Vlanif10
           10.2.2.0/24  ISIS-L2     15   20         D   10.1.1.2        Vlanif10
           10.3.3.0/24  Direct  0    0          D   10.3.3.1        Vlanif20
           10.3.3.1/32  Direct  0    0          D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct      0    0          D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct      0    0          D   127.0.0.1       InLoopBack0
         172.16.1.0/24  ISIS-L2     15   30         D   10.1.1.2        Vlanif10

    从路由表可以看出,在主链路失效后,备份链路SwitchA-SwitchC-SwitchB生效,去往172.16.1.0/24的路由下一跳地址为10.1.1.2。

    # 在SwitchA上执行display isis bfd session all命令,只能看到SwitchA和SwitchC之间的BFD State的状态为Up。

    [SwitchA] display isis bfd session all
    
                          BFD session information for ISIS(1)
                          -----------------------------------
    
    Peer System ID : 0000.0000.0003        Interface : Vlanif10    
    TX : 1000          BFD State : up      Peer IP Address : 10.1.1.2 
    RX : 1000          LocDis : 8193       Local IP Address: 10.1.1.1 
    Multiplier : 3     RemDis : 8193       Type : L2
    Diag : No diagnostic information
    
    Total BFD session(s): 1

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 20
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.3.3.1 255.255.255.0
     isis enable 1
     isis cost 5
     isis bfd enable
     isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 40 50
    #
    bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.3.3.2 255.255.255.0
     isis enable 1
     isis cost 5
     isis bfd enable
     isis bfd min-tx-interval 100 min-rx-interval 100 detect-multiplier 4
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 10.2.2.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 50
    #
    bfd
    #
    isis 1
     is-level level-2
     bfd all-interfaces enable
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 10.2.2.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22076

下载量:1342

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页