所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IS-IS的路由聚合示例

配置IS-IS的路由聚合示例

组网需求

图1所示,现网有3台交换机通过IS-IS路由协议实现互联,且SwitchA为Level-2设备,SwitchB为Level-1-2设备,SwitchC为Level-1设备。但是由于IS-IS网络的路由条目过多造成SwitchA系统资源负载过重,现要求降低SwitchA的系统资源的消耗。

图8-34  配置IS-IS的路由聚合组网图

配置思路

采用如下的思路配置IS-IS路由聚合:

  1. 配置各交换机的接口IP地址以及IS-IS路由协议,实现网络互联。

  2. 在SwitchB上配置路由聚合,使得在不影响数据转发的前提下减少SwitchA中路由表规模,从而降低SwitchA系统资源的消耗。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 50
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 50
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 50
    [SwitchA-Vlanif50] ip address 172.17.1.1 24
    [SwitchA-Vlanif50] quit

  3. 配置IS-IS基本功能

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-2
    [SwitchA-isis-1] network-entity 20.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 50
    [SwitchA-Vlanif50] isis enable 1
    [SwitchA-Vlanif50] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis enable 1
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 50
    [SwitchB-Vlanif50] isis enable 1
    [SwitchB-Vlanif50] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] is-level level-1
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] isis enable 1
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] isis enable 1
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] isis enable 1
    [SwitchC-Vlanif40] quit

  4. 查看SwitchA的IS-IS路由表信息

    [SwitchA]display isis route
     
                             Route information for ISIS(1)
                             -----------------------------
     
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     
     IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------------
     172.17.1.0/24        10         NULL    Vlanif50        Direct          D/-/L/-
     172.16.1.0/24        30         NULL    Vlanif50        172.17.1.2      A/-/-/-
     172.16.2.0/24        30         NULL    Vlanif50        172.17.1.2      A/-/-/-
     172.16.3.0/24        30         NULL    Vlanif50        172.17.1.2      A/-/-/-
     172.16.4.0/24        20         NULL    Vlanif50        172.17.1.2      A/-/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    

  5. SwitchB配置路由聚合

    # 在SwitchB将172.16.1.0/24、172.16.2.0/24、172.16.3.0./24、172.16.4.0/24聚合成172.16.0.0/16。

    [SwitchB] isis 1
    [SwitchB-isis-1] summary 172.16.0.0 255.255.0.0 level-1-2
    [SwitchB-isis-1] quit

  6. 验证配置结果

    # 查看SwitchA的路由表,可以看到172.16.1.0/24、172.16.2.0/24、172.16.3.0/24和172.16.4.0/24聚合成了172.16.0.0/16一条路由。

    [SwitchA] display isis route
     
                             Route information for ISIS(1)
                             -----------------------------
     
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
     
     IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
    -------------------------------------------------------------------------------
     172.17.1.0/24        10         NULL    Vlanif50        Direct          D/-/L/-
     172.16.0.0/16        20         NULL    Vlanif50        172.17.1.2      A/-/-/-
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 50
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0001.00
    #
    interface Vlanif50
     ip address 172.17.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 50
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     summary 172.16.0.0 255.255.0.0 level-1-2
    #
    interface Vlanif10
     ip address 172.16.4.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 172.17.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 20 30 40
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 172.16.4.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 172.16.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.16.3.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:23139

下载量:1351

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页