所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IS-IS的DIS选择示例

配置IS-IS的DIS选择示例

组网需求

图1所示,广播网中有4台设备通过IS-IS路由协议实现互联,其中SwitchA和SwitchB是Level-1-2设备,SwitchC是Level-1设备,SwitchD是Level-2设备。用户希望将性能较好的SwitchA配置为Level-2的DIS。

图8-35  配置IS-IS的DIS选择组网图

配置思路

采用如下的思路配置IS-IS的DIS选择:

  1. 配置IS-IS路由协议,实现网络互联。

  2. 配置SwitchA DIS优先级为100,实现SwitchA被选举为Level-2的DIS。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchSwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

  3. 查看各台Switch上VLANIF10的MAC地址

    # 查看SwitchA上接口VLANIF10的MAC地址。

    [SwitchA] display interface Vlanif 10
    Vlanif10 current state : UP
    Line protocol current state : UP 
    Last line protocol up time : 2014-12-02 18:02:15 UTC+08:00
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.1/24 
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc10-afec
    Current system time: 2014-12-02 18:03:12+08:00
        Input bandwidth utilization  : --
        Output bandwidth utilization : --

    # 查看SwitchB上接口VLANIF10的MAC地址。

    [SwitchB] display interface Vlanif 10
    Vlanif10 current state : UP
    Line protocol current state : UP 
    Last line protocol up time : 2014-12-02 18:01:15 UTC+08:00
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.2/24 
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fccd-acdf
    Current system time: 2014-12-02 18:02:12+08:00
        Input bandwidth utilization  : --
        Output bandwidth utilization : --

    # 查看SwitchC上接口VLANIF10的MAC地址。

    [SwitchC] display interface Vlanif 10
    Vlanif10 current state : UP
    Line protocol current state : UP 
    Last line protocol up time : 2014-12-02 18:03:15 UTC+08:00
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.3/24 
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fc50-25fe
    Current system time: 2014-12-02 18:04:12+08:00
        Input bandwidth utilization  : --
        Output bandwidth utilization : --

    # 查看SwitchD上接口VLANIF10的MAC地址。

    [SwitchD] display interface Vlanif 10
    Vlanif10 current state : UP
    Line protocol current state : UP 
    Last line protocol up time : 2014-12-02 18:07:15 UTC+08:00
    Description:
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.4/24 
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 00e0-fcfd-305c
    Current system time: 2014-12-02 18:08:12+08:00
        Input bandwidth utilization  : --
        Output bandwidth utilization : --

  4. 配置IS-IS基本功能

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis enable 1
    [SwitchB-Vlanif10] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] is-level level-1
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit

    # 配置SwitchD。

    [SwitchD] isis 1
    [SwitchD-isis-1] network-entity 10.0000.0000.0004.00
    [SwitchD-isis-1] is-level level-2
    [SwitchD-isis-1] quit
    [SwitchD] interface vlanif 10
    [SwitchD-Vlanif10] isis enable 1
    [SwitchD-Vlanif10] quit

    # 查看SwitchA的IS-IS邻居信息。

    [SwitchA] display isis peer
     
                              Peer information for ISIS(1)
    
      System Id         Interface         Circuit Id        State HoldTime Type       PRI
    -------------------------------------------------------------------------------
      0000.0000.0002    Vlanif10          0000.0000.0002.01  Up    9s       L1(L1L2)  64
      0000.0000.0003    Vlanif10          0000.0000.0002.01  Up    27s      L1        64
      0000.0000.0002    Vlanif10          0000.0000.0002.01  Up    28s      L2(L1L2)  64
      0000.0000.0004    Vlanif10          0000.0000.0002.01  Up    8s       L2        64
    
    Total Peer(s): 4
    

    # 查看SwitchA的IS-IS接口信息。

    [SwitchA] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU  Type  DIS
     Vlanif10        001      Up                    Down         1497 L1/L2 No/No

    # 查看SwitchB的IS-IS接口信息。

    [SwitchB] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU  Type  DIS
     Vlanif10        001         Up                 Down         1497 L1/L2 Yes/Yes

    # 查看SwitchD的IS-IS接口信息。

    [SwitchD] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU  Type  DIS
     Vlanif10        001         Up                 Down         1497 L1/L2 No/No
    说明:

    从接口信息中可以看到,在使用缺省DIS优先级的情况下,在Level-1级别的设备中,SwitchB接口的MAC地址最大,因此SwitchB为Level-1的DIS;在Level-2级别的设备中,SwitchD接口的MAC地址最大,因此SwitchD为Level-2的DIS。Level-1和Level-2的伪节点分别是0000.0000.0002.01和0000.0000.0004.01。

  5. 配置SwitchA的DIS优先级

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis dis-priority 100
    [SwitchA-Vlanif10] quit

    # 查看SwitchA的IS-IS邻居信息。

    [SwitchA] display isis peer
     
                              Peer information for ISIS(1)
    
      System Id          Interface           Circuit Id       State HoldTime Type      PRI
    -------------------------------------------------------------------------------
     0000.0000.0002      Vlanif10           0000.0000.0001.01 Up    21s      L1(L1L2)  64
     0000.0000.0003      Vlanif10           0000.0000.0001.01 Up    27s      L1        64
     0000.0000.0002      Vlanif10           0000.0000.0001.01 Up    28s      L2(L1L2)  64
     0000.0000.0004      Vlanif10           0000.0000.0001.01 Up    30s      L2        64
    
    Total Peer(s): 4
    

  6. 验证配置结果

    # 查看SwitchA的IS-IS接口信息。

    [SwitchA] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU   Type  DIS
     Vlanif10        001         Up                 Down         1497  L1/L2 Yes/Yes

    从上述信息中可以看到,在改变IS-IS接口的DIS优先级后,SwitchA即成为Level-1和Level-2的DIS,且伪节点是0000.0000.0001.01。

    # 查看SwitchB的IS-IS邻居和接口信息

    [SwitchB] display isis peer
     
                              Peer information for ISIS(1)
    
      System Id          Interface           Circuit Id       State HoldTime Type      PRI
    -------------------------------------------------------------------------------
      0000.0000.0001     Vlanif10            0000.0000.0001.01 Up    7s       L1(L1L2)  100
      0000.0000.0003     Vlanif10            0000.0000.0001.01 Up    25s      L1        64
      0000.0000.0001     Vlanif10            0000.0000.0001.01 Up    7s       L2(L1L2)  100
      0000.0000.0004     Vlanif10            0000.0000.0001.01 Up    25s      L2        64
      
      Total Peer(s): 4
    [SwitchB] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU   Type  DIS
     Vlanif10        001         Up                 Down         1497  L1/L2 No/No

    # 查看SwitchD的IS-IS邻居和接口信息

    [SwitchD] display isis peer
     
                              Peer information for ISIS(1)
    
      System Id      Interface          Circuit Id          State HoldTime Type     PRI
    -------------------------------------------------------------------------------
      0000.0000.0002 Vlanif10           0000.0000.0001.01    Up   28s      L2       64
      0000.0000.0001 Vlanif10           0000.0000.0001.01    Up   9s       L2       100
    
    Total Peer(s): 2
    [SwitchD] display isis interface
     
                           Interface information for ISIS(1)
                           ---------------------------------
     Interface       Id      IPV4.State          IPV6.State      MTU   Type  DIS
     Vlanif10        001         Up                 Down         1497  L1/L2 No/No

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis dis-priority 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.3 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif10
     ip address 10.1.1.4 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22709

下载量:1349

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页