所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
在路由引入时应用路由策略示例

在路由引入时应用路由策略示例

组网需求

图1所示,SwitchB与SwitchA之间通过OSPF协议交换路由信息,与SwitchC之间通过IS-IS协议交换路由信息。用户希望在SwitchB上将IS-IS网络中路由引入到OSPF网络后,OSPF网络中路由172.17.1.0/24的选路优先级较低;路由172.17.2.0/24具有标识,方便以后运用路由策略。

图11-20  配置在路由引入时应用路由策略组网图

设备名

接口

对应的VLANIF

IP地址

SwitchA

GE0/0/1

VLANIF10

192.168.1.1/24

SwitchB

GE0/0/1

VLANIF10

192.168.1.2/24

SwitchB

GE0/0/2

VLANIF20

192.168.2.2/24

SwitchC

GE0/0/1

VLANIF20

192.168.2.1/24

SwitchC

GE0/0/2

VLANIF30

172.17.1.1/24

SwitchC

GE0/0/3

VLANIF40

172.17.2.1/24

SwitchC

GE0/0/4

VLANIF50

172.17.3.1/24

配置思路

采用如下的思路配置在路由引入时应用路由策略:

  1. SwitchB上配置路由策略,将172.17.1.0/24的路由的开销设置为100,在OSPF引入IS-IS路由时应用路由策略,实现OSPF网络中路由172.17.1.0/24的选路优先级较低。

  2. SwitchB上配置路由策略,将172.17.2.0/24的路由的Tag属性设置为20。在OSPF引入IS-IS路由时应用路由策略,实现路由172.17.2.0/24具有标识,方便以后运用路由策略。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置IS-IS路由协议

    # 配置SwitchC。

    [SwitchC] isis
    [SwitchC-isis-1] is-level level-2
    [SwitchC-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] isis enable
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] isis enable
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] isis enable
    [SwitchC-Vlanif40] quit
    [SwitchC] interface vlanif 50
    [SwitchC-Vlanif50] isis enable
    [SwitchC-Vlanif50] quit

    # 配置SwitchB。

    [SwitchB] isis
    [SwitchB-isis-1] is-level level-2
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis enable
    [SwitchB-Vlanif20] quit

  4. 配置OSPF路由协议及路由引入

    # 配置SwitchA,启动OSPF。

    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB,启动OSPF,并引入IS-IS路由。

    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] import-route isis 1
    [SwitchB-ospf-1] quit

    # 查看SwitchA的OSPF路由表,可以看到引入的路由。

    [SwitchA] display ospf routing
     
              OSPF Process 1 with Router ID 192.168.1.1
                       Routing Tables
     
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.1     192.168.1.1     0.0.0.0
     
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop         AdvRouter
     172.17.1.0/24      1         Type2      1           192.168.1.2     192.168.1.2
     172.17.2.0/24      1         Type2      1           192.168.1.2     192.168.1.2
     172.17.3.0/24      1         Type2      1           192.168.1.2     192.168.1.2
     192.168.2.0/24     1         Type2      1           192.168.1.2     192.168.1.2
     
     Total Nets: 5
     Intra Area: 1  Inter Area: 0  ASE: 4  NSSA: 0

  5. 配置过滤列表

    # 配置编号为2002的ACL,允许172.17.2.0/24通过。

    [SwitchB] acl number 2002
    [SwitchB-acl-basic-2002] rule permit source 172.17.2.0 0.0.0.255
    [SwitchB-acl-basic-2002] quit

    # 配置名为prefix-a的地址前缀列表,允许172.17.1.0/24通过。

    [SwitchB] ip ip-prefix prefix-a index 10 permit 172.17.1.0 24

  6. 配置Route-Policy

    [SwitchB] route-policy isis2ospf permit node 10
    [SwitchB-route-policy] if-match ip-prefix prefix-a
    [SwitchB-route-policy] apply cost 100
    [SwitchB-route-policy] quit
    [SwitchB] route-policy isis2ospf permit node 20
    [SwitchB-route-policy] if-match acl 2002
    [SwitchB-route-policy] apply tag 20
    [SwitchB-route-policy] quit
    [SwitchB] route-policy isis2ospf permit node 30  
    [SwitchB-route-policy] quit

  7. 在路由引入时应用Route-Policy

    # 配置SwitchB,设置在路由引入时应用Route-Policy。

    [SwitchB] ospf
    [SwitchB-ospf-1] import-route isis 1 route-policy isis2ospf
    [SwitchB-ospf-1] quit

    # 查看SwitchA的OSPF路由表,可以看到目的地址为172.17.1.0/24的路由的开销为100,目的地址为172.17.2.0/24的路由的标记域(Tag)为20,而其他路由的属性未发生变化。

    [SwitchA] display ospf routing
     
              OSPF Process 1 with Router ID 192.168.1.1
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.1     192.168.1.1     0.0.0.0
     
     Routing for ASEs
     Destination        Cost      Type       Tag         NextHop           AdvRouter
     172.17.1.0/24      100       Type2      1           192.168.1.2       192.168.1.2
     172.17.2.0/24      1         Type2      20          192.168.1.2       192.168.1.2
     172.17.3.0/24      1         Type2      1           192.168.1.2       192.168.1.2
     192.168.2.0/24     1         Type2      1           192.168.1.2       192.168.1.2
      
     Total Nets: 5
     Intra Area: 1  Inter Area: 0  ASE: 4  NSSA: 0

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    acl number 2002
     rule 5 permit source 172.17.2.0 0.0.0.255
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1
     import-route isis 1 route-policy isis2ospf
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    route-policy isis2ospf permit node 10
     if-match ip-prefix prefix-a
     apply cost 100
    #
    route-policy isis2ospf permit node 20
     if-match acl 2002
     apply tag 20
    #
    route-policy isis2ospf permit node 30
    #
    ip ip-prefix prefix-a index 10 permit 172.17.1.0 24
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 30 40 50
    #
    isis 1
     is-level level-2
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 172.17.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.17.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 172.17.3.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:27226

下载量:1381

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页