所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6静态路由示例

配置IPv6静态路由示例

组网需求

图1所示,IPv6网络中属于不同网段的主机通过几台Switch相连,要求不配置动态路由协议,使不同网段的任意两台主机之间能够互通。

图3-7  配置IPv6静态路由组网图

配置思路

采用如下的思路配置IPv6静态路由:

  1. 创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IPv6地址,实现相邻设备网络互通。
  2. 在各主机上配置IPv6缺省网关,在各台Switch上配置IPv6静态路由或者静态缺省路由,实现不配置动态路由协议,使不同网段的任意两台主机之间能够互通。

操作步骤

  1. 配置接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    

  2. 配置VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:2001::1/64
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ipv6 enable
    [SwitchA-Vlanif20] ipv6 address fc00:0:0:2010::1/64
    [SwitchA-Vlanif20] quit

  3. 配置主机地址和网关

    根据组网图配置好各主机的IPv6地址,并将PC1的缺省网关配置为fc00:0:0:2001::1,PC2的缺省网关配置为fc00:0:0:2002::1,主机3的缺省网关配置为fc00:0:0:2003::1。

  4. 配置IPv6静态路由

    # 在SwitchA配置IPv6缺省路由。

    [SwitchA] ipv6 route-static :: 0 vlanif20 fc00:0:0:2010::2

    # 在SwitchB配置两条IPv6静态路由。

    [SwitchB] ipv6 route-static fc00:0:0:2001:: 64 vlanif20 fc00:0:0:2010::1
    [SwitchB] ipv6 route-static fc00:0:0:2003:: 64 vlanif40 fc00:0:0:2020::2

    # 在SwitchC配置IPv6缺省路由。

    [SwitchC] ipv6 route-static :: 0 vlanif40 fc00:0:0:2020::1

  5. 查看配置结果

    # 查看SwitchA的IPv6路由表。

    [SwitchA] display ipv6 routing-table
    Routing Table : Public 
             Destinations : 7        Routes : 7
    
     Destination  : ::                              PrefixLength : 0
     NextHop      : FC00:0:0:2010::2                Preference   : 60
     Cost         : 0                               Protocol     : Static
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : Vlanif20                        Flags        : D
    
     Destination  : ::1                             PrefixLength : 128
     NextHop      : ::1                             Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : InLoopBack0                     Flags        : D            
    
     Destination  : FC00:0:0:2001::                 PrefixLength : 64
     NextHop      : FC00:0:0:2001::1                Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : Vlanif10                        Flags        : D     
    
     Destination  : FC00:0:0:2001::1                PrefixLength : 128
     NextHop      : ::1                             Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : Vlanif10                        Flags        : D 
    
     Destination  : FC00:0:0:2010::                 PrefixLength : 64
     NextHop      : FC00:0:0:2010::1                Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : Vlanif20                        Flags        : D
    
     Destination  : FC00:0:0:2010::1                PrefixLength : 128
     NextHop      : ::1                             Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : Vlanif20                        Flags        : D
    
     Destination  : FE80::                          PrefixLength : 10
     NextHop      : ::                              Preference   : 0
     Cost         : 0                               Protocol     : Direct
     RelayNextHop : ::                              TunnelID     : 0x0
     Interface    : NULL0                           Flags        : D 

    # 使用Ping进行验证。

    [SwitchA] ping ipv6 fc00:0:0:2003::1
      PING fc00:0:0:2003::1 : 56  data bytes, press CTRL_C to break
        Reply from FC00:0:0:2003::1
        bytes=56 Sequence=1 hop limit=63  time = 63 ms
        Reply from FC00:0:0:2003::1
        bytes=56 Sequence=2 hop limit=63  time = 62 ms
        Reply from FC00:0:0:2003::1
        bytes=56 Sequence=3 hop limit=63  time = 62 ms
        Reply from FC00:0:0:2003::1
        bytes=56 Sequence=4 hop limit=63  time = 63 ms
        Reply from FC00:0:0:2003::1
        bytes=56 Sequence=5 hop limit=63  time = 63 ms
    
      --- fc00:0:0:2003::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 62/62/63 ms

    # 使用Tracert进行验证。

    [SwitchA] tracert ipv6 fc00:0:0:2003::1
     traceroute to fc00:0:0:2003::1  30 hops max,60 bytes packet
     1 FC00:0:0:2010::2 31 ms  32 ms  31 ms
     2 FC00:0:0:2003::1 62 ms  63 ms  62 ms

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2010::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    ipv6 route-static :: 0 Vlanif20 FC00:0:0:2010::2
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 20 30 40
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2010::2/64
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2020::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 30
    #
    ipv6 route-static FC00:0:0:2001:: 64 Vlanif20 FC00:0:0:2010::1
    ipv6 route-static FC00:0:0:2003:: 64 Vlanif40 FC00:0:0:2020::2
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 40 50
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2020::2/64
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 50
    #
    ipv6 route-static :: 0 Vlanif40 FC00:0:0:2020::1
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22069

下载量:1342

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页