所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置公网IP FRR示例

配置公网IP FRR示例

组网需求

图1所示,互联网出口分别为RouterB和RouterC,交换机SwitchA采用双GE链路上行至两台核心交换机SwitchB和SwitchC,核心交换机SwitchB和SwitchC分别采用双GE链路上行至出口的Router。要求当SwitchB、RouterB之间的链路出现故障时,可以快速应对出现的链路故障,直接启用备份路由进行数据转发,尽快使业务流恢复正常。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图12-1  配置公网IP FRR功能

配置思路

采用如下的思路配置公网IP FRR功能:

  1. SwitchA上配置静态路由,使目的地址为192.168.1.1/24的流量经过SwitchC转发,目的地址为10.55.1.1/24的流量经过SwitchB转发。

  2. SwitchB上配置路由策略,并在使能公网IP FRR功能时运用该策略,使得链路SwitchB->RouterB发生故障后,业务可以快速切换至备份链路SwitchB->SwitchC->RouterB进行转发。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 50 60
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 50
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 60
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 50
    [SwitchA-Vlanif50] ip address 10.50.1.2 24
    [SwitchA-Vlanif50] quit
    [SwitchA] interface vlanif 60
    [SwitchA-Vlanif60] ip address 10.60.1.2 24
    [SwitchA-Vlanif60] quit

  3. SwitchB、SwitchC上配置OSPF基本功能

    # 配置SwitchB。

    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.10.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.20.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.60.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.70.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchC。

    [SwitchC] ospf
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.30.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.40.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.50.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.70.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

  4. 在RouterB、RouterC上配置IP地址和OSPF基本功能,使得RouterB、RouterC、SwitchB和SwitchC之间路由可达。
  5. SwitchA上配置静态路由,使目的地址为192.168.1.1/24的流量经过SwitchC转发,目的地址为10.55.1.1/24的流量经过SwitchB转发

    # 配置SwitchA

    [SwitchA] ip route-static 10.55.1.0 24 vlanif 60 10.60.1.1
    [SwitchA] ip route-static 192.168.1.0 24 vlanif 50 10.50.1.1

  6. 配置路由策略及使能IP FRR功能

    # 配置SwitchB地址前缀列表

    [SwitchB] ip ip-prefix ip_frr_pre index 10 permit 10.55.1.0 24
    

    # 配置SwitchB路由策略、备份下一跳和备份出接口

    [SwitchB] route-policy ip_frr_rp permit node 10
    [SwitchB-route-policy] if-match ip-prefix ip_frr_pre 
    [SwitchB-route-policy] apply backup-nexthop 10.70.1.1
    [SwitchB-route-policy] apply backup-interface vlanif 70
    [SwitchB-route-policy] quit

    # 使能SwitchB公网IP FRR功能

    [SwitchB] ip frr route-policy ip_frr_rp 

  7. 查看备份出接口和备份下一跳的信息

    # 在SwitchB上查看备份出接口和备份下一跳信息

    [SwitchB] display ip routing-table verbose
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 1       Routes : 1     
    
    Destination: 10.55.1.0/24
         Protocol: OSPF                    Process ID: 1
       Preference: 10                            Cost: 2
          NextHop: 10.10.1.1                Neighbour: 0.0.0.0
            State: Active Adv                     Age: 1d17h58m22s                          
              Tag: 0                         Priority: medium                               
            Label: NULL                       QoSInfo: 0x0                                  
       IndirectID: 0x80000001                               
      RelayNextHop: 0.0.0.0                 Interface:  Vlanif10
          TunnelID: 0x0                         Flags: RD
       BkNextHop: 10.70.1.1             BkInterface: Vlanif70
           BkLabel: NULL                  SecTunnelID: 0x0
      BkPETunnelID: 0x0               BkPESecTunnelID: 0x0
      BkIndirectID: 0x0
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 50 60
    #
    interface Vlanif50 
     ip address 10.50.1.2 255.255.255.0
    #
    interface Vlanif60 
     ip address 10.60.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ip route-static 10.55.1.0 255.255.255.0 Vlanif60 10.60.1.1                            
    ip route-static 192.168.1.0 255.255.255.0 Vlanif50 10.50.1.1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20 60 70
    #
    ip frr route-policy ip_frr_rp
    # 
    interface Vlanif10 
     ip address 10.10.1.2 255.255.255.0 
    # 
    interface Vlanif20 
     ip address 10.20.1.2 255.255.255.0
    #
    interface Vlanif60 
     ip address 10.60.1.1 255.255.255.0
    #
    interface Vlanif70 
     ip address 10.70.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.0 0.0.0.255
      network 10.20.1.0 0.0.0.255
      network 10.60.1.0 0.0.0.255
      network 10.70.1.0 0.0.0.255
    #
    ip ip-prefix ip_frr_pre index 10 permit 10.55.1.0 24
    #
    route-policy ip_frr_rp permit node 10
     if-match ip-prefix ip_frr_pre 
     apply backup-nexthop 10.70.1.1
     apply backup-interface Vlanif70
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30 40 50 70
    #
    interface Vlanif30 
     ip address 10.30.1.1 255.255.255.0 
    # 
    interface Vlanif40 
     ip address 10.40.1.1 255.255.255.0
    #
    interface Vlanif50 
     ip address 10.50.1.1 255.255.255.0
    #
    interface Vlanif70 
     ip address 10.70.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.30.1.0 0.0.0.255
      network 10.40.1.0 0.0.0.255
      network 10.50.1.0 0.0.0.255
      network 10.70.1.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22417

下载量:1345

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页