所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OSPFv3区域示例

配置OSPFv3区域示例

组网需求

图1所示,所有的Switch都运行OSPFv3,整个自治系统划分为3个区域。其中SwitchB、SwitchC作为ABR来转发区域之间的路由。

要求将Area2配置为Stub区域,减少通告到此区域内的LSA数量,但不影响路由的可达性。

图7-12  配置OSPFv3区域组网图

配置思路

采用如下的思路配置OSPFv3区域:

  1. 配置接口的IPv6地址。

  2. 在各Switch上使能OSPFv3的基本功能。

  3. 配置Area2为Stub区域(需要在Area2内所有的Switch上配置Stub命令),查看SwitchD的OSPFv3路由表信息。

  4. 配置Area2为Totally Stub区域,查看SwitchD的OSPFv3路由表信息。

操作步骤

  1. 配置接口所属VLAN

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/3] quit
    [SwitchA] vlan 20
    [SwitchA-vlan20] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置VLANIF接口的IPv6地址

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:2000::1/64
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ipv6 enable
    [SwitchA-Vlanif20] ipv6 address fc00:0:0:1001::2/64
    [SwitchA-Vlanif20] quit

  3. 配置OSPFv3基本功能

    # 配置SwitchA。

    [SwitchA] ospfv3
    [SwitchA-ospfv3-1] router-id 10.1.1.1
    [SwitchA-ospfv3-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ospfv3 1 area 1
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ospfv3 1 area 1
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    [SwitchB] ospfv3
    [SwitchB-ospfv3-1] router-id 10.2.2.2
    [SwitchB-ospfv3-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ospfv3 1 area 1
    [SwitchB-Vlanif20] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] ospfv3 1 area 0
    [SwitchB-Vlanif30] quit

    # 配置SwitchC。

    [SwitchC] ospfv3
    [SwitchC-ospfv3-1] router-id 10.3.3.3
    [SwitchC-ospfv3-1] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] ospfv3 1 area 0
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] ospfv3 1 area 2
    [SwitchC-Vlanif40] quit

    # 配置SwitchD。

    [SwitchD] ospfv3
    [SwitchD-ospfv3-1] router-id 10.4.4.4
    [SwitchD-ospfv3-1] quit
    [SwitchD] interface vlanif 40
    [SwitchD-Vlanif40] ospfv3 1 area 2
    [SwitchD-Vlanif40] quit

    # 查看SwitchB的OSPFv3邻居状态。

    [SwitchB] display ospfv3 peer
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    10.3.3.3          1   Full/DR          00:00:32    Vlanif30           0
    OSPFv3 Area (0.0.0.1)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID  
    10.1.1.1          1   Full/Backup      00:00:34    Vlanif20           0
    

    # 查看SwitchC的OSPFv3邻居状态。

    [SwitchC] display ospfv3 peer
    OSPFv3 Process (1)
    OSPFv3 Area (0.0.0.0)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    10.2.2.2          1   Full/DR          00:00:37    Vlanif30           0
    OSPFv3 Area (0.0.0.2)
    Neighbor ID     Pri   State            Dead Time   Interface  Instance ID
    10.4.4.4          1   Full/Backup      00:00:33    Vlanif40           0
    

    # 查看SwitchD的OSPFv3路由表信息。

    [SwitchD] display ospfv3 routing
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,
            N - NSSA, U - Uninstalled, D - Denied by Import Policy
    
    OSPFv3 Process (1)
       Destination                                   Metric
         Next-hop
      IA FC00:0:0:1000::/64                                     2
               via FE80::1572:0:5EF4:1, Vlanif40
      IA FC00:0:0:1001::/64                                     3
               via FE80::1572:0:5EF4:1, Vlanif40
         FC00:0:0:1002::/64                                     1
               directly connected, Vlanif40
      IA FC00:0:0:2000::/64                                     4
               via FE80::1572:0:5EF4:1, Vlanif40

  4. 配置Stub区域

    # 配置SwitchD的Stub区域。

    [SwitchD] ospfv3
    [SwitchD-ospfv3-1] area 2
    [SwitchD-ospfv3-1-area-0.0.0.2] stub
    [SwitchD-ospfv3-1-area-0.0.0.2] quit
    [SwitchD-ospfv3-1] quit

    # 配置SwitchC的Stub区域,设置发送到Stub区域的缺省路由的开销为10。

    [SwitchC] ospfv3
    [SwitchC-ospfv3-1] area 2
    [SwitchC-ospfv3-1-area-0.0.0.2] stub
    [SwitchC-ospfv3-1-area-0.0.0.2] default-cost 10

    # 查看SwitchD的OSPFv3路由表信息,可以看到路由表中多了一条缺省路由,它的开销值为直连路由的开销和所配置的开销值之和。

    [SwitchD] display ospfv3 routing
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,
            N - NSSA, U - Uninstalled, D - Denied by Import Policy
    
    OSPFv3 Process (1)
       Destination                                   Metric
         Next-hop
      IA ::/0                                          2
               via FE80::1572:0:5EF4:1, Vlanif40
      IA FC00:0:0:1000::/64                                     2
               via FE80::1572:0:5EF4:1, Vlanif40
      IA FC00:0:0:1001::/64                                     3
               via FE80::1572:0:5EF4:1, Vlanif40
         FC00:0:0:1002::/64                                     1
               directly connected, Vlanif40
      IA FC00:0:0:2000::/64                                     4
               via FE80::1572:0:5EF4:1, Vlanif40

  5. 配置Totally Stub区域

    # 配置SwitchC,设置Area2为Totally Stub区域。

    [SwitchC-ospfv3-1-area-0.0.0.2] stub no-summary

  6. 验证配置结果

    # 查看SwitchD的OSPFv3路由表,可以发现路由表项数目减少了,其他非直连路由都被抑制,只有缺省路由被保留。

    [SwitchD] display ospfv3 routing
    
    Codes : E2 - Type 2 External, E1 - Type 1 External, IA - Inter-Area,
            N - NSSA, U - Uninstalled, D - Denied by Import Policy
    
    OSPFv3 Process (1)
       Destination                                               Metric
         Next-hop
      IA ::/0                                                          2
               via FE80::1572:0:5EF4:1, Vlanif40
         FC00:0:0:1002::/64                                            1
               directly connected, Vlanif40

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 10 20
    #
    ospfv3 1
     router-id 10.1.1.1
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2000::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1001::2/64
     ospfv3 1 area 0.0.0.1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #  
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 20 30
    #
    ospfv3 1
     router-id 10.2.2.2
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:1001::1/64
     ospfv3 1 area 0.0.0.1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1000::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #  
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 30 40
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.2
      stub no-summary
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:1000::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:1002::1/64
     ospfv3 1 area 0.0.0.2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #  
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    ipv6
    #
    vlan batch 40
    #
    ospfv3 1
     router-id 10.4.4.4
     area 0.0.0.2
      stub
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:1002::2/64
     ospfv3 1 area 0.0.0.2
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:23193

下载量:1351

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页