所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IS-IS基本功能示例

配置IS-IS基本功能示例

组网需求

图1所示,现网中有4台交换机。用户希望在这4台交换机实现网络互联,并且因为SwitchA和SwitchB性能相对较低,所以还要使这两台交换机处理相对较少的数据信息。

图8-33  配置IS-IS基本功能组网图

配置思路

采用如下的思路配置IS-IS的基本功能:

  1. 在各交换机上配置IS-IS基本功能,实现网络互联。其中,配置SwitchA和SwitchB为Level-1设备,可以使这两台交换机维护相对少量的数据信息。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.2 24
    [SwitchA-Vlanif10] quit

  3. 在各Switch上运行IS-IS进程,指定网络实体,配置level级别

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-1
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] is-level level-1
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] quit

    # 配置SwitchD。

    [SwitchD] isis 1
    [SwitchD-isis-1] is-level level-2
    [SwitchD-isis-1] network-entity 20.0000.0000.0004.00
    [SwitchD-isis-1] quit

  4. 在各接口上使能IS-IS进程

    # 配置SwitchA。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # 配置SwitchB。

    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis enable 1
    [SwitchB-Vlanif20] quit

    # 配置SwitchC。

    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] isis enable 1
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] isis enable 1
    [SwitchC-Vlanif30] quit

    # 配置SwitchD。

    [SwitchD] interface vlanif 30
    [SwitchD-Vlanif30] isis enable 1
    [SwitchD-Vlanif30] quit
    [SwitchD] interface vlanif 40
    [SwitchD-Vlanif40] isis enable 1
    [SwitchD-Vlanif40] quit

  5. 验证配置结果

    # 查看各Switch的IS-IS LSDB信息。

    [SwitchA] display isis lsdb
                                                                                    
                            Database information for ISIS(1)                        
                            --------------------------------                        
                                                                                    
                              Level-1 Link State Database                           
                                                                                    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL 
    ------------------------------------------------------------------------------- 
    0000.0000.0001.00-00* 0x0000006e   0x953e        862           68      0/0/0    
    0000.0000.0002.00-00  0x0000006a   0xc015        766           68      0/0/0    
    0000.0000.0002.01-00  0x00000008   0xccb6        766           55      0/0/0    
    0000.0000.0003.00-00  0x00000086   0x529e        1155          111     1/0/0    
    0000.0000.0003.01-00  0x0000005e   0xf238        1155          55      0/0/0    
                                                                                    
    Total LSP(s): 5                                                                 
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),        
               ATT-Attached, P-Partition, OL-Overload
    
    [SwitchB] display isis lsdb
                                                                                    
                            Database information for ISIS(1)                        
                            --------------------------------                        
                                                                                    
                              Level-1 Link State Database                           
                                                                                    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL 
    ------------------------------------------------------------------------------- 
    0000.0000.0001.00-00  0x0000006e   0x953e        899           68      0/0/0    
    0000.0000.0002.00-00* 0x0000006a   0xc015        808           68      0/0/0    
    0000.0000.0002.01-00* 0x00000008   0xccb6        808           55      0/0/0    
    0000.0000.0003.00-00  0x00000086   0x529e        1195          111     1/0/0    
    0000.0000.0003.01-00  0x0000005e   0xf238        1195          55      0/0/0    
                                                                                    
    Total LSP(s): 5                                                                 
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),        
               ATT-Attached, P-Partition, OL-Overload
    
    [SwitchC] display isis lsdb
                                                                                    
                            Database information for ISIS(1)                        
                            --------------------------------                        
                                                                                    
                              Level-1 Link State Database                           
                                                                                    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL 
    ------------------------------------------------------------------------------- 
    0000.0000.0001.00-00  0x0000006e   0x953e        953           68      0/0/0    
    0000.0000.0002.00-00  0x0000006a   0xc015        859           68      0/0/0    
    0000.0000.0002.01-00  0x00000008   0xccb6        859           55      0/0/0    
    0000.0000.0003.00-00* 0x00000085   0x549d        937           111     1/0/0    
    0000.0000.0003.01-00* 0x0000005d   0xf437        937           55      0/0/0    
                                                                                    
    Total LSP(s): 5                                                                 
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),        
               ATT-Attached, P-Partition, OL-Overload                               
                                                                                    
                                                                                    
                              Level-2 Link State Database                           
                                                                                    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL 
    ------------------------------------------------------------------------------- 
    0000.0000.0003.00-00* 0x0000008a   0x513c        876           100     0/0/0    
    0000.0000.0004.00-00  0x00000063   0x48ad        761           84      0/0/0    
    0000.0000.0004.01-00  0x0000005b   0x3aef        761           55      0/0/0    
                                                                                    
    Total LSP(s): 3                                                                 
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),        
               ATT-Attached, P-Partition, OL-Overload
    
    [SwitchD] display isis lsdb
                                                                                    
                            Database information for ISIS(1)                        
                            --------------------------------                        
                                                                                    
                              Level-2 Link State Database                           
                                                                                    
    LSPID                 Seq Num      Checksum      Holdtime      Length  ATT/P/OL 
    ------------------------------------------------------------------------------- 
    0000.0000.0003.00-00  0x0000008a   0x513c        901           100     0/0/0    
    0000.0000.0004.00-00* 0x00000063   0x48ad        789           84      0/0/0    
    0000.0000.0004.01-00* 0x0000005b   0x3aef        789           55      0/0/0    
                                                                                    
    Total LSP(s): 3                                                                 
        *(In TLV)-Leaking Route, *(By LSPID)-Self LSP, +-Self LSP(Extended),        
               ATT-Attached, P-Partition, OL-Overload

    # 查看各Switch的IS-IS路由信息。Level-1设备的路由表中应该有一条缺省路由,且下一跳为Level-1-2设备,Level-2设备应该有所有Level-1和Level-2的路由。

    [SwitchA] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    0.0.0.0/0            10         NULL    Vlanif10        10.1.1.1        A/-/-/- 
    192.168.0.0/24       20         NULL    Vlanif10        10.1.1.1        A/-/-/- 
    10.1.1.0/24          10         NULL    Vlanif10        Direct          D/-/L/- 
    10.1.2.0/24          20         NULL    Vlanif10        10.1.1.1        A/-/-/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    
    [SwitchB] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    0.0.0.0/0            10         NULL    Vlanif20        10.1.2.1        A/-/-/- 
    192.168.0.0/24       20         NULL    Vlanif20        10.1.2.1        A/-/-/- 
    10.1.1.0/24          20         NULL    Vlanif20        10.1.2.1        A/-/-/- 
    10.1.2.0/24          10         NULL    Vlanif20        Direct          D/-/L/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    
    [SwitchC] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    192.168.0.0/24       10         NULL    Vlanif30        Direct          D/-/L/- 
    10.1.1.0/24          10         NULL    Vlanif10        Direct          D/-/L/- 
    10.1.2.0/24          10         NULL    Vlanif20        Direct          D/-/L/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
                                                                                    
                                                                                    
                            ISIS(1) Level-2 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    172.16.1.0/24        20         NULL    Vlanif30        192.168.0.2     A/-/-/- 
    192.168.0.0/24       10         NULL    Vlanif30        Direct          D/-/L/- 
    10.1.1.0/24          10         NULL    Vlanif10        Direct          D/-/L/- 
    10.1.2.0/24          10         NULL    Vlanif20        Direct          D/-/L/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    
    [SwitchD] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-2 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    172.16.1.0/24        10         NULL    Vlanif40        Direct          D/-/L/- 
    192.168.0.0/24       10         NULL    Vlanif30        Direct          D/-/L/- 
    10.1.1.0/24          20         NULL    Vlanif30        192.168.0.1     A/-/-/- 
    10.1.2.0/24          20         NULL    Vlanif30        192.168.0.1     A/-/-/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set 
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 20 30
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 192.168.0.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    isis 1
     is-level level-2
     network-entity 20.0000.0000.0004.00
    #
    interface Vlanif30
     ip address 192.168.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22186

下载量:1343

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页