所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OSPF的NSSA区域示例

配置OSPF的NSSA区域示例

组网需求

图1所示,四台交换机都运行OSPF,且整个OSPF网络被划分为Area0和Area1两个区域。现要求Area1内的设备不接收其他OSPF区域引入的外部路由信息,而Area1内的交换机则通过区域内的设备引入外部路由来与外部网络进行通信。同时,由于SwitchB承载的业务较多,所以需要指定SwitchA作为转换路由器将Type7 LSA转换为Type5 LSA发送到其他OSPF区域。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图6-72  配置OSPF NSSA区域组网图

配置思路

采用如下的思路配置OSPF的NSSA区域:

  1. 在各交换机上配置OSPF基本功能,实现OSPF网络的基本互通。

  2. 配置Area1为NSSA区域,并在SwitchD上配置静态路由,并引入到OSPF路由表中,实现Area1内的交换机仅能通过SwitchD来与外部网络进行通信。

  3. 配置SwitchA为转换路由器,实现指定SwitchA将Type7 LSA转换为Type5 LSA发送到其他OSPF区域。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 192.168.3.1 24
    [SwitchA-Vlanif30] quit

  3. 配置OSPF基本功能

    # 配置SwitchA。

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchC。

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # 配置SwitchD。

    [SwitchD] ospf 1 router-id 10.4.4.4
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  4. 配置Area1区域为NSSA区域

    # 配置SwitchA。

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] nssa
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchD。

    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] nssa
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  5. 配置SwitchD引入静态路由

    [SwitchD] ip route-static 172.16.0.0 16 null 0
    [SwitchD] ospf 1
    [SwitchD-ospf-1] import-route static
    [SwitchD-ospf-1] quit

    # 查看SwitchC的OSPF路由表。

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
    
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.2.2.2
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    从以上回显信息可以看出NSSA区域引入的AS外部路由是通过SwitchB向其他区域发布的,即SwitchB将Type7 LSA转换成了Type5 LSA。这是因为OSPF会选举Router ID较大的ABR作为转换路由器。

  6. 配置SwitchA为转换路由器

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa translator-always
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

  7. 验证配置结果

    # 等待40秒后,查看SwitchC的OSPF路由表。

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
    
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.1.1.1
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    从以上回显信息可以看出NSSA区域引入的AS外部路由是通过SwitchA向其他区域发布的,即SwitchA成了转换路由器。

    说明:

    缺省情况下,新指定的转换路由器会和以前的转换路由器共同承担40s转换路由器的角色,过了40s后,只有新指定的转换路由器会继续完成转换路由器的工作。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      nssa translator-always
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
     area 0.0.0.1
      network 192.168.4.0 0.0.0.255
      nssa
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.4.4.4
     import-route static
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      nssa
    #
    ip route-static 172.16.0.0 255.255.0.0 NULL0
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22079

下载量:1342

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页