所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OSPF与BFD联动示例

配置OSPF与BFD联动示例

组网需求

图1所示,SwitchA、SwitchB和SwitchC之间运行OSPF,SwitchA和SwitchB之间的交换机仅作透传功能。现在需要SwitchA和SwitchB能快速感应它们之间的链路状态,当链路SwitchA-SwitchB发生故障时,业务能快速切换到备份链路SwitchA-SwitchC-SwitchB上。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图6-76  配置OSPF与BFD联动组网图

配置思路

采用如下思路配置OSPF与BFD联动:

  1. 在各交换机上配置OSPF基本功能,实现整个OSPF网络的互通。

  2. 在各交换机上配置OSPF与BFD联动功能,实现当SwitchA和SwitchB之间的链路出现故障时快速的切换到备份链路。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.3.3.1 24
    [SwitchA-Vlanif30] quit

  3. 配置OSPF基本功能

    # 配置SwitchA。

    [SwitchA] ospf 1 router-id 10.10.10.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    [SwitchB] ospf 1 router-id 10.10.10.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchC。

    [SwitchC] ospf 1 router-id 10.10.10.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # 配置完成后,执行命令display ospf peer,可以看到SwitchA,SwitchB和SwitchC之间互相建立了邻接关系。以SwitchA的显示结果为例。

    [SwitchA] display ospf peer
    
              OSPF Process 1 with Router ID 10.10.10.1
                      Neighbors
    
     Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s neighbors
     Router ID: 10.10.10.3       Address: 10.1.1.2          
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 10.1.1.2  BDR: 10.1.1.1  MTU: 0
       Dead timer due in 38  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:15
       Authentication Sequence: [ 0 ]
    
                      Neighbors
    
     Area 0.0.0.0 interface 10.3.3.1(Vlanif30)'s neighbors
     Router ID: 10.10.10.2       Address: 10.3.3.2
       State: Full  Mode:Nbr is   Master  Priority: 1
       DR: 10.3.3.2  BDR: 10.3.3.1  MTU: 0
       Dead timer due in 25  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:59
       Authentication Sequence: [ 0 ]

    # 查看SwitchA的OSPF路由表的信息,可以看到去往SwitchB和SwitchC的路由表项。而去往目的网段172.16.1.0/24的路由下一跳地址为10.3.3.2,说明流量在链路SwitchA→SwitchB上传输。

    [SwitchA] display ospf routing
    
              OSPF Process 1 with Router ID 10.10.10.1
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0
     10.2.2.0/24        2     Transit    10.1.1.2        10.10.10.3      0.0.0.0
     10.2.2.0/24        2     Transit    10.3.3.2        10.10.10.3      0.0.0.0
     10.3.3.0/24        1     Transit    10.3.3.1        10.10.10.1      0.0.0.0
     172.16.1.0/24      2     Stub       10.3.3.2        10.10.10.2      0.0.0.0
    
     Total Nets: 5
     Intra Area: 5  Inter Area: 0  ASE: 0  NSSA: 0

  4. 配置OSPF与BFD联动

    # 在SwitchA上配置OSPF与BFD联动功能。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] bfd all-interfaces enable
    [SwitchA-ospf-1] quit

    # 在SwitchB上配置OSPF与BFD联动功能。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] bfd all-interfaces enable
    [SwitchB-ospf-1] quit

    # 在SwitchC上配置OSPF与BFD联动功能。

    [SwitchC] bfd
    [SwitchC-bfd] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] bfd all-interfaces enable
    [SwitchC-ospf-1] quit

    # 配置完成后,在SwitchA或SwitchB、SwitchC上执行display ospf bfd session all命令,可以看到BFD会话的状态为Up。以SwitchA的显示为例。

    [SwitchA] display ospf bfd session all
    
              OSPF Process 1 with Router ID 10.10.10.1
      Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s BFD Sessions
    
     NeighborId:10.10.10.3       AreaId:0.0.0.0          Interface:Vlanif10
     BFDState:up                 rx    :1000             tx       :1000
     Multiplier:3                BFD Local Dis:8195      LocalIpAdd:10.1.1.1
     RemoteIpAdd:10.1.1.2        Diagnostic Info:No diagnostic information
    
      Area 0.0.0.0 interface 10.3.3.1(Vlanif30)'s BFD Sessions
    
     NeighborId:10.10.10.2       AreaId:0.0.0.0          Interface:Vlanif30
     BFDState:up                 rx    :1000             tx       :1000
     Multiplier:3                BFD Local Dis:8194      LocalIpAdd:10.3.3.1
     RemoteIpAdd:10.3.3.2         Diagnostic Info:No diagnostic information

  5. 检查配置结果

    # 对SwitchB的GE0/0/1接口执行shutdown命令,模拟链路故障。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] shutdown

    # 在SwitchA上查看OSPF路由表。

    [SwitchA] display ospf routing
    
              OSPF Process 1 with Router ID 10.10.10.1
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0
     10.2.2.0/24        2     Transit    10.1.1.2        10.10.10.3      0.0.0.0
     10.3.3.0/24        1     Stub       10.3.3.1        10.10.10.1      0.0.0.0
     172.16.1.0/24      3     Stub       10.1.1.2        10.10.10.2      0.0.0.0
    
     Total Nets: 4
     Intra Area: 4  Inter Area: 0  ASE: 0  NSSA: 0

    可以看出在链路SwitchA-SwitchB出现故障后,备份链路SwitchA-SwitchC-SwitchB开始生效,即去往目的网段172.16.1.0/24的路由下一跳地址变成了10.1.1.2。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.3.3.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1 router-id 10.10.10.1
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.3.3.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 30 40
    #
    bfd
    #
    interface Vlanif20
     ip address 10.2.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.3.3.2 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.10.10.2
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.2.2.0 0.0.0.255
      network 10.3.3.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.10.10.3
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22122

下载量:1343

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页