所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OSPF-BGP联动特性示例

配置OSPF-BGP联动特性示例

组网需求

图1所示,SwitchD和SwitchE之间建立EBGP连接。在AS10内的交换机之间建立IBGP连接,并且使用OSPF作为IGP协议。要求在SwitchB上使能OSPF-BGP联动功能,使得当SwitchB重启后,从SwitchA到AS20的流量不发生中断。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图6-74  配置OSPF-BGP联动组网图

配置思路

采用如下的思路配置OSPF-BGP联动功能。

  1. 在各交换机的VLANIF接口上配置IP地址并配置各接口所属VLAN,实现网段内的互通。

  2. SwitchA、SwitchB、SwitchC和SwitchD(除去10.2.1.1/30)上配置OSPF基本功能和IBGP连接,实现AS10内设备互通。

  3. SwitchD和SwitchE之间配置EBGP连接并引入直连路由和OSPF路由,实现AS10与AS20之间互通。

  4. SwitchC上配置OSPF协议的开销值为2,实现SwitchA只选择SwitchB作为到10.2.1.0网段的中间路由器,SwitchC成为SwitchB的备份路由器。

  5. SwitchB上配置OSPF-BGP联动功能,实现BGP当SwitchB重启后,从SwitchA到AS20的流量不发生中断。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口和LoopBack接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 30
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.2.1 30
    [SwitchA-Vlanif20] quit
    [SwitchA] interface loopback 0
    [SwitchA-LoopBack0] ip address 10.10.10.1 32
    [SwitchA-LoopBack0] quit

  3. 配置OSPF的基本功能

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] router id 10.10.10.1
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.10.10.1 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.3
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.3
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  4. 配置IBGP全连接

    # 配置SwitchA。

    [SwitchA] bgp 10
    [SwitchA-bgp] peer 10.10.10.2 as-number 10
    [SwitchA-bgp] peer 10.10.10.2 connect-interface LoopBack 0
    [SwitchA-bgp] peer 10.10.10.3 as-number 10
    [SwitchA-bgp] peer 10.10.10.3 connect-interface LoopBack 0
    [SwitchA-bgp] peer 10.10.10.4 as-number 10
    [SwitchA-bgp] peer 10.10.10.4 connect-interface LoopBack 0
    [SwitchA-bgp] quit

    # 配置SwitchB。

    [SwitchB] bgp 10
    [SwitchB-bgp] peer 10.10.10.1 as-number 10
    [SwitchB-bgp] peer 10.10.10.1 connect-interface LoopBack 0
    [SwitchB-bgp] peer 10.10.10.3 as-number 10
    [SwitchB-bgp] peer 10.10.10.3 connect-interface LoopBack 0
    [SwitchB-bgp] peer 10.10.10.4 as-number 10
    [SwitchB-bgp] peer 10.10.10.4 connect-interface LoopBack 0
    [SwitchB-bgp] quit

    # 配置SwitchC。

    [SwitchC] bgp 10
    [SwitchC-bgp] peer 10.10.10.1 as-number 10
    [SwitchC-bgp] peer 10.10.10.1 connect-interface LoopBack 0
    [SwitchC-bgp] peer 10.10.10.2 as-number 10
    [SwitchC-bgp] peer 10.10.10.2 connect-interface LoopBack 0
    [SwitchC-bgp] peer 10.10.10.4 as-number 10
    [SwitchC-bgp] peer 10.10.10.4 connect-interface LoopBack 0
    [SwitchC-bgp] quit

    # 配置SwitchD。

    [SwitchD] bgp 10
    [SwitchD-bgp] peer 10.10.10.1 as-number 10
    [SwitchD-bgp] peer 10.10.10.1 connect-interface LoopBack 0
    [SwitchD-bgp] peer 10.10.10.2 as-number 10
    [SwitchD-bgp] peer 10.10.10.2 connect-interface LoopBack 0
    [SwitchD-bgp] peer 10.10.10.3 as-number 10
    [SwitchD-bgp] peer 10.10.10.3 connect-interface LoopBack 0
    [SwitchD-bgp] quit

  5. 配置EBGP连接

    # 配置SwitchD。

    [SwitchD] bgp 10
    [SwitchD-bgp] peer 10.2.1.2 as-number 20
    [SwitchD-bgp] import-route direct
    [SwitchD-bgp] import-route ospf 1
    [SwitchD-bgp] quit

    # 配置SwitchE。

    [SwitchE] bgp 20
    [SwitchE-bgp] router-id 10.10.10.5
    [SwitchE-bgp] peer 10.2.1.1 as-number 10
    [SwitchE-bgp] ipv4-family unicast
    [SwitchE-bgp-af-ipv4] network 10.3.1.0 30
    [SwitchE-bgp-af-ipv4] quit
    [SwitchE-bgp] quit

  6. 配置SwitchC上OSPF协议的开销值

    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] ospf cost 2
    [SwitchC-Vlanif20] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] ospf cost 2
    [SwitchC-Vlanif30] quit

    # 查看SwitchA的路由表。从路由表中可以看出,通过BGP协议可以学习到目标网段10.3.1.0的路由,出接口是Vlanif10。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib 
    ------------------------------------------------------------------------------
    Routing Tables: Public 
             Destinations : 14       Routes : 15 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
    
           10.1.1.0/30  Direct  0    0           D   10.1.1.1        Vlanif10      
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10      
           10.1.2.0/30  Direct  0    0           D   10.1.2.1        Vlanif20      
           10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20      
           10.1.3.0/30  OSPF    10   2           D   10.1.1.2        Vlanif10      
           10.1.4.0/30  OSPF    10   3           D   10.1.2.2        Vlanif20      
                        OSPF    10   3           D   10.1.1.2        Vlanif10      
           10.2.1.0/30  IBGP    255  0          RD   10.10.10.4      Vlanif10      
           10.3.1.0/30  IBGP    255  0          RD   10.2.1.2        Vlanif10      
         10.10.10.1/32  Direct  0    0           D   127.0.0.1       LoopBack0     
         10.10.10.2/32  OSPF    10   1           D   10.1.1.2        Vlanif10      
         10.10.10.3/32  OSPF    10   1           D   10.1.2.2        Vlanif20      
         10.10.10.4/32  OSPF    10   2           D   10.1.1.2        Vlanif10      
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0   
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0   

    # 查看SwitchB的路由表。

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib 
    ------------------------------------------------------------------------------
    Routing Tables: Public 
             Destinations : 14       Routes : 15 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
    
           10.1.1.0/30  Direct  0    0           D   10.1.1.2        Vlanif10      
           10.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif10      
           10.1.2.0/30  OSPF    10   2           D   10.1.1.1        Vlanif10      
           10.1.3.0/30  Direct  0    0           D   10.1.3.1        Vlanif40      
           10.1.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif40      
           10.1.4.0/30  OSPF    10   2           D   10.1.3.2        Vlanif40      
           10.2.1.0/30  IBGP    255  0          RD   10.10.10.4      Vlanif40      
           10.3.1.0/30  IBGP    255  0          RD   10.2.1.2        Vlanif40      
         10.10.10.1/32  OSPF    10   1           D   10.1.1.1        Vlanif10      
         10.10.10.2/32  Direct  0    0           D   127.0.0.1       LoopBack0     
         10.10.10.3/32  OSPF    10   2           D   10.1.1.1        Vlanif10      
                        OSPF    10   2           D   10.1.3.2        Vlanif40      
         10.10.10.4/32  OSPF    10   1           D   10.1.3.2        Vlanif40      
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0   
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0   

    从路由表中可以看出,SwitchB通过BGP协议可以学习到目标网段10.3.1.0的路由,出接口是Vlanif40。通过OSPF协议可以学习到目标网段10.1.2.0和10.1.4.0的路由,路由开销都是2。

  7. SwitchB上配置OSPF-BGP联动功能

    [SwitchB] ospf
    [SwitchB-ospf-1] stub-router on-startup
    [SwitchB-ospf-1] return

  8. 查看配置结果

    # 保存配置。

    <SwitchB> save
    

    系统会提示将当前配置保存至设备,是否继续,输入y即可。

    # 重启SwitchB

    <SwitchB> reboot
    

    系统会提示即将重新启动,是否继续,输入y即可。

    # 查看SwitchA的路由表。从路由表中可以看出,通过BGP协议可以学习到目标网段10.3.1.0的路由,出接口变为Vlanif20。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib 
    ------------------------------------------------------------------------------
    Routing Tables: Public 
             Destinations : 10       Routes : 10 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
    
           10.1.2.0/30  Direct  0    0           D   10.1.2.1        Vlanif20      
           10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20      
           10.1.4.0/30  OSPF    10   3           D   10.1.2.2        Vlanif20      
           10.2.1.0/30  IBGP    255  0          RD   10.10.10.4      Vlanif20      
           10.3.1.0/30  IBGP    255  0          RD   10.2.1.2        Vlanif20      
         10.10.10.1/32  Direct  0    0           D   127.0.0.1       LoopBack0     
         10.10.10.3/32  OSPF    10   1           D   10.1.2.2        Vlanif20      
         10.10.10.4/32  OSPF    10   3           D   10.1.2.2        Vlanif20      
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0   
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0   

    # 查看SwitchB的路由表。从路由表中可以看出,由于IGP收敛速度比BGP快,所以路由表中暂时只有OSPF路由,并且开销值都已变为较大的数(≥65535)。

    <SwitchB> display ip routing-table
    Route Flags: R - relay, D - download to fib 
    ------------------------------------------------------------------------------
    Routing Tables: Public 
             Destinations : 12       Routes : 13 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface        
    
           10.1.1.0/30  Direct  0    0           D   10.1.1.2        Vlanif10      
           10.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif10      
           10.1.2.0/30  OSPF    10   65536       D   10.1.1.1        Vlanif10      
           10.1.3.0/30  Direct  0    0           D   10.1.3.1        Vlanif40      
           10.1.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif40      
           10.1.4.0/30  OSPF    10   65536       D   10.1.3.2        Vlanif40      
         10.10.10.1/32  OSPF    10   65535       D   10.1.1.1        Vlanif10      
         10.10.10.2/32  Direct  0    0           D   127.0.0.1       LoopBack0     
         10.10.10.3/32  OSPF    10   65536       D   10.1.1.1        Vlanif10      
                        OSPF    10   65536       D   10.1.3.2        Vlanif40      
         10.10.10.4/32  OSPF    10   65535       D   10.1.3.2        Vlanif40      
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0   
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0   

    # 在网络稳定后,再次查看SwitchB的路由表。

    <SwitchB> display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public 
             Destinations : 14       Routes : 15 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface        
    
           10.1.1.0/30  Direct  0    0           D   10.1.1.2        Vlanif10      
           10.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif10      
           10.1.2.0/30  OSPF    10   2           D   10.1.1.1        Vlanif10      
           10.1.3.0/30  Direct  0    0           D   10.1.3.1        Vlanif40      
           10.1.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif40      
           10.1.4.0/30  OSPF    10   2           D   10.1.3.2        Vlanif40      
           10.2.1.0/30  IBGP    255  0          RD   10.10.10.4      Vlanif40      
           10.3.1.0/30  IBGP    255  0          RD   10.2.1.2        Vlanif40      
         10.10.10.1/32  OSPF    10   1           D   10.1.1.1        Vlanif10      
         10.10.10.2/32  Direct  0    0           D   127.0.0.1       LoopBack0     
         10.10.10.3/32  OSPF    10   2           D   10.1.1.1        Vlanif10      
                        OSPF    10   2           D   10.1.3.2        Vlanif40      
         10.10.10.4/32  OSPF    10   1           D   10.1.3.2        Vlanif40      
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0   
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0   

    从路由表中可以看出,当SwitchB上的BGP完全收敛后,路由信息又恢复到重启前的内容。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    router id 10.10.10.1
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.252
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 10.10.10.1 255.255.255.255
    #
    bgp 10
     peer 10.10.10.2 as-number 10
     peer 10.10.10.2 connect-interface LoopBack0
     peer 10.10.10.3 as-number 10
     peer 10.10.10.3 connect-interface LoopBack0
     peer 10.10.10.4 as-number 10
     peer 10.10.10.4 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 10.10.10.2 enable
      peer 10.10.10.3 enable
      peer 10.10.10.4 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.1.2.0 0.0.0.3
      network 10.10.10.1 0.0.0.0
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    router id 10.10.10.2
    #
    vlan batch 10 40
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.252
    #
    interface Vlanif40
     ip address 10.1.3.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 10.10.10.2 255.255.255.255
    #
    bgp 10
     peer 10.10.10.1 as-number 10
     peer 10.10.10.1 connect-interface LoopBack0
     peer 10.10.10.3 as-number 10
     peer 10.10.10.3 connect-interface LoopBack0
     peer 10.10.10.4 as-number 10
     peer 10.10.10.4 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 10.10.10.1 enable
      peer 10.10.10.3 enable
      peer 10.10.10.4 enable
    #
    ospf 1
     stub-router on-startup
     area 0.0.0.0
      network 10.1.1.0 0.0.0.3
      network 10.1.3.0 0.0.0.3
      network 10.10.10.2 0.0.0.0
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    router id 10.10.10.3
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.252
     ospf cost 2
    #
    interface Vlanif30
     ip address 10.1.4.1 255.255.255.252
     ospf cost 2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 10.10.10.3 255.255.255.255
    #
    bgp 10
     peer 10.10.10.1 as-number 10
     peer 10.10.10.1 connect-interface LoopBack0
     peer 10.10.10.2 as-number 10
     peer 10.10.10.2 connect-interface LoopBack0
     peer 10.10.10.4 as-number 10
     peer 10.10.10.4 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 10.10.10.1 enable
      peer 10.10.10.2 enable
      peer 10.10.10.4 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.3
      network 10.1.4.0 0.0.0.3
      network 10.10.10.3 0.0.0.0
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    router id 10.10.10.4
    #
    vlan batch 30 40 50
    #
    interface Vlanif30
     ip address 10.1.4.2 255.255.255.252
    #
    interface Vlanif40
     ip address 10.1.3.2 255.255.255.252
    #
    interface Vlanif50
     ip address 10.2.1.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface LoopBack0
     ip address 10.10.10.4 255.255.255.255
    #
    bgp 10
     peer 10.10.10.1 as-number 10
     peer 10.10.10.1 connect-interface LoopBack0
     peer 10.10.10.2 as-number 10
     peer 10.10.10.2 connect-interface LoopBack0
     peer 10.10.10.3 as-number 10
     peer 10.10.10.3 connect-interface LoopBack0
     peer 10.2.1.2 as-number 20
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      import-route ospf 1
      peer 10.10.10.1 enable
      peer 10.10.10.2 enable
      peer 10.10.10.3 enable
      peer 10.2.1.2 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.3
      network 10.1.4.0 0.0.0.3
      network 10.10.10.4 0.0.0.0
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 50 60
    #
    interface Vlanif50
     ip address 10.2.1.2 255.255.255.252
    #
    interface Vlanif60
     ip address 10.3.1.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface LoopBack0
     ip address 10.10.10.5 255.255.255.255
    #
    bgp 20
     router-id 10.10.10.5
     peer 10.2.1.1 as-number 10
     #
     ipv4-family unicast
      undo synchronization
      network 10.3.1.0 255.255.255.252
      peer 10.2.1.1 enable
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:26875

下载量:1376

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页