所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RIP引入外部路由示例

配置RIP引入外部路由示例

组网需求

图1所示,SwitchB上运行两个RIP进程:RIP100和RIP200。要求在SwitchA与网段192.168.3.0/24能实现互通。

图4-12  配置RIP引入外部路由组网图

配置思路

采用如下的思路配置RIP引入外部路由:

  1. 在各交换机上使能RIP,实现各进程内网络互连。

  2. SwitchB上配置RIP100和RIP200之间的路由相互引入,其中将引入的RIP200路由的缺省权值设为3,实现两进程路由互通。

  3. SwitchB上配置ACL,对引入的RIP200的一条路由(192.168.4.0/24)进行过滤,实现SwitchA仅与网段192.168.3.0/24互通。

操作步骤

  1. 配置各接口所属的VLAN。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 50
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 50
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    

  2. 配置各VLANIF接口的IP地址。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 50
    [SwitchA-Vlanif50] ip address 192.168.0.1 24
    [SwitchA-Vlanif50] quit

  3. 配置RIP的基本功能

    # 在SwitchA上启动RIP进程100。

    [SwitchA] rip 100
    [SwitchA-rip-100] network 192.168.0.0
    [SwitchA-rip-100] network 192.168.1.0
    [SwitchA-rip-100] quit

    # 在SwitchB上启动两个RIP进程,进程号分别为100和200。

    [SwitchB] rip 100
    [SwitchB-rip-100] network 192.168.1.0
    [SwitchB-rip-100] quit
    [SwitchB] rip 200
    [SwitchB-rip-200] network 192.168.2.0
    [SwitchB-rip-200] quit

    # 在SwitchC上启动RIP进程200。

    [SwitchC] rip 200
    [SwitchC-rip-200] network 192.168.2.0
    [SwitchC-rip-200] network 192.168.3.0
    [SwitchC-rip-200] network 192.168.4.0
    [SwitchC-rip-200] quit

    # 查看SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 6       Routes : 6
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop        Interface
    
          127.0.0.0/8   Direct 0    0        D      127.0.0.1      InLoopBack0
          127.0.0.1/32  Direct 0    0        D      127.0.0.1      InLoopBack0
        192.168.0.0/24  Direct 0    0        D      192.168.0.1    Vlanif50
        192.168.0.1/32  Direct 0    0        D      127.0.0.1      Vlanif50
        192.168.1.0/24  Direct 0    0        D      192.168.1.1    Vlanif10
        192.168.1.1/32  Direct 0    0        D      127.0.0.1      Vlanif10

    可以看到,SwitchA的路由表中不存在其他进程的路由信息。

  4. 配置RIP引入外部路由

    # 在SwitchB上设置RIP进程100引入路由的缺省开销值为3,并将两个不同RIP进程的路由相互引入到对方的路由表中。

    [SwitchB] rip 100
    [SwitchB-rip-100] default-cost 3
    [SwitchB-rip-100] import-route rip 200
    [SwitchB-rip-100] quit
    [SwitchB] rip 200
    [SwitchB-rip-200] import-route rip 100
    [SwitchB-rip-200] quit

    # 查看路由引入后SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9       Routes : 9
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop         Interface
    
          127.0.0.0/8   Direct 0    0       D         127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0       D         127.0.0.1       InLoopBack0
        192.168.0.0/24  Direct 0    0       D         192.168.0.1     Vlanif50
        192.168.0.1/32  Direct 0    0       D         127.0.0.1       Vlanif50
        192.168.1.0/24  Direct 0    0       D         192.168.1.1     Vlanif10
        192.168.1.1/32  Direct 0    0       D         127.0.0.1       Vlanif10
        192.168.2.0/24  RIP    100  4       D         192.168.1.2     Vlanif10
        192.168.3.0/24  RIP    100  4       D         192.168.1.2     Vlanif10
        192.168.4.0/24  RIP    100  4       D         192.168.1.2     Vlanif10

    可以看到SwitchA的路由表中,出现了192.168.2.0/24、192.168.3.0/24和192.168.4.0/24路由信息。这些新增的路由信息都是通过SwitchB上的RIP进程200学习到的。

  5. 配置RIP对引入的路由进行过滤

    # 在SwitchB上配置ACL,并设置一条规则:拒绝源地址为192.168.4.0/24的数据包。

    [SwitchB] acl 2000
    [SwitchB-acl-basic-2000] rule deny source 192.168.4.0 0.0.0.255
    [SwitchB-acl-basic-2000] rule permit
    [SwitchB-acl-basic-2000] quit

    # 在SwitchB上按照ACL的规则对引入的RIP进程200的路由192.168.4.0/24进行过滤。

    [SwitchB] rip 100
    [SwitchB-rip-100] filter-policy 2000 export
    [SwitchB-rip-100] quit

  6. 验证配置结果

    # 查看过滤后SwitchA的路由表。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 8
    
    Destination/Mask    Proto  Pre  Cost   Flags    NextHop         Interface
    
          127.0.0.0/8   Direct 0    0       D         127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0       D         127.0.0.1       InLoopBack0
        192.168.0.0/24  Direct 0    0       D         192.168.0.1     Vlanif50
        192.168.0.1/32  Direct 0    0       D         127.0.0.1       Vlanif50
        192.168.1.0/24  Direct 0    0       D         192.168.1.1     Vlanif10
        192.168.1.1/32  Direct 0    0       D         127.0.0.1       Vlanif10
        192.168.2.0/24  RIP    100  4       D         192.168.1.2     Vlanif10
        192.168.3.0/24  RIP    100  4       D         192.168.1.2     Vlanif10

    可以看到SwitchA的路由表发生了变化。即源地址为192.168.4.0/24的路由被拒绝了。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 50
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.0.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 100
     network 192.168.0.0
     network 192.168.1.0
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    acl number 2000
     rule 5 deny source 192.168.4.0 0.0.0.255
     rule 10 permit
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    rip 100
     default-cost 3
     network 192.168.1.0
     filter-policy 2000 export
     import-route rip 200
    #
    rip 200
     network 192.168.2.0
     import-route rip 100
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 30 40
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    rip 200
     network 192.168.2.0
     network 192.168.3.0
     network 192.168.4.0
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22449

下载量:1345

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页