所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置OSPFv3 GR示例

配置OSPFv3 GR示例

组网需求

图1所示。SwitchA、SwitchB和SwitchC属于同一OSPFv3区域,通过OSPFv3协议实现网络互连,并提供GR机制。

SwitchA、SwitchC和SwitchB建立起OSPFv3邻接关系后,3台Switch开始交换路由信息。当SwitchA发生OSPFv3协议重启时,通过GR机制与邻居Switch进行同步。

图7-15  配置OSPFv3 GR特性组网图

配置思路

采用如下思路配置OSPFv3 GR:

  1. 配置接口的IPv6地址。

  2. 在各Switch上配置OSPFv3的基本功能。

  3. SwitchB的OSPFv3视图下使能OSPFv3 Helper能力。

  4. SwitchA的OSPFv3视图下使能OSPFv3 GR能力。

操作步骤

  1. 配置接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置VLANIF接口的IPv6地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] ipv6
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ipv6 enable
    [SwitchA-Vlanif10] ipv6 address fc00:0:0:1000::1/64
    [SwitchA-Vlanif10] quit

  3. 配置OSPFv3基本功能

    # 配置SwitchA,启动OSPFv3,并设置其Router ID为10.1.1.1。

    [SwitchA] ospfv3 100
    [SwitchA-ospfv3-100] router-id 10.1.1.1
    [SwitchA-ospfv3-100] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ospfv3 100 area 0
    [SwitchA-Vlanif10] quit

    # 配置SwitchB,启动OSPFv3,并设置其Router ID为10.2.2.2。

    [SwitchB] ospfv3 100
    [SwitchB-ospfv3-100] router-id 10.2.2.2
    [SwitchB-ospfv3-100] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ospfv3 100 area 0
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ospfv3 100 area 0
    [SwitchB-Vlanif20] quit

    # 配置SwitchC,启动OSPFv3,并设置其Router ID为10.3.3.3。

    [SwitchC] ospfv3 100
    [SwitchC-ospfv3-100] router-id 10.3.3.3
    [SwitchC-ospfv3-100] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] ospfv3 100 area 0
    [SwitchC-Vlanif20] quit

  4. 配置SwitchA的OSPFv3 GR功能

    [SwitchA] ospfv3 100
    [SwitchA-ospfv3-100] graceful-restart
    [SwitchA-ospfv3-100] return

  5. 配置SwitchB的OSPFv3 Helper功能

    [SwitchB] ospfv3 100
    [SwitchB-ospfv3-100] helper-role
    [SwitchB-ospfv3-100] return

  6. 检验配置结果

    # 在SwitchA使用display ipv6 fib命令,查看转发信息表。

    <SwitchA> display ipv6 fib
     IPv6 FIB Table:
     Total number of Routes : 5
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:2000::                         PrefixLength: 64
    Nexthop    :  FE80::200:1FF:FE00:200                  Flag        : DGU
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    # 在SwitchA不以Graceful Restart方式重启OSPFv3进程100。

    <SwitchA> reset ospfv3 100

    # 立即在SwitchA使用display ipv6 fib命令,查看转发信息表。

    <SwitchA> display ipv6 fib 
     IPv6 FIB Table:
     Total number of Routes : 4
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    可以看到,SwitchA的转发信息表发生了变化,转发业务受到了影响。

    # 在SwitchA上以Graceful Restart方式重启OSPFv3进程100。

    <SwitchA> reset ospfv3 100 graceful-restart

    # 立即在SwitchA使用display ipv6 fib命令,查看转发信息表,检查GR是否正常工作。如果GR正常工作,则在SwitchA上以Graceful Restart方式重启OSPFv3进程时,转发信息表没有变化,转发业务不受影响。

    <SwitchA> display ipv6 fib 
     IPv6 FIB Table:
     Total number of Routes : 5
    
    Destination:  ::1                                     PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FE80::                                  PrefixLength: 10
    Nexthop    :  ::                                      Flag        : BU
    Interface  :  NULL0                                   Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::1                        PrefixLength: 128
    Nexthop    :  ::1                                     Flag        : HU
    Interface  :  InLoopBack0                             Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:1000::                         PrefixLength: 64
    Nexthop    :  FC00:0:0:1000::1                        Flag        : U
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46
    
    Destination:  FC00:0:0:2000::                         PrefixLength: 64
    Nexthop    :  FE80::200:1FF:FE00:200                  Flag        : DGU
    Interface  :  Vlanif10                                Tunnel ID   : 0x0
    TimeStamp  :  2007-06-25 17:31:46

    可以看到,SwitchA的转发信息表没有发生变化,转发业务不受影响。

配置文件

  • SwitchA的配置文件

    # 
    sysname SwitchA
    # 
    ipv6
    #
    vlan batch 10
    #
    ospfv3 100 
     router-id 10.1.1.1 
     graceful-restart
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::1/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    return 
  • SwitchB的配置文件

    # 
    sysname SwitchB
    # 
    ipv6
    #
    vlan batch 10 20
    #
    ospfv3 100 
     router-id 10.2.2.2 
     helper-role 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1000::2/64
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2000::1/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #  
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    # 
    return 
  • SwitchC的配置文件

    # 
    sysname SwitchC
    # 
    ipv6
    #
    vlan batch 20
    #
    ospfv3 100 
     router-id 10.3.3.3
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2000::2/64
     ospfv3 100 area 0.0.0.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22054

下载量:1341

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页