所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置BGP路由反射示例

配置BGP路由反射示例

组网需求

图1所示,4台设备分属两个不同AS,SwitchA和SwitchB之间建立EBGP邻居,SwitchC分别和SwitchB及SwitchD建立IBGP邻居。为了避免IBGP全连接,达到简化网络配置的目的,用户希望SwitchB和SwitchD间在不建立IBGP连接的情况下实现两个AS之间的互通。

图10-23  配置BGP路由反射器组网图

配置思路

采用如下的思路配置BGP路由反射器:

  1. 配置BGP基本功能,实现BGP邻居间的互通。

  2. 配置SwitchC为路由反射器,SwitchB和SwitchD是它的两个客户机。这样可以使得SwitchB和SwitchD之间不需要建立IBGP连接即可学习到SwitchA发布的路由,达到简化配置的目的。

操作步骤

  1. 配置接口所属VLAN

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置各接口的IP地址,其中SwitchA上的LoopBack0的IP地址作为测试地址。

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.10.10.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface LoopBack 0
    [SwitchA-LoopBack0] ip address 192.168.10.1 32
    [SwitchA-LoopBack0] quit

  3. 配置BGP基本功能,同时在各交换机的在BGP进程中发布直连网段。

    # 配置SwitchA。

    [SwitchA] bgp 100
    [SwitchA-bgp] router-id 10.1.1.1
    [SwitchA-bgp] peer 10.10.10.2 as-number 200
    [SwitchA-bgp] ipv4-family unicast
    [SwitchA-bgp-af-ipv4] network 192.168.10.1 32
    [SwitchA-bgp-af-ipv4] network 10.10.10.0 24
    [SwitchA-bgp-af-ipv4] quit
    [SwitchA-bgp] quit

    # 配置SwitchB。

    [SwitchB] bgp 200
    [SwitchB-bgp] router-id 10.2.2.2
    [SwitchB-bgp] peer 10.10.10.1 as-number 100
    [SwitchB-bgp] peer 10.10.20.2 as-number 200
    [SwitchB-bgp] ipv4-family unicast
    [SwitchB-bgp-af-ipv4] network 10.10.10.0 24
    [SwitchB-bgp-af-ipv4] network 10.10.20.0 24
    [SwitchB-bgp-af-ipv4] quit
    [SwitchB-bgp] quit
    

    # 配置SwitchC。

    [SwitchC] bgp 200
    [SwitchC-bgp] router-id 10.3.3.3
    [SwitchC-bgp] peer 10.10.20.1 as-number 200
    [SwitchC-bgp] peer 10.10.30.2 as-number 200
    [SwitchC-bgp] ipv4-family unicast
    [SwitchC-bgp-af-ipv4] network 10.10.20.0 24
    [SwitchC-bgp-af-ipv4] network 10.10.30.0 24
    [SwitchC-bgp-af-ipv4] quit
    [SwitchC-bgp] quit

    # 配置SwitchD。

    [SwitchD] bgp 200
    [SwitchD-bgp] router-id 10.4.4.4
    [SwitchD-bgp] peer 10.10.30.1 as-number 200
    [SwitchD-bgp] ipv4-family unicast
    [SwitchD-bgp-af-ipv4] network 10.10.30.0 24
    [SwitchD-bgp-af-ipv4] quit
    [SwitchD-bgp] quit

  4. 配置路由反射器

    # 配置SwitchC作为路由反射器,SwitchB和SwitchD它的两个客户机。

    [SwitchC] bgp 200
    [SwitchC-bgp] ipv4-family unicast
    [SwitchC-bgp-af-ipv4] peer 10.10.20.1 reflect-client
    [SwitchC-bgp-af-ipv4] peer 10.10.30.2 reflect-client
    [SwitchC-bgp-af-ipv4] quit
    [SwitchC-bgp] quit

  5. 检查配置结果

    # 查看SwitchB的路由表。

    [SwitchB] display bgp routing-table 192.168.10.1 32
    
     BGP local router ID : 10.2.2.2
     Local AS number : 200
     Paths:   1 available, 1 best, 1 select
     BGP routing table entry information of 192.168.10.1/32:
     From: 10.10.10.1 (10.1.1.1)
     Route Duration: 00h34m09s  
     Direct Out-interface: Vlanif10
     Original nexthop: 10.10.10.1
     Qos information : 0x0
     AS-path 100, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255
     Advertised to such 1 peers:
        10.10.20.2

    可以看到SwitchB上学习到了192.168.10.1/32这条路由,并且通告给SwitchC。

    # 查看SwitchC的路由表。

    [SwitchC] display bgp routing-table 192.168.10.1 32
    
     BGP local router ID : 10.3.3.3
     Local AS number : 200
     Paths:   1 available, 1 best, 1 select
     BGP routing table entry information of 192.168.10.1/32:
     RR-client route.
     From: 10.10.20.1 (10.2.2.2)
     Route Duration: 00h34m17s  
     Relay IP Nexthop: 10.10.20.1
     Relay IP Out-Interface: Vlanif20
     Original nexthop: 10.10.10.1
     Qos information : 0x0
     AS-path 100, origin igp, MED 0, localpref 100, pref-val 0, valid, internal, best, select, active, pre 255
     Advertised to such 2 peers:
        10.10.20.1
        10.10.30.2

    可以看到SwitchC上学习到了192.168.10.1/32这条路由,并且通告给它的两个客户端SwitchB和SwitchD。

    # 查看SwitchD的路由表。

    [SwitchD] display bgp routing-table 192.168.10.1 32
    
     BGP local router ID : 10.4.4.4
     Local AS number : 200
     Paths:   1 available, 1 best, 1 select
     BGP routing table entry information of 192.168.10.1/32:
     From: 10.10.30.1 (10.3.3.3)
     Route Duration: 00h34m25s  
     Relay IP Nexthop: 10.10.30.1
     Relay IP Out-Interface: Vlanif30
     Original nexthop: 10.10.10.1
     Qos information : 0x0
     AS-path 100, origin igp, MED 0, localpref 100, pref-val 0, valid, internal, best, select, active, pre 255
     Originator:  10.2.2.2
     Cluster list: 10.3.3.3
     Not advertised to any peer yet

    可以看到SwitchD从SwitchC那里学到了SwitchA通告的192.168.10.1/32这条路由。

    # 在SwitchD上ping SwitchA的LoopBack0的IP地址,验证路由可达性。

    [SwitchD] ping 192.168.10.1
      PING 192.168.10.1: 56  data bytes, press CTRL_C to break
        Reply from 192.168.10.1: bytes=56 Sequence=1 ttl=255 time=31 ms
        Reply from 192.168.10.1: bytes=56 Sequence=2 ttl=255 time=16 ms
        Reply from 192.168.10.1: bytes=56 Sequence=3 ttl=255 time=40 ms
        Reply from 192.168.10.1: bytes=56 Sequence=4 ttl=255 time=30 ms
        Reply from 192.168.10.1: bytes=56 Sequence=5 ttl=255 time=26 ms
    
      --- 192.168.10.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 70/84/100 ms

    可以看到,在SwitchD上能ping通SwitchA的LoopBack0的IP地址,说明到SwitchA的路由可达。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.10.10.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface LoopBack0
     ip address 192.168.10.1 255.255.255.255
    #
    bgp 100
     router-id 10.1.1.1
     peer 10.10.10.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 10.10.10.0 255.255.255.0
      network 192.168.10.1 255.255.255.255
      peer 10.10.10.2 enable
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.10.10.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 200
     router-id 10.2.2.2
     peer 10.10.10.1 as-number 100
     peer 10.10.20.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 10.10.10.0 255.255.255.0
      network 10.10.20.0 255.255.255.0
      peer 10.10.10.1 enable
      peer 10.10.20.2 enable
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 30
    #
    interface Vlanif20
     ip address 10.10.20.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.10.30.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 200
     router-id 10.3.3.3
     peer 10.10.20.1 as-number 200
     peer 10.10.30.2 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 10.10.20.0 255.255.255.0
      network 10.10.30.0 255.255.255.0
      peer 10.10.20.1 enable
      peer 10.10.20.1 reflect-client
      peer 10.10.30.2 enable
      peer 10.10.30.2 reflect-client
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30
    #
    interface Vlanif30
     ip address 10.10.30.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    bgp 200
     router-id 10.4.4.4
     peer 10.10.30.1 as-number 200
     #
     ipv4-family unicast
      undo synchronization
      network 10.10.30.0 255.255.255.0
      peer 10.10.30.1 enable
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22931

下载量:1351

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页