所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4静态路由与静态BFD联动示例

配置IPv4静态路由与静态BFD联动示例

组网需求

图1所示,SwitchA通过SwitchB和NMS跨网段相连。在SwitchA上通过静态路由与NMS进行正常通信。在SwitchA和SwitchB之间实现毫秒级故障感知,提高收敛速度。

图3-8  配置IPv4静态路由与静态BFD联动组网图

配置思路

采用如下思路配置IPv4静态路由与静态BFD联动:

  1. SwitchA和SwitchB上配置BFD Session,在SwitchA和SwitchB之间实现毫秒级故障感知,提高收敛速度。

  2. 配置SwitchA到NMS的静态路由并绑定BFD Session,实现毫秒级故障感知,提高收敛速度。

操作步骤

  1. 配置各接口所属的VLAN

    # 配置SwitchA。SwitchB的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置SwitchA和SwitchB间的BFD会话

    # 在SwitchA配置与SwitchB间的BFD Session。

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd aa bind peer-ip 10.1.1.2
    [SwitchA-bfd-session-aa] discriminator local 10
    [SwitchA-bfd-session-aa] discriminator remote 20
    [SwitchA-bfd-session-aa] commit
    [SwitchA-bfd-session-aa] quit

    # 在SwitchB配置与SwitchA之间的BFD Session。

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd bb bind peer-ip 10.1.1.1
    [SwitchB-bfd-session-bb] discriminator local 20
    [SwitchB-bfd-session-bb] discriminator remote 10
    [SwitchB-bfd-session-bb] commit
    [SwitchB-bfd-session-bb] quit

  4. 配置静态路由并绑定BFD会话

    # 在SwitchA配置到外部网络的静态路由,并绑定BFD会话aa。

    [SwitchA]ip route-static 10.2.2.0 24 10.1.1.2 track bfd-session aa

  5. 验证配置结果

    # 配置完成后,在SwitchA和SwitchB上执行display bfd session all命令,可以看到BFD会话已经建立,且状态为Up

    SwitchA上的显示为例。

    [SwitchA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName                
    --------------------------------------------------------------------------------
    10    20     10.1.1.2        Up        S_IP_PEER         -                    
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

    # 在SwitchA查看IP路由表,静态路由存在于路由表中。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
     
    Destination/Mask    Proto   Pre  Cost    Flags NextHop       Interface
     
            10.1.1.0/24  Direct  0    0          D   10.1.1.1      Vlanif10
            10.1.1.1/32  Direct  0    0          D   127.0.0.1     Vlanif10
            10.2.2.0/24  Static  60   0         RD   10.1.1.2      Vlanif10
          127.0.0.0/8    Direct  0    0          D   127.0.0.1     InLoopBack0
          127.0.0.1/32   Direct  0    0          D   127.0.0.1     InLoopBack0

    # 对SwitchB接口GigabitEthernet0/0/1执行shutdown命令模拟链路故障。

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] shutdown

    # 查看SwitchA的路由表,发现静态路由10.2.2.0/24也不存在了。因为静态路由绑定了BFD会话,当BFD检测到故障后,就会迅速通知所绑定的静态路由不可用。

    [SwitchA]display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 2        Routes : 2
     
    Destination/Mask    Proto   Pre  Cost    Flags NextHop       Interface
     
          127.0.0.0/8   Direct  0    0          D  127.0.0.1     InLoopBack0
          127.0.0.1/32  Direct  0    0          D  127.0.0.1     InLoopBack0

    # 对SwitchB接口GigabitEthernet0/0/1执行undo shutdown命令模拟链路恢复正常。

    [SwitchB-GigabitEthernet0/0/1]undo shutdown

    # 查看SwitchA的路由表,发现静态路由10.2.2.0/24重新出现在路由表中。因为当BFD检测到链路恢复正常后,就会迅速通知所绑定的静态路由重新生效。

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
     
    Destination/Mask    Proto   Pre  Cost    Flags NextHop       Interface
     
            10.1.1.0/24  Direct  0    0          D   10.1.1.1      Vlanif10
            10.1.1.1/32  Direct  0    0          D   127.0.0.1     Vlanif10
            10.2.2.0/24  Static  60   0         RD   10.1.1.2      Vlanif10
          127.0.0.0/8    Direct  0    0          D   127.0.0.1     InLoopBack0
          127.0.0.1/32   Direct  0    0          D   127.0.0.1     InLoopBack0

配置文件

  • SwitchA的配置文件

    # 
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bfd aa bind peer-ip 10.1.1.2
     discriminator local 10
     discriminator remote 20
     commit
    #
    ip route-static 10.2.2.0 255.255.255.0 10.1.1.2 track bfd-session aa
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.2.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bfd bb bind peer-ip 10.1.1.1
     discriminator local 20
     discriminator remote 10
     commit
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:27152

下载量:1379

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页