所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IS-IS GR示例

配置IS-IS GR示例

组网需求

图1所示,SwitchA、SwitchB、SwitchC属于同一自治系统,通过IS-IS协议实现网络互连,并提供GR机制。当SwitchA发生IS-IS协议重启时,通过GR机制向邻居重新发送连接请求,同步数据库。

图8-40  配置IS-IS GR组网图

配置思路

采用如下思路配置IS-IS GR:
  1. 在各Switch上配置IS-IS基本功能,实现互连。
  2. 在所有Switch的IS-IS视图下配置GR能力并配置相同的重启间隔时间。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] interface vlanif10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

  3. 配置IS-IS的基本功能

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-1
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] is-level level-2
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis enable 1
    [SwitchB-Vlanif20] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 20
    [SwitchC-Vlanif20] isis enable 1
    [SwitchC-Vlanif20] quit

  4. 配置IS-IS GR功能,并配置重起间隔时间

    # 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似。

    [SwitchA] isis 1
    [SwitchA-isis-1] graceful-restart
    [SwitchA-isis-1] graceful-restart interval 150
    [SwitchA-isis-1] quit
    [SwitchA] quit

  5. 检查配置结果

    # 在SwitchA使用display fib命令,查看转发信息表。

    <SwitchA> display fib
    Route Flags: G - Gateway Route, H - Host Route,    U - Up Route                 
                 S - Static Route,  D - Dynamic Route, B - Black Hole Route         
                 L - Vlink Route
    --------------------------------------------------------------------------------
    FIB Table:
     Total number of Routes : 5
     
    Destination/Mask  Nexthop         Flag TimeStamp     Interface       TunnelID
    127.0.0.1/32      127.0.0.1       HU   t[21]         InLoop0         0x0
    127.0.0.0/8       127.0.0.1       U    t[21]         InLoop0         0x0
    10.1.1.1/32       127.0.0.1       HU   t[20678]      InLoop0         0x0
    10.1.1.0/24       10.1.1.1        U    t[20678]      Vlanif10        0x0
    10.2.1.0/24       10.1.1.2        DGU  t[79388]      Vlanif10        0x0

    # 在SwitchA以GR方式重启IS-IS进程。

    <SwitchA> reset isis all graceful-restart
    说明:

    只有在IS-IS进程中使能了GR功能,Switch才以GR方式重启IS-IS进程。

    # 立即在SwitchA使用display fib命令,查看转发信息表,检查GR是否正常工作。如果GR正常工作,则在SwitchA GR方式重启IS-IS进程时,转发信息表没有变化,转发业务不受影响。

    <SwitchA> display fib
    Route Flags: G - Gateway Route, H - Host Route,    U - Up Route                 
                 S - Static Route,  D - Dynamic Route, B - Black Hole Route         
                 L - Vlink Route
    --------------------------------------------------------------------------------
    FIB Table:
     Total number of Routes : 5
     
    Destination/Mask  Nexthop         Flag TimeStamp     Interface       TunnelID
    127.0.0.1/32      127.0.0.1       HU   t[21]         InLoop0         0x0
    127.0.0.0/8       127.0.0.1       U    t[21]         InLoop0         0x0
    10.1.1.1/32       127.0.0.1       HU   t[20678]      InLoop0         0x0
    10.1.1.0/24       10.1.1.1        U    t[20678]      Vlanif10        0x0
    10.2.1.0/24       10.1.1.2        DGU  t[79388]      Vlanif10        0x0

    可以看到,SwitchA的转发信息表没有发生变化,转发业务不受影响。

    # 在SwitchA关闭IS-IS GR功能。

    <SwitchA> system-view
    [SwitchA] isis 1
    [SwitchA-isis-1] undo graceful-restart
    [SwitchA-isis-1] quit
    [SwitchA] quit

    # 在SwitchA不以GR方式重启IS-IS进程。

    <SwitchA> reset isis all

    # 立即在SwitchA使用display fib命令,查看转发信息表。

    <SwitchA> display fib
    Route Flags: G - Gateway Route, H - Host Route,    U - Up Route                 
                 S - Static Route,  D - Dynamic Route, B - Black Hole Route         
                 L - Vlink Route
    --------------------------------------------------------------------------------
    FIB Table:
     Total number of Routes : 4
     
    Destination/Mask  Nexthop         Flag TimeStamp     Interface       TunnelID
    127.0.0.1/32      127.0.0.1       HU   t[21]         InLoop0         0x0
    127.0.0.0/8       127.0.0.1       U    t[21]         InLoop0         0x0
    10.1.1.1/32       127.0.0.1       HU   t[20678]      InLoop0         0x0
    10.1.1.0/24       10.1.1.1        U    t[20678]      Vlanif10        0x0

    可以看到,SwitchA的转发信息表发生了变化,转发业务受到了影响。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     graceful-restart
     graceful-restart interval 150
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20
    #
    isis 1
     graceful-restart
     graceful-restart interval 150
     is-level level-2
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    isis 1
     graceful-restart
     graceful-restart interval 150
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22238

下载量:1343

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页