所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R010C00 配置指南-IP单播路由

本文档介绍了设备支持的IP单播路由相关配置。主要内容包括IP路由概述,静态路由、RIP、RIPng、OSPF、OSPFv3、IS-IS(IPv4)、IS-IS(IPv6)、BGP、路由策略以及策略路由的基本原理和配置过程,并提供相关的配置案例。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IS-IS Auto FRR(IP保护IP)示例

配置IS-IS Auto FRR(IP保护IP)示例

组网需求

图1所示,现网中有四台交换机通过IS-IS路由协议实现路由互通。现要求提高SwitchA到SwitchD数据转发的可靠性,实现当出现故障时流量不中断。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图8-37  配置IS-IS Auto FRR组网图

配置思路

采用如下思路配置IS-IS Auto FRR:

  1. 配置各交换机的接口IP地址以及IS-IS路由协议,实现四台交换机路由可达。

  2. 在SwitchA的GigabitEthernet0/0/2接口上配置较大开销(需满足IS-IS Auto FRR流量保护不等式),使得链路T作为主链路转发SwitchA到SwitchD的数据。

  3. 在SwitchA上配置IS-IS Auto FRR,使得链路T出现故障时,可以将流量快速切换到备份链路上,而不用等待路由收敛,从而达到流量不中断的目的。

操作步骤

  1. 配置各接口所属VLAN

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit

  2. 配置各VLANIF接口的IP地址

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.2.0.1 24
    [SwitchA-Vlanif20] quit

  3. 配置IS-IS基本功能

    # 配置SwitchA。

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-1-2
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] isis enable 1
    [SwitchA-Vlanif20] quit

    # 配置SwitchB。

    [SwitchB] isis 1
    [SwitchB-isis-1] is-level level-1-2
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] isis enable 1
    [SwitchB-Vlanif20] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] isis enable 1
    [SwitchB-Vlanif30] quit

    # 配置SwitchC。

    [SwitchC] isis 1
    [SwitchC-isis-1] is-level level-1-2
    [SwitchC-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] isis enable 1
    [SwitchC-Vlanif10] quit
    [SwitchC] interface vlanif 50
    [SwitchC-Vlanif50] isis enable 1
    [SwitchC-Vlanif50] quit

    # 配置SwitchD。

    [SwitchD] isis 1
    [SwitchD-isis-1] is-level level-1-2
    [SwitchD-isis-1] network-entity 10.0000.0000.0004.00
    [SwitchD-isis-1] quit
    [SwitchD] interface vlanif 50
    [SwitchD-Vlanif50] isis enable 1
    [SwitchD-Vlanif50] quit
    [SwitchD] interface vlanif 30
    [SwitchD-Vlanif30] isis enable 1
    [SwitchD-Vlanif30] quit
    [SwitchD] interface vlanif 40
    [SwitchD-Vlanif40] isis enable 1
    [SwitchD-Vlanif40] quit

  4. 配置SwitchA的Vlanif20接口开销为30,并查看路由信息。

    # 配置SwitchA的Vlanif20接口开销为30。

    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] isis cost 30
    [SwitchA-Vlanif20] quit

    # 查看SwitchA到SwitchD的链路信息。由于链路T的开销最小,因此,IS-IS优选链路T来传送SwitchA转发的流量。

    [SwitchA] display isis route 192.168.1.1 verbose
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 192.168.1.0/24     Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 1             Flags     : A/-/L/-
     Priority   : Low                                                               
     NextHop    :                    Interface :               ExitIndex :          
        10.1.0.2                  Vlanif10                   0x00000003
                                                                                    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                        
                                                                                    
                                                                                    
                            ISIS(1) Level-2 Forwarding Table                        
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 192.168.1.0/24     Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 3             Flags     : -/-/-/-
     Priority   : Low                                                               
                                                                                    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                        
                                                                                    

    # 在SwitchA上执行display fib 192.168.1.1 verbose命令查看SwitchA到SwitchD的转发表项。

    [SwitchA] display fib 192.168.1.1 verbose
    
      Route Entry Count: 1
     Destination: 192.168.1.0         Mask     : 255.255.255.0
     Nexthop    : 10.1.0.2           OutIf    : Vlanif10
     LocalAddr  : 10.1.0.1            LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 26sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 0.0.0.0             OutIfBak : [No Intf]
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0                 
     BgpKey : 0                   
     BgpKeyBak : 0
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0            IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    

    从显示信息可以看出,此时SwitchA到SwitchD的流量转发只有一条链路T。

  5. SwitchA上使能IS-IS Auto FRR,并查看路由信息。

    # 在SwitchA上使能IS-IS Auto FRR。

    [SwitchA] isis
    [SwitchA-isis-1] frr
    [SwitchA-isis-1-frr] loop-free-alternate
    

    # 查看SwitchA到SwitchD的路由信息。由于使能了IS-IS Auto FRR,IS-IS生成了一条备份路由。

    [SwitchA] display isis route 192.168.1.1 verbose
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 192.168.1.0/24     Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 1             Flags     : A/-/L/-
     Priority   : Low                                                               
     NextHop    :                    Interface :               ExitIndex :          
        10.1.0.2                           Vlanif10                   0x00000003    
     (B)10.2.0.2                           Vlanif20                  0x00000004
                                                                                    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                        
                                                                                    
                                                                                    
                            ISIS(1) Level-2 Forwarding Table                        
                            --------------------------------                        
                                                                                    
     IPV4 Dest  : 192.168.1.0/24     Int. Cost : 30            Ext. Cost : NULL     
     Admin Tag  : -                  Src Count : 3             Flags     : -/-/-/-
     Priority   : Low                                                               
                                                                                    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                        
                                                                                    

    # 查看SwitchA到SwitchD的流量保护类型。

    [SwitchA] display isis spf-tree systemid 0000.0000.0004 verbose
                                                                                    
                             Shortest Path Tree for ISIS(1)                         
                             ------------------------------                         
                                                                                    
                           ISIS(1) Level-1 Shortest Path Tree                       
                           ----------------------------------                       
     0000.0000.0004.00                                                              
       Distance            : 20                                                     
       Distance-URT        : 20                                                     
       Flags               : SPT/V6_Islt                                            
       IPv4 Nexthops-URT   : 1                                                      
                 (1) 10.1.0.2         IF:Vlanif10  NBR:0000.0000.0003.00            
                 (B) 10.2.0.2         IF:Vlanif20  NBR:0000.0000.0002.00            
                                      TYPE:LOOP-FREE  PROTECT:LINK-NODE             
       IPv4 Nexthops-MIGP  : 0                                                      
       IPv6 Nexthops       : 0                                                      
       Neighbors: 2 (Children:1 Parents:1 Others:0)                                 
                 (1)   0000.0000.0003.02                                            
                         Cost  : 10                                                 
                         Flags : Parent                                             
                                                                                    
                 (2)   0000.0000.0004.03                                            
                         Cost  : 10                                                 
                         Flags : Child                                              
                                                                                    
                                                                                    
                           ISIS(1) Level-2 Shortest Path Tree                       
                           ----------------------------------                       
     0000.0000.0004.00                                                              
       Distance            : 20                                                     
       Distance-URT        : 20                                                     
       Flags               : SPT/V6_Islt                                            
       IPv4 Nexthops-URT   : 1                                                      
                 (1) 10.1.0.2         IF:Vlanif10  NBR:0000.0000.0003.00            
                 (B) 10.2.0.2         IF:Vlanif20  NBR:0000.0000.0002.00            
                                      TYPE:LOOP-FREE  PROTECT:LINK-NODE             
       IPv4 Nexthops-MIGP  : 0                                                      
       IPv6 Nexthops       : 0                                                      
       Neighbors: 2 (Children:1 Parents:1 Others:0)                                 
                 (1)   0000.0000.0003.02                                            
                         Cost  : 10                                                 
                         Flags : Parent                                             
                                                                                    
                 (2)   0000.0000.0004.03                                            
                         Cost  : 10                                                 
                         Flags : Child                                              
                                                                                    

    从显示信息可以看出,SwitchA到SwitchD的流量保护类型是节点链路双保护。

    # 在SwitchA上执行display fib 192.168.1.1 verbose命令查看SwitchA到SwitchD的转发表项。

    [SwitchA] display fib 192.168.1.1 verbose
      Route Entry Count: 1
     Destination: 192.168.1.0         Mask     : 255.255.255.0
     Nexthop    : 10.1.0.2            OutIf    : Vlanif10
     LocalAddr  : 10.1.0.1            LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 6sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 10.2.0.2            OutIfBak : Vlanif20
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0                 
     BgpKey : 0                   
     BgpKeyBak : 0
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0            IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    

    从显示信息可以看出,此时SwitchA到SwitchD的主用链路是链路T,备份链路是出接口为Vlanif20、下一跳为10.2.0.2的路由。

  6. 检查配置结果

    # 在SwitchC的Vlanif50端口上执行命令shutdown,模拟链路Down掉。

    [SwitchC] interface vlanif 50
    [SwitchC-Vlanif50] shutdown

    # 在SwitchA上立即执行display fib 192.168.1.1 verbose命令查看SwitchA到SwitchD的路由信息。

    [SwitchA] display fib 192.168.1.1 verbose
      Route Entry Count: 1
     Destination: 192.168.1.0         Mask     : 255.255.255.0
     Nexthop    : 10.2.0.2            OutIf    : Vlanif20
     LocalAddr  : 10.2.0.1            LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 124sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 0.0.0.0             OutIfBak : [No Intf]
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0 
     BgpKey : 0                   
     BgpKeyBak : 0
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0              IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    
    

    从显示信息可以看出,SwitchA转发的流量已经切换到出接口为Vlanif20,下一跳为10.2.0.2的备份链路上。

    说明:

    当网络发生故障的时候,IS-IS Auto FRR功能能够保证流量在路由协议收敛之前快速切换到备份链路上,从而达到流量保护的目的。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     frr
      loop-free-alternate level-1
      loop-free-alternate level-2
    #
    interface Vlanif10
     ip address 10.1.0.1 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.2.0.1 255.255.255.0
     isis enable 1
     isis cost 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 30
    #
    isis 1
     network-entity 10.0000.0000.0002.00
    #
    interface Vlanif20
     ip address 10.2.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 10.3.0.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 50
    #
    isis 1
     network-entity 10.0000.0000.0003.00
    #
    interface Vlanif10
     ip address 10.1.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif50
     ip address 10.4.0.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 40 50
    #
    isis 1
     network-entity 10.0000.0000.0004.00
    #
    interface Vlanif50
     ip address 10.4.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif30
     ip address 10.3.0.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif40
     ip address 192.168.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    return
翻译
下载文档
更新时间:2019-04-17

文档编号:EDOC1000141402

浏览量:22353

下载量:1345

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页