所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S600-E V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、IP性能优化配置、IPv6基础配置、DHCPv6配置和IPv6 DNS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过DHCP服务器为IP话机分配IP地址示例

配置通过DHCP服务器为IP话机分配IP地址示例

组网需求

图3-12所示,企业中IP Phone支持发送带Tag的语音报文。用户对语音通话质量较敏感,需要提高语音数据流的传输优先级,以保证用户的通话质量。为方便管理,企业管理员希望通过DHCP服务器为IP Phone终端统一分配IP地址。IP Phone除了获取IP地址,还需要动态获取启动配置文件,且启动配置文件configuration.ini存放在FTP文件服务器上。IP Phone与FTP文件服务器路由可达。

图3-12  配置通过DHCP服务器为IP话机分配IP地址组网图

配置思路

  1. 在Switch上配置Voice VLAN,提升报文优先级,保证设备优先转发语音报文。
  2. 在Switch上配置DHCP服务器,实现为IP Phone动态分配IP地址、Voice VLAN和启动配置文件参数。

操作步骤

  1. 配置Switch接口加入VLAN,创建VLAN10并将接口GE0/0/1和GE0/0/2加入到VLAN10中。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 10
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/2] quit

  2. 配置Voice VLAN功能,提升语音报文优先级。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] voice-vlan 10 enable
    [Switch-GigabitEthernet0/0/1] voice-vlan remark-mode vlan
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] voice-vlan 10 enable
    [Switch-GigabitEthernet0/0/2] voice-vlan remark-mode vlan
    [Switch-GigabitEthernet0/0/2] quit
    

    执行命令display voice-vlan 10 status,查看Voice VLAN的配置是否正确。

    [Switch] display voice-vlan 10 status
    Voice VLAN Configurations:
    -----------------------------------------------------------
    Voice VLAN ID            : 10
    Voice VLAN status        : Enable
    Voice VLAN 8021p remark  : 6
    Voice VLAN dscp remark   : 46
    -----------------------------------------------------------
    Port Information:
    -------------------------------------------------------------------------------------------
    Port                       Add-Mode  Security-Mode  Legacy  PribyVLAN  Untag
    -------------------------------------------------------------------------------------------
    GigabitEthernet0/0/2       Manual    Normal         Disable Enable     Disable
    GigabitEthernet0/0/1       Manual    Normal         Disable Enable     Disable

  3. 配置Switch作为DHCP服务器,实现为IP Phone分配IP地址、Voice VLAN和启动配置文件参数。
    1. 使能DHCP服务。

      [Switch] dhcp enable

    2. 配置VLANIF10接口工作在接口地址池模式,并配置可分配IP地址范围、Voice VLAN和启动配置文件参数。

      [Switch] interface vlanif 10
      [Switch-Vlanif10] ip address 10.1.1.1 24
      [Switch-Vlanif10] dhcp select interface
      [Switch-Vlanif10] dhcp server bootfile configuration.ini
      [Switch-Vlanif10] dhcp server next-server 10.1.1.3
      [Switch-Vlanif10] dhcp server option184 voice-vlan 10
      [Switch-Vlanif10] quit

      配置DHCP服务器分配给客户端Option184字段的目的是将VLAN ID下发给IP Phone,以保证IP Phone发送的报文携带的VLAN Tag跟DHCP服务器上配置的一致。不同厂商的IP电话可能会使用不同的Option数值,具体请参考IP电话机的使用说明。

  4. 验证配置结果

    # 在Switch上执行命令display ip pool interface vlanif10命令,查看IP地址池配置情况。

    [Switch] display ip pool interface vlanif10
      Pool-name      : Vlanif10
      Pool-No        : 0
      Lease          : 1 Days 0 Hours 0 Minutes
      Next-server    : 10.1.1.3
      Domain-name    : -
      Option-code    : 184
        Option-subcode : --
        Option-type    : hex
        Option-value   : 0302000A
      DNS-server0    : -
      NBNS-server0   : -
      Netbios-type   : -
      Position       : Interface           Status           : Unlocked
      Gateway-0      : 10.1.1.1
      Network        : 10.1.1.0
      Mask           : 255.255.255.0
      Bootfile       : configuration.ini
      Logging        : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :2                      
                         Idle        :251       Expired     :0                      
                         Conflict    :0         Disable     :0                      
                                                                                    
     -----------------------------------------------------------------------------
      Network section
             Start           End     Total  Used  Idle(Expired)  Conflict  Disabled
     -----------------------------------------------------------------------------
          10.20.20.1    10.20.20.254   253     2        251(0)         0        0
     -----------------------------------------------------------------------------     

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10
#
dhcp enable
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 dhcp select interface
 dhcp server next-server 10.1.1.3
 dhcp server option184 voice-vlan 10
 dhcp server bootfile configuration.ini
#
interface GigabitEthernet0/0/1
 port link-type trunk
 voice-vlan 10 enable
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/2
 port link-type trunk
 voice-vlan 10 enable
 port trunk pvid vlan 10
 port trunk allow-pass vlan 10
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141438

浏览量:11134

下载量:17

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页