所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S600-E V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、IP性能优化配置、IPv6基础配置、DHCPv6配置和IPv6 DNS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
基于全局地址池配置DHCP服务器实现为动态客户端和静态客户端分配不同网络参数示例

基于全局地址池配置DHCP服务器实现为动态客户端和静态客户端分配不同网络参数示例

组网需求

图3-11所示,IP Phone和PC为某办公区办公设备。为了方便统一管理,降低手工配置成本,管理员希望网络主机通过DHCP协议动态获取IP地址。其中,PC为值班室固定终端,需要永久在线,且需要通过域名访问网络设备,因此,除了动态获取IP地址,还需要地址的租期为无限长,且需要获取DNS服务器信息;IP Phone使用固定IP地址10.1.1.4/24,MAC地址为dcd2-fc96-e4c0,除了获取IP地址,还需要动态获取启动配置文件,且启动配置文件configuration.ini存放在FTP文件服务器上。IP Phone与FTP文件服务器路由可达。PC和IP Phone的网关地址为10.1.1.1/24。

图3-11  配置DHCP服务器实现为动态客户端和静态客户端分配不同网络参数组网图

配置思路

  1. 在SwitchA上创建DHCP Option模板,并在DHCP Option模板视图下为静态客户端IP Phone配置启动配置文件和获取启动配置文件的网络服务器的地址。
  2. 在SwitchA上创建全局地址池,并在全局地址池视图下为动态客户端PC配置租期和DNS服务器信息;为静态客户端IP Phone绑定IP地址和DHCP Option模板,从而实现为动态客户端和静态客户端分配不同的网络参数。

操作步骤

  1. 配置接口IP地址。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [SwitchA-Vlanif10] quit
    

  2. 使能DHCP服务。

    [SwitchA] dhcp enable

  3. 创建DHCP Option模板并在DHCP Option模板视图下配置需要为静态客户端IP Phone分配的启动配置文件和获取启动配置文件的文件服务器地址。

    [SwitchA] dhcp option template template1
    [SwitchA-dhcp-option-template-template1] gateway-list 10.1.1.1
    [SwitchA-dhcp-option-template-template1] bootfile configuration.ini 
    [SwitchA-dhcp-option-template-template1] next-server 10.1.1.3
    [SwitchA-dhcp-option-template-template1] quit

  4. 创建地址池并在地址池视图下为PC配置网关地址、租期和DNS服务器地址;为IP Phone配置分配固定IP地址和启动配置文件信息。

    [SwitchA] ip pool pool1
    [SwitchA-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.0
    [SwitchA-ip-pool-pool1] dns-list 10.1.1.2
    [SwitchA-ip-pool-pool1] gateway-list 10.1.1.1
    [SwitchA-ip-pool-pool1] excluded-ip-address 10.1.1.2 10.1.1.3
    [SwitchA-ip-pool-pool1] lease unlimited
    [SwitchA-ip-pool-pool1] static-bind ip-address 10.1.1.4 mac-address dcd2-fc96-e4c0 option-template template1 
    [SwitchA-ip-pool-pool1] quit

  5. 在Vlanif10接口下使能DHCP服务器。

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] dhcp select global
    [SwitchA-Vlanif10] quit

  6. 配置DHCP数据保存功能,设备发生故障时,可以在系统重启后,执行命令dhcp server database recover,从存储设备文件恢复DHCP数据。

    [SwitchA] dhcp server database enable

  7. 验证配置结果。

    # 在SwitchA上使用display ip pool name pool1命令用来查看IP地址池配置情况。

    [SwitchA] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : unlimited
      Domain-name      : -
      DNS-server0      : 10.1.1.2
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Local           Status           : Unlocked
      Gateway-0        : 10.1.1.1
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :4                      
                         Idle        :247       Expired     :0                      
                         Conflict    :0         Disable     :2                      
                                                                                    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254     253       4        247(0)       0     2   
     -------------------------------------------------------------------------------

    # 在SwitchA上使用display dhcp option template name template1命令用来查看DHCP Option模板的配置情况。

    [SwitchA] display dhcp option template name template1
     -------------------------------------------------------------------------------
      Template-Name  : template1                                                    
      Template-No    : 0                                                            
      Next-server    : 10.1.1.3                                                     
      Domain-name    : -                                                            
      DNS-server0    : -                                                            
      NBNS-server0   : -                                                            
      Netbios-type   : -                                                            
      Gateway-0      : 10.1.1.1                                                     
      Bootfile       : configuration.ini                                            

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10
#
dhcp enable
#                                                                               
dhcp server database enable
#
dhcp option template template1                                                  
 gateway-list 10.1.1.1                                                          
 next-server 10.1.1.3                                                           
 bootfile configuration.ini  
#
ip pool pool1
 gateway-list 10.1.1.1                                                          
 network 10.1.1.0 mask 255.255.255.0                                            
 excluded-ip-address 10.1.1.2 10.1.1.3                                          
 static-bind ip-address 10.1.1.4 mac-address dcd2-fc96-e4c0 option-template template1                                                                          
 lease unlimited                                                                
 dns-list 10.1.1.2        
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 dhcp select global  
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141438

浏览量:10523

下载量:17

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页