所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S600-E V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、IP性能优化配置、IPv6基础配置、DHCPv6配置和IPv6 DNS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置堆叠系统对接NLB服务器群集示例(通过物理链路环回方法)

配置堆叠系统对接NLB服务器群集示例(通过物理链路环回方法)

组网需求

图2-20所示,交换机Switch_1与Switch_2组成堆叠系统Stack,通过接口GE0/0/1和GE1/0/1分别与两台NLB服务器直连。NLB服务器群集工作在组播模式下,群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fc。Switch与客户端Client之间路由可达。

用户希望网络中客户端Client访问NLB服务器群集时,堆叠系统能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。

图2-20  堆叠系统对接组播模式的NLB服务器群集

配置思路

通过物理链路环回方法实现对接的配置思路如下:

  1. 配置与NLB服务器直连的接口GE0/0/1和GE1/0/1加入VLAN100。
  2. 配置接口GE0/0/4和GE1/0/4加入Eth-Trunk4、接口GE0/0/5和GE1/0/5加入Eth-Trunk5。
  3. 去使能自环接口Eth-Trunk4和Eth-Trunk5的STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100和VLAN200。
  4. 配置三层接口VLANIF200的IP地址,VLANIF200作为NLB服务器群集的网关。
  5. 配置静态ARP表项。静态ARP表项的IP地址为群集IP地址,MAC地址为群集组播MAC,出接口为自环口上NLB服务器群集网关VLAN所在的接口。
  6. 连接接口GE0/0/4和GE0/0/5GE1/0/4和GE1/0/5

操作步骤

  1. 配置与NLB直连的接口加入VLAN100

    # 配置接口GE0/0/1加入VLAN100。

    <HUAWEI> system-view
    [HUAWEI] sysname Stack
    [Stack] vlan batch 100 200
    [Stack] interface gigabitethernet 0/0/1
    [Stack-GigabitEthernet0/0/1] port link-type access 
    [Stack-GigabitEthernet0/0/1] port default vlan 100
    [Stack-GigabitEthernet0/0/1] quit
    

    # 配置接口GE1/0/1加入VLAN100。

    [Stack] interface gigabitethernet 1/0/1
    [Stack-GigabitEthernet1/0/1] port link-type access 
    [Stack-GigabitEthernet1/0/1] port default vlan 100
    [Stack-GigabitEthernet1/0/1] quit
    

  2. 配置接口加入Eth-Trunk

    # 配置接口GE0/0/4和GE1/0/4加入Eth-Trunk4。

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] quit
    [Stack] interface gigabitethernet 0/0/4
    [Stack-GigabitEthernet0/0/4] eth-trunk 4
    [Stack-GigabitEthernet0/0/4] quit
    [Stack] interface gigabitethernet 1/0/4
    [Stack-GigabitEthernet1/0/4] eth-trunk 4
    [Stack-GigabitEthernet1/0/4] quit

    # 配置接口GE0/0/5和GE1/0/5加入Eth-Trunk5。

    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] quit
    [Stack] interface gigabitethernet 0/0/5
    [Stack-GigabitEthernet0/0/5] eth-trunk 5
    [Stack-GigabitEthernet0/0/5] quit
    [Stack] interface gigabitethernet 1/0/5
    [Stack-GigabitEthernet1/0/5] eth-trunk 5
    [Stack-GigabitEthernet1/0/5] quit

  3. 配置自环口Eth-Trunk4和Eth-Trunk5

    # 去使能接口Eth-Trunk4和Eth-Trunk5的STP/RSTP/VBST/MSTP功能。

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] undo stp enable
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] undo stp enable
    [Stack-Eth-Trunk5] quit
    

    # 配置接口Eth-Trunk4和Eth-Trunk5以Access类型分别加入VLAN100和VLAN200。

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] port link-type access
    [Stack-Eth-Trunk4] port default vlan 100
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] port link-type access
    [Stack-Eth-Trunk5] port default vlan 200
    [Stack-Eth-Trunk5] quit

  4. 配置NLB服务器群集网关的IP地址

    [Stack] interface vlanif 200
    [Stack-Vlanif200] ip address 10.128.246.250 24
    [Stack-Vlanif200] quit
    

  5. 配置静态ARP表项,静态ARP表项的IP地址为群集IP地址10.128.246.252,MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口Eth-Trunk5

    [Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5 

  6. 连接接口Switch_1上的GE0/0/4和GE0/0/5、Switch_2上的GE1/0/4和GE1/0/5

    上述配置完成后,进行物理连线。

  7. 检查配置结果

    上述配置完成后,发往NLB服务器群集IP地址的报文Server_1和Server_2都能收到。

配置文件

Stack的配置文件

#
sysname Stack
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                             
 ip address 10.128.246.250 255.255.255.0                                        
#
interface Eth-Trunk4                                                            
 port link-type access                                                          
 port default vlan 100                                                          
 stp disable                                                                    
#                                                                                
interface Eth-Trunk5                                                            
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                    
#                                                                                
interface GigabitEthernet0/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                               
# 
interface GigabitEthernet0/0/4
 eth-trunk 4
# 
interface GigabitEthernet0/0/5
 eth-trunk 5
# 
interface GigabitEthernet1/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                                
#                                                                               
interface GigabitEthernet1/0/4                                                 
 eth-trunk 4                                                                    
#                                                                               
interface GigabitEthernet1/0/5                                                 
 eth-trunk 5                                                                    
#
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5 
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141438

浏览量:10213

下载量:17

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页