所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6 over IPv4手动隧道示例

配置IPv6 over IPv4手动隧道示例

组网需求

图12-12所示,两个IPv6网络分别通过SwitchA和SwitchC与IPv4骨干网络中的SwitchB连接,客户希望两个IPv6网络能通过IPv4骨干网互通。

图12-12  配置IPv6 over IPv4手动隧道组网图

配置思路

配置IPv6 over IPv4手动隧道的思路如下:

  1. 配置接口的IP地址,使设备可以和IPv4骨干网进行通信。

  2. 配置隧道接口的IPv6地址、源接口、目的地址,使设备可以和IPv6网络进行通信。

  3. 配置协议类型为IPv6-IPv4,使IPv6网络可以通过IPv4骨干网进行通信。

操作步骤

  1. 配置SwitchA

    # 配置业务环回聚合接口。
    说明:

    对于支持内部环回口的单板,此步骤为可选。详细内容请参考(可选)配置业务环回聚合接口

    此处做业务环回聚合的接口必须是空闲的,没有承载业务的接口。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] service type tunnel
    [SwitchA-Eth-Trunk1] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/3] quit
    

    # 配置接口的IP地址。

    [SwitchA] ipv6
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 192.168.50.2 255.255.255.0
    [SwitchA-Vlanif100] quit

    # 配置协议类型为IPv6-IPv4。

    [SwitchA] interface tunnel 1
    [SwitchA-Tunnel1] tunnel-protocol ipv6-ipv4
    [SwitchA-Tunnel1] eth-trunk 1

    # 配置隧道接口的IPv6地址、目的地址。

    [SwitchA-Tunnel1] ipv6 enable
    [SwitchA-Tunnel1] ipv6 address fc00:3::1 64
    [SwitchA-Tunnel1] source vlanif 100
    [SwitchA-Tunnel1] destination 192.168.51.2
    [SwitchA-Tunnel1] quit

    # 配置静态路由。

    [SwitchA] ip route-static 192.168.51.2 255.255.255.0 192.168.50.1

  2. 配置SwitchB

    # 配置接口的IP地址。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 200
    [SwitchB-vlan200] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 192.168.50.1 255.255.255.0
    [SwitchB-Vlanif100] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] ip address 192.168.51.1 255.255.255.0
    [SwitchB-Vlanif200] quit

  3. 配置SwitchC

    # 配置业务环回聚合接口。
    说明:

    对于支持内部环回口的单板,此步骤为可选。详细内容请参考(可选)配置业务环回聚合接口

    此处做业务环回聚合的接口必须是空闲的,没有承载业务的接口。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] interface eth-trunk 1
    [SwitchC-Eth-Trunk1] service type tunnel
    [SwitchC-Eth-Trunk1] quit
    [SwitchC] interface gigabitethernet 1/0/3
    [SwitchC-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchC-GigabitEthernet1/0/3] quit
    

    # 配置接口的IP地址。

    [SwitchC] ipv6
    [SwitchC] vlan 200
    [SwitchC-vlan200] quit
    [SwitchC] interface gigabitethernet1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 200
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 200
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface vlanif 200
    [SwitchC-Vlanif200] ip address 192.168.51.2 255.255.255.0
    [SwitchC-Vlanif200] quit

    # 配置协议类型为IPv6-IPv4。

    [SwitchC] interface tunnel 1
    [SwitchC-Tunnel1] tunnel-protocol ipv6-ipv4
    [SwitchC-Tunnel1] eth-trunk 1

    # 配置隧道接口的IPv6地址、目的地址。

    [SwitchC-Tunnel1] ipv6 enable
    [SwitchC-Tunnel1] ipv6 address fc00:3::2 64
    [SwitchC-Tunnel1] source vlanif 200
    [SwitchC-Tunnel1] destination 192.168.50.2
    [SwitchC-Tunnel1] quit

    # 配置静态路由。

    [SwitchC] ip route-static 192.168.50.2 255.255.255.0 192.168.51.1

  4. 检查配置结果

    # 在SwitchC上Ping SwitchA的VLANIF100的IPv4地址,可收到返回的报文。

    [SwitchC] ping 192.168.50.2
      PING 192.168.50.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.50.2: bytes=56 Sequence=1 ttl=253 time=84 ms
        Reply from 192.168.50.2: bytes=56 Sequence=2 ttl=253 time=27 ms
        Reply from 192.168.50.2: bytes=56 Sequence=3 ttl=253 time=25 ms
        Reply from 192.168.50.2: bytes=56 Sequence=4 ttl=253 time=3 ms
        Reply from 192.168.50.2: bytes=56 Sequence=5 ttl=253 time=24 ms
    
      --- 192.168.50.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/32/84 ms

    # 在SwitchC上Ping隧道的SwitchA接口Tunnel1的IPv6地址,可收到返回的报文。

    [SwitchC] ping ipv6 FC00:3::1
      PING FC00:3::1 : 56  data bytes, press CTRL_C to break
        Reply from FC00:3::1
        bytes=56 Sequence=1 hop limit=64  time = 28 ms
        Reply from FC00:3::1
        bytes=56 Sequence=2 hop limit=64  time = 27 ms
        Reply from FC00:3::1
        bytes=56 Sequence=3 hop limit=64  time = 26 ms
        Reply from FC00:3::1
        bytes=56 Sequence=4 hop limit=64  time = 27 ms
        Reply from FC00:3::1
        bytes=56 Sequence=5 hop limit=64  time = 26 ms
    
      --- FC00:3::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 26/26/28 ms

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 192.168.50.2 255.255.255.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::1/64
     tunnel-protocol ipv6-ipv4
     source Vlanif100
     destination 192.168.51.2
     eth-trunk 1
    #
    ip route-static 192.168.51.0 255.255.255.0 192.168.50.1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 192.168.50.1 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.51.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 200
    #
    interface Vlanif200
     ip address 192.168.51.2 255.255.255.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::2/64
     tunnel-protocol ipv6-ipv4
     source Vlanif200
     destination 192.168.50.2
     eth-trunk 1
    #
    ip route-static 192.168.50.0 255.255.255.0 192.168.51.1
    #
    return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141459

浏览量:20007

下载量:846

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页