所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4 over IPv6隧道示例

配置IPv4 over IPv6隧道示例

组网需求

图13-2,两个IPv4网络分别通过SwitchA和SwitchE与IPv6网络连接。IPv6网络的边界设备SwitchB和SwitchD支持IPv4和IPv6双协议栈。要求在SwitchB和SwitchD之间配置IPv4 over IPv6隧道,使这两个物理分离的IPv4网络可以互通。

图13-2  IPv4 over IPv6隧道组网图

配置思路

本例按如下思路进行配置:

  1. 在两端IPv6网络边界设备上配置IPv4 over IPv6隧道。

  2. 配置经过该隧道接口转发的路由。

操作步骤

  1. 在SwitchB上配置业务环回聚合接口。

    说明:

    此处做业务环回聚合的接口必须是空闲的,没有承载业务的接口。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] interface eth-trunk 1
    [SwitchB-Eth-Trunk1] service type tunnel
    [SwitchB-Eth-Trunk1] quit
    [SwitchB] interface gigabitethernet 1/0/3
    [SwitchB-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchB-GigabitEthernet1/0/3] quit
    

  2. 在SwitchD上配置业务环回聚合接口。

    说明:

    此处做业务环回聚合的接口必须是空闲的,没有承载业务的接口。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchD
    [SwitchD] interface eth-trunk 1
    [SwitchD-Eth-Trunk1] service type tunnel
    [SwitchD-Eth-Trunk1] quit
    [SwitchD] interface gigabitethernet 1/0/3
    [SwitchD-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchD-GigabitEthernet1/0/3] quit
    

  3. 配置IS-IS(IPv6),实现IPv6网络的IP连通性。

    # 配置SwitchB。

    [SwitchB] ipv6
    [SwitchB] vlan batch 100 200
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] ipv6 enable
    [SwitchB-Vlanif200] ipv6 address fc00:1::1 64
    [SwitchB-Vlanif200] quit
    [SwitchB] isis 1
    [SwitchB-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchB-isis-1] ipv6 enable topology standard
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] isis ipv6 enable 1
    [SwitchB-Vlanif200] quit

    # 配置SwitchC。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] ipv6
    [SwitchC] vlan batch 100 200
    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 200
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 200
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchC-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [SwitchC-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [SwitchC-GigabitEthernet1/0/2] quit
    [SwitchC] interface vlanif 200
    [SwitchC-Vlanif200] ipv6 enable
    [SwitchC-Vlanif200] ipv6 address fc00:1::2 64
    [SwitchC-Vlanif200] quit
    [SwitchC] interface vlanif 100
    [SwitchC-Vlanif100] ipv6 enable
    [SwitchC-Vlanif100] ipv6 address fc00:2::1 64
    [SwitchC-Vlanif100] quit
    [SwitchC] isis 1
    [SwitchC-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchC-isis-1] ipv6 enable topology standard
    [SwitchC-isis-1] quit
    [SwitchC] interface vlanif 100
    [SwitchC-Vlanif100] isis ipv6 enable 1
    [SwitchC-Vlanif100] quit
    [SwitchC] interface vlanif 200
    [SwitchC-Vlanif200] isis ipv6 enable 1
    [SwitchC-Vlanif200] quit
    

    # 配置SwitchD。

    [SwitchD] ipv6
    [SwitchD] vlan batch 100 200
    [SwitchD] interface gigabitethernet 1/0/1
    [SwitchD-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchD-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchD-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchD-GigabitEthernet1/0/1] quit
    [SwitchD] interface vlanif 100
    [SwitchD-Vlanif100] ipv6 enable
    [SwitchD-Vlanif100] ipv6 address fc00:2::2 64
    [SwitchD-Vlanif100] quit
    [SwitchD] isis 1
    [SwitchD-isis-1] network-entity 10.0000.0000.0003.00
    [SwitchD-isis-1] ipv6 enable topology standard
    [SwitchD-isis-1] quit
    [SwitchD] interface vlanif 100
    [SwitchD-Vlanif100] isis ipv6 enable 1
    [SwitchD-Vlanif100] quit
    

  4. 配置IPv4网络的物理接口IPv4地址和OSPF,实现IPv4网络的IP连通性。

    # 配置SwitchA。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.2.2 30
    [SwitchA-Vlanif100] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.3
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.2.1 30
    [SwitchB-Vlanif100] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.3
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchD。

    [SwitchD] interface gigabitethernet 1/0/2
    [SwitchD-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchD-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [SwitchD-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchD-GigabitEthernet1/0/2] quit
    [SwitchD] interface vlanif 200
    [SwitchD-Vlanif200] ip address 10.1.3.1 30
    [SwitchD-Vlanif200] quit
    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.3
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    # 配置SwitchE。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchE
    [SwitchE] vlan batch 200
    [SwitchE] interface gigabitethernet 1/0/1
    [SwitchE-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchE-GigabitEthernet1/0/1] port hybrid pvid vlan 200
    [SwitchE-GigabitEthernet1/0/1] port hybrid untagged vlan 200
    [SwitchE-GigabitEthernet1/0/1] quit
    [SwitchE] interface vlanif 200
    [SwitchE-Vlanif200] ip address 10.1.3.2 30
    [SwitchE-Vlanif200] quit
    [SwitchE] ospf 1
    [SwitchE-ospf-1] area 0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.3
    [SwitchE-ospf-1-area-0.0.0.0] quit
    [SwitchE-ospf-1] quit

  5. 配置Tunnel接口。

    # 配置SwitchB。

    [SwitchB] interface tunnel 2
    [SwitchB-Tunnel2] tunnel-protocol ipv4-ipv6
    [SwitchB-Tunnel2] ip address 10.1.1.1 30
    [SwitchB-Tunnel2] eth-trunk 1
    [SwitchB-Tunnel2] source vlanif 200
    [SwitchB-Tunnel2] destination fc00:2::2
    [SwitchB-Tunnel2] quit

    # 配置SwitchD。

    [SwitchD] interface tunnel 1
    [SwitchD-Tunnel1] tunnel-protocol ipv4-ipv6
    [SwitchD-Tunnel1] ip address 10.1.1.2 30
    [SwitchD-Tunnel1] eth-trunk 1
    [SwitchD-Tunnel1] source vlanif 100
    [SwitchD-Tunnel1] destination fc00:1::1
    [SwitchD-Tunnel1] quit

  6. 配置SwitchA和SwitchE之间的静态路由。

    # 配置SwitchA。

    [SwitchA] ip route-static 10.1.3.2 255.255.255.252 vlanif 100 10.1.2.1
    

    # 配置SwitchE。

    [SwitchE] ip route-static 10.1.2.2 255.255.255.252 vlanif 200 10.1.3.1
    

  7. 配置Tunnel两端的静态路由。

    # 配置SwitchB。

    [SwitchB] ip route-static 10.1.3.2 255.255.255.252 tunnel 2
    

    # 配置SwitchD。

    [SwitchD] ip route-static 10.1.2.2 255.255.255.252 tunnel 1
    

  8. 检查配置结果。

    完成上述配置后,在SwitchB和SwitchD上查看隧道接口,可看到隧道接口的协议状态为Up。

    [SwitchB] display interface tunnel 2
    Tunnel2 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2014-12-24 17:03:42
    Description: 
    Route Port,The Maximum Transmit Unit is 1500
    Internet Address is 10.1.1.1/30
    Encapsulation is TUNNEL6, loopback not set
    Tunnel protocol/transport (IPv6 or IPv4) over IPv6
    Tunnel Source FC00:1::1 (Vlanif200)
    Tunnel Destination FC00:2::2
    Tunnel Encapsulation limit 4
    Tunnel Traffic class not set
    Tunnel Flow label not set
    Tunnel Hop limit 64
    Current system time: 2014-12-24 17:04:18
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%

    SwitchA上ping SwitchE的VLANIF200接口,可以收到返回的报文。

    [SwitchA] ping 10.1.3.2
      PING 10.1.3.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.3.2: bytes=56 Sequence=1 ttl=254 time=20 ms
        Reply from 10.1.3.2: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.1.3.2: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.1.3.2: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.1.3.2: bytes=56 Sequence=5 ttl=254 time=1 ms
    
      --- 10.1.3.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/4/20 ms

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.2.2 255.255.255.252
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ospf 1 
     area 0.0.0.0  
      network 10.1.2.0 0.0.0.3
    #
    ip route-static 10.1.3.0 255.255.255.252 Vlanif100 10.1.2.1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 100 200
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif100
     ip address 10.1.2.1 255.255.255.252 
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:1::1/64
     isis ipv6 enable 1
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface Tunnel2
     ip address 10.1.1.1 255.255.255.252
     tunnel-protocol ipv4-ipv6
     source Vlanif200
     destination FC00:2::2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    ospf 1 
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.3
    #
    ip route-static 10.1.3.0 255.255.255.252 Tunnel2
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 100 200
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::1/64
     isis ipv6 enable 1
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:1::2/64
     isis ipv6 enable 1
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    ipv6
    #
    vlan batch 100 200
    #
    isis 1
     network-entity 10.0000.0000.0003.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::2/64
     isis ipv6 enable 1
    #
    interface Vlanif200
     ip address 10.1.3.1 255.255.255.252
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ip address 10.1.1.2 255.255.255.252
     tunnel-protocol ipv4-ipv6
     source Vlanif100
     destination FC00:1::1
     eth-trunk 1
    #
    ospf 1 
     area 0.0.0.0 
      network 10.1.3.0 0.0.0.3
    #
    ip route-static 10.1.2.0 255.255.255.252 Tunnel1
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 200
    #
    interface Vlanif200
     ip address 10.1.3.2 255.255.255.252
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ospf 1 
     area 0.0.0.0 
      network 10.1.3.0 0.0.0.3
    #
    ip route-static 10.1.2.0 255.255.255.252 Vlanif200 10.1.3.1
    #
    return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141459

浏览量:18696

下载量:841

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页