所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态ARP示例

配置静态ARP示例

组网需求

图2-18所示,企业通过Switch实现各个部门之间的互连,且各个部门加入不同的VLAN。总裁办公室和文件备份服务器采取手工方式分配已经获取到固定IP地址,市场部和研发部主机通过DHCP方式已经获取到动态IP地址。由于市场部拥有访问外网的权利,主机经常会感染ARP病毒,攻击Switch并修改Switch上的动态ARP表项,造成总裁办公室与外界的通信中断以及各个部门不能正常访问文件备份服务器。公司希望在Switch上配置静态ARP表项,以保证总裁办公室与外界的通信安全,并保证各个部门能正常访问文件备份服务器。

图2-18  配置静态ARP组网图

配置思路

静态ARP的配置思路如下:

  1. 在Switch上为总裁办公室主机配置静态ARP表项,防止总裁办公室主机的ARP表项被ARP攻击报文修改,造成总裁办公室与外界的通信中断。
  2. 在Switch上为文件备份服务器配置静态ARP表项,防止文件备份服务器的ARP表项被ARP攻击报文修改,造成各个部门不能正常访问文件备份服务器。

操作步骤

  1. 在Switch上创建VLAN,并配置各接口的IP地址

    # 创建VLAN10,将接口加入VLAN10,并配置接口VLANIF10的IP地址。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.164.1.20 24
    [Switch-Vlanif10] quit

    # 配置接口GE1/0/2为主接口,并配置接口的IP地址。

    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] undo portswitch
    [Switch-GigabitEthernet1/0/2] ip address 10.164.10.10 24
    [Switch-GigabitEthernet1/0/2] quit

    # 配置接口GE1/0/3为主接口,并配置接口的IP地址。

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] undo portswitch
    [Switch-GigabitEthernet1/0/3] ip address 10.164.20.1 24
    [Switch-GigabitEthernet1/0/3] quit

  2. 在Switch上配置静态ARP表项

    [Switch] arp static 10.164.1.1 00e0-fc01-0001 vid 10 interface gigabitethernet 1/0/1
    [Switch] arp static 10.164.10.1 0df0-fc01-003a interface gigabitethernet 1/0/2

  3. 验证配置结果

    # 执行命令display arp static,查看已配置的静态ARP表项。

    [Switch] display arp static
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE
                                              VLAN/CEVLAN
    ------------------------------------------------------------------------------
    10.164.1.1      00e0-fc01-0001            S--         GE1/0/1
                                                10/-
    10.164.10.1     0df0-fc01-003a            S--         GE1/0/2
    ------------------------------------------------------------------------------
    Total:2         Dynamic:0       Static:2     Interface:0

    # 在总裁办公室的主机(IP地址为10.164.1.1/24,操作系统以Windows 7为例)上Ping路由器上与Switch相连的接口IP地址10.164.20.2/24,可以Ping通。

    C:\Documents and Settings\Administrator> ping 10.164.20.2
    Pinging 10.164.20.2 with 32 bytes of data:
    Reply from 10.164.20.2: bytes=32 time=1ms TTL=128
    Reply from 10.164.20.2: bytes=32 time=1ms TTL=128
    Reply from 10.164.20.2: bytes=32 time=1ms TTL=128
    Reply from 10.164.20.2: bytes=32 time=1ms TTL=128
    
    Ping statistics for 10.164.20.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    # 在市场部的某主机(IP地址为10.164.2.100/24,操作系统以Windows 7为例)上Ping文件备份服务器的IP地址10.164.10.10/24,可以Ping通。

    C:\Documents and Settings\Administrator> ping 10.164.10.10
    Pinging 10.164.10.10 with 32 bytes of data:
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    
    Ping statistics for 10.164.10.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    # 在研发部的某主机(IP地址为10.164.3.100/24,操作系统以Windows 7为例)上Ping文件备份服务器的IP地址10.164.10.10/24,可以Ping通。

    C:\Documents and Settings\Administrator> ping 10.164.10.10
    Pinging 10.164.10.10 with 32 bytes of data:
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    Reply from 10.164.10.10: bytes=32 time=1ms TTL=125
    
    Ping statistics for 10.164.10.10:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

配置文件

Switch的配置文件。

#
sysname Switch
#
vlan batch 10
#
interface Vlanif10
 ip address 10.164.1.20 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 undo portswitch
 ip address 10.164.10.10 255.255.255.0
#
interface GigabitEthernet1/0/3
 undo portswitch
 ip address 10.164.20.1 255.255.255.0
#
arp static 10.164.1.1 00e0-fc01-0001 vid 10 interface GigabitEthernet1/0/1
arp static 10.164.10.1 0df0-fc01-003a interface GigabitEthernet1/0/2
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141459

浏览量:18704

下载量:841

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页