所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置多端口ARP示例

配置多端口ARP示例

组网需求

图2-22所示,Switch通过属于VLAN10的三个接口GE1/0/1GE1/0/2GE1/0/3分别连接三台NLB服务器。NLB服务器群集工作在组播模式。NLB服务器群集中每台服务器除了各自拥有一个IP地址和MAC地址外,还共同使用一个群集IP地址和群集MAC地址。NLB服务器的群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fc。Switch与客户端Client之间路由可达。

用户希望网络中客户端访问NLB服务器群集IP地址时,Switch能够将发往NLB服务器群集IP地址的报文发送给NLB服务器群集中的每台服务器。

图2-22  配置多端口ARP组网图

配置思路

多端口ARP的配置思路如下:

  1. 配置接口IP地址,并将接口加入相应VLAN。
  2. 配置对应多出接口的MAC地址表项,并配置静态ARP表项,实现Switch将发往NLB群集IP地址的报文发送给NLB群集内三台服务器。

操作步骤

  1. 创建VLAN,并将接口加入到VLAN中

    # 在Switch上创建VLAN,并将接口加入到VLAN中。
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type access
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] vlan 10
    [Switch-vlan10] port gigabitethernet 1/0/1 to 1/0/3
    [Switch-vlan10] quit
    

  2. Switch上创建VLANIF接口,并配置IP地址

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.128.246.251 24
    [Switch-Vlanif10] quit
    

  3. Switch上配置对应多出接口的MAC地址表项

    [Switch] mac-address multiport 03bf-0a80-f6fc interface gigabitethernet 1/0/1 to gigabitethernet 1/0/3 vlan 10
    

  4. Switch上配置静态ARP表项

    [Switch] arp static 10.128.246.252 03bf-0a80-f6fc
    [Switch] quit

  5. 验证配置结果

    # 在Switch上使用display mac-address multiport vlan 10命令,查看已配置的对应多出接口的MAC地址表项信息。

    <Switch> display mac-address multiport vlan 10
    --------------------------------------------------------------------------------
    MAC Address       VLANID    Out-Interface               Status                                                                      
    --------------------------------------------------------------------------------
    03bf-0a80-f6fc    10        GigabitEthernet1/0/1        Active                                
                                GigabitEthernet1/0/2        Active                                
                                GigabitEthernet1/0/3        Active                                
                                                3 port(s)                           
    --------------------------------------------------------------------------------
     Total Group(s) : 1 
    

    # 在Switch上使用display arp static命令,查看静态ARP表项信息。

    <Switch> display arp static
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE  
                                              VLAN/CEVLAN                           
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc            S--         Multi-port:3            
    ------------------------------------------------------------------------------  
    Total:1        Dynamic:0      Static:1     Interface:0 
    

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 
#
interface Vlanif10
 ip address 10.128.246.251 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10 
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141459

浏览量:20054

下载量:846

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页