所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
如何修改接口类型?

如何修改接口类型?

接口的链路类型总共有4种,分别为:Access、Trunk、Hybrid、Dot1q-tunnel。不同版本,接口类型的修改方法不同。
  • V200R005及后续版本:直接执行命令port link-type { access | trunk | hybrid | dot1q-tunnel },然后根据提示输入“y”或“n”。当接口上VLAN的配置为缺省配置时,不会出现提示信息,会直接修改链路类型。
    • 若输入“y”后回车,设备会自动删除接口上VLAN的非默认配置,然后设置接口的链路类型为指定的类型。
    • 若输入“n”后回车,设备不做任何处理,保持当前的链路类型和接口上的VLAN配置不变。
    例如:将接口类型修改为Hybrid。
    <HUAWEI> system-view
    [HUAWEI] interface GigabitEthernet1/0/1
    [HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
    Warning: This command will delete VLANs on this port. Continue?[Y/N]:y 
    Info: This operation may take a few seconds. Please wait for a moment...done.
  • V200R005以前版本:当接口上VLAN的缺省配置为默认加入VLAN 1,并且PVID为VLAN 1,可以执行命令port link-type { access | trunk | hybrid | dot1q-tunnel },修改接口类型。
    • 将接口类型修改为Access

      <HUAWEI> system-view
      [HUAWEI] interface GigabitEthernet1/0/1
      [HUAWEI-GigabitEthernet1/0/1] port link-type access
      [HUAWEI-GigabitEthernet1/0/1] port default vlan 10
    • 将接口类型修改为Trunk

      <HUAWEI> system-view
      [HUAWEI] interface GigabitEthernet1/0/1
      [HUAWEI-GigabitEthernet1/0/1] port link-type trunk
      [HUAWEI-GigabitEthernet1/0/1] port trunk pvid vlan 10
      [HUAWEI-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 10 20
    • 将接口类型修改为Hybrid

      <HUAWEI> system-view
      [HUAWEI] interface GigabitEthernet1/0/1
      [HUAWEI-GigabitEthernet1/0/1] port link-type hybrid
      [HUAWEI-GigabitEthernet1/0/1] port hybrid pvid vlan 10
      [HUAWEI-GigabitEthernet1/0/1] port hybrid untagged vlan 2 10
      [HUAWEI-GigabitEthernet1/0/1] port hybrid tagged vlan 20
    • 将接口类型修改为Dot1q-tunnel

      <HUAWEI> system-view
      [HUAWEI] interface GigabitEthernet1/0/1
      [HUAWEI-GigabitEthernet1/0/1] port link-type dot1q-tunnel
      [HUAWEI-GigabitEthernet1/0/1] port default vlan 10

    在修改链路类型时,如果接口上VLAN的配置不是缺省值,会出现以下提示信息:Error: Please renew the default configurations.

    此时需要先把接口上VLAN的配置恢复为缺省值,然后再修改链路类型。

    • 恢复Access或Dot1q-tunnel接口上VLAN的缺省配置
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet 1/0/1
      [HUAWEI-GigabitEthernet1/0/1] undo port default vlan
    • 恢复Trunk接口上VLAN的缺省配置
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet 1/0/1
      [HUAWEI-GigabitEthernet1/0/1] undo port trunk pvid vlan
      [HUAWEI-GigabitEthernet1/0/1] undo port trunk allow-pass vlan all
      [HUAWEI-GigabitEthernet1/0/1] port trunk allow-pass vlan 1
    • 恢复Hybrid接口上VLAN的缺省配置
      <HUAWEI> system-view
      [HUAWEI] interface gigabitethernet 1/0/1
      [HUAWEI-GigabitEthernet1/0/1] undo port hybrid pvid vlan
      [HUAWEI-GigabitEthernet1/0/1] undo port hybrid vlan all
      [HUAWEI-GigabitEthernet1/0/1] port hybrid untagged vlan 1
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84703

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页