所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过管理VLAN实现远程管理设备示例

配置通过管理VLAN实现远程管理设备示例

组网需求

图4-34所示,用户希望安全地登录到Switch进行远程管理,Switch上没有空闲管理网口。

图4-34  配置通过管理VLAN实现远程管理设备组网图

配置思路

用户可以通过管理网口或管理VLAN的VLANIF接口远程登录到设备进行管理。设备上没有空闲的管理网口,需要采用管理VLAN实现。同时,为了用户安全登录,采用STelnet登录方式。配置思路如下:

  1. Switch上配置管理VLAN,并将接口加入VLAN。

  2. Switch上配置VLANIF并指定IP地址。

  3. Switch上开启STelnet服务功能,并配置SSH用户。

  4. 用户PC以STelnet方式登录Switch

说明:
  • 用户PC上需要安装登录SSH服务器的软件以及密钥对生成软件、公钥转换软件。
  • 为充分保证设备安全,请用户定期修改密码。

操作步骤

  1. 配置管理VLAN,并将接口加入VLAN

    # 在Switch上创建VLAN10,并指定为管理VLAN,然后将接口GE1/0/1以Tagged方式加入VLAN10。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] management-vlan
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit

  2. 配置VLANIF接口及其IP地址

    # 在Switch上创建VLANIF10,并配置其IP地址为10.10.10.2/24。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.10.10.2 24
    [Switch-Vlanif10] quit
    

  3. 启用STelnet服务,并配置SSH用户

    1. Switch上生成本地密钥对

      [Switch] rsa local-key-pair create
      The key name will be: Switch_Host
      The range of public key size is (2048 ~ 2048).
      NOTES: If the key modulus is greater than 512,
       it will take a few minutes.
      Input the bits in the modulus[default = 2048]:     //按Enter键
      Generating keys...
      ...................+++++
      ........................++
      ....++++
      ...........++
    2. 配置SSH用户

      # 在Switch上配置VTY用户界面。

      [Switch] user-interface vty 0 14
      [Switch-ui-vty0-14] authentication-mode aaa
      [Switch-ui-vty0-14] protocol inbound ssh
      [Switch-ui-vty0-14] quit

      # 在Switch上新建用户名为client001的SSH用户,且认证方式为password。

      [Switch] aaa
      [Switch-aaa] local-user client001 password irreversible-cipher Huawei@123
      [Switch-aaa] local-user client001 privilege level 3
      [Switch-aaa] local-user client001 service-type ssh
      [Switch-aaa] quit
      [Switch] ssh user client001 authentication-type password
    3. 开启STelnet服务功能

      # 在Switch上开启STelnet服务功能。

      [Switch] stelnet server enable

      # 配置SSH用户client001的服务方式为STelnet

      [Switch] ssh user client001 service-type stelnet
    说明:

    PC和Switch之间通过其他设备相连,中间设备上需要透传管理VLAN10,并且存在10.1.1.1/24到10.10.10.2/24的路由表项。

  4. 验证配置结果

    配置完成后,用户PC即可采用password认证方式登录Switch

    # 在用户PC上运行putty软件,出现如图4-35所示对话框,输入Switch的IP地址10.10.10.2,选择协议类型为SSH。

    图4-35  配置通过管理VLAN实现远程管理设备组网图

    # 点击“Open”,Switch上出现如下界面,输入用户名和密码,并按Enter键。

    login as: client001
    SSH server: User Authentication
    Using keyboard-interactive authentication.
    Password:
    
    Info: The max number of VTY users is 10, and the number
          of current VTY users on line is 1.
          The current login time is 2014-02-25 05:45:41+00:00.
    <Switch>

    至此,用户PC已成功登录到Switch,可以对Switch进行远程管理。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10
#
vlan 10
 management-vlan
#
aaa
 local-user client001 password irreversible-cipher $1a$EqZEVTq=/@T2XM0q0W{Ec[Fs2@&4YII@-=(lbr[K>4Dq76]3#BgqMOAxu^%$$
 local-user client001 privilege level 3
 local-user client001 service-type ssh
#
interface Vlanif10
 ip address 10.10.10.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 10
# 
stelnet server enable
ssh user client001
ssh user client001 authentication-type password
ssh user client001 service-type stelnet
# 
user-interface vty 0 14
 authentication-mode aaa
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84489

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页