所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置GVRP示例

配置GVRP示例

组网需求

图12-10所示,公司A、公司A的分公司以及公司B之间有较多的交换设备相连,需要通过GVRP功能,实现VLAN的动态注册。公司A的分公司与总部通过SwitchA和SwitchB互通;公司B通过SwitchB和SwitchC与公司A互通,但只允许公司B配置的VLAN通过。

图12-10  配置GVRP的组网图

配置思路

采用如下的思路配置GVRP:

  1. 使能GVRP功能,实现VLAN的动态注册。

  2. 公司A的所有交换机配置GVRP功能并配置接口注册模式为Normal,以简化配置。

  3. 公司B的所有交换机配置GVRP功能并将与公司A相连的接口的注册模式配置为Fixed,以控制只允许公司B配置的VLAN通过。

说明:

使能GVRP之前,必须先设置VCMP的角色为Transparent或Silent。

操作步骤

  1. 配置交换机SwitchA

    # 全局使能GVRP功能。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vcmp role silent
    [SwitchA] gvrp
    

    # 配置接口为Trunk类型,并允许所有VLAN通过。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchA-GigabitEthernet1/0/2] quit
    

    # 使能接口的GVRP功能,并配置接口注册模式。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] gvrp
    [SwitchA-GigabitEthernet1/0/1] gvrp registration normal
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] gvrp
    [SwitchA-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. 配置交换机SwitchB

    # 全局使能GVRP功能。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vcmp role silent
    [SwitchB] gvrp
    

    # 配置接口为Trunk类型,并允许所有VLAN通过。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchB-GigabitEthernet1/0/2] quit
    

    # 使能接口的GVRP功能,并配置接口注册模式。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] gvrp
    [SwitchB-GigabitEthernet1/0/1] gvrp registration normal
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] gvrp
    [SwitchB-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchB-GigabitEthernet1/0/2] quit
    

  3. 配置交换机SwitchC

    # 创建VLAN101~VLAN200。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 101 to 200
    

    # 全局使能GVRP功能。

    [SwitchC] vcmp role silent
    [SwitchC] gvrp
    

    # 配置接口为Trunk类型,并允许所有VLAN通过。

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type trunk
    [SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan all
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] port link-type trunk
    [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan all
    [SwitchC-GigabitEthernet1/0/2] quit
    

    # 使能接口的GVRP功能,并配置接口注册模式。

    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] gvrp
    [SwitchC-GigabitEthernet1/0/1] gvrp registration fixed
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface gigabitethernet 1/0/2
    [SwitchC-GigabitEthernet1/0/2] gvrp
    [SwitchC-GigabitEthernet1/0/2] gvrp registration normal
    [SwitchC-GigabitEthernet1/0/2] quit
    

  4. 验证配置结果

    配置完成后,公司A的分公司用户可以与总部互通,公司A属于VLAN101~VLAN200的用户可以与公司B用户互通。

    在SwitchA上使用命令display gvrp statistics,查看接口的GVRP统计信息,其中包括:GVRP状态、GVRP注册失败次数、上一个GVRP数据单元源MAC地址和接口GVRP注册类型,结果如下:

    [SwitchA] display gvrp statistics
    
      GVRP statistics on port GigabitEthernet1/0/1 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    
      GVRP statistics on port GigabitEthernet1/0/2 
        GVRP status                         : Enabled                               
        GVRP registrations failed           : 0                                     
        GVRP last PDU origin                : 0000-0000-0000                        
        GVRP registration type              : Normal
    Info: GVRP is disabled on one or multiple ports.
    

    SwitchB和SwitchC的查看方法与SwitchA类似,这里不再赘述。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vcmp role silent
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vcmp role silent
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vcmp role silent
    #
    vlan batch 101 to 200
    #
    gvrp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
     gvrp registration fixed
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
     gvrp
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84463

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页