所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过Loop Detection检测设备下挂网络环路示例

配置通过Loop Detection检测设备下挂网络环路示例

组网需求

图20-5所示,某企业新建分支网络接入到汇聚交换机Switch,该新建分支网络所属VLAN范围为10~20。新建网络可能因连接或配置错误而产生环路,进而影响到Switch及其上行网络的通信。

用户希望能在Switch上及时检测到新建分支网络中的环路,防止环路对Switch及其上行网络的冲击。

图20-5  配置通过Loop Detection检测设备下挂网络环路示例组网图

配置思路

由于新建分支网络属于VLAN 10~20,需要检测的VLAN数大于8,因此需要在Switch上配置Loop Detection功能来检测该网络是否存在环路。可采用如下思路配置Loop Detection功能:

  1. Switch的接口GE1/0/1上使能Loop Detection功能,并配置对指定VLAN进行环路检测,实现对下行网络环路的检测。
  2. 配置Loop Detection处理动作,实现Switch在检测到环路后能及时关闭接口以防止环路影响Switch及其上行网络的通信。
说明:
  • 新建网络中的交换设备上需要配置接口的链路类型为Trunk或Hybrid,并允许相应的VLAN通过,以保证新建网络内以及新建网络与Switch间的二层互通。

  • 本示例的配置也可实现交换设备间连接接口的自环检测。

操作步骤

  1. 使能全局的Loop Detection功能

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] loop-detection enable

  2. 使能VLAN的Loop Detection功能

    [Switch] vlan batch 10 to 20
    [Switch] loop-detection enable vlan 10 to 20

  3. 配置Loop Detection检测报文的发送周期

    [Switch] loop-detection interval-time 10

  4. 配置Loop Detection处理动作

    # 打开Loop Detection告警开关。

    [Switch] snmp-agent trap enable feature-name ldttrap

    配置Loop Detection处理动作为Shutdown。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] stp disable
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 10 to 20
    [Switch-GigabitEthernet1/0/1] loop-detection mode port-shutdown
    [Switch-GigabitEthernet1/0/1] quit

  5. 检查配置结果

    # 配置完成后,执行命令display loop-detection,查看设备上全局环路检测运行情况。

    [Switch] display loop-detection
    Loop Detection is enabled.                                                      
    Detection interval time is 10 seconds.                                           
    Following VLANs enable loop-detection: 
     VLAN  10 to 20         
    Following ports are blocked for loop:                                           
    NULL                                                                            
    Following ports are shutdown for loop:                                          
    GigabitEthernet1/0/1     Include Vlans: 
    10                                                                            
    Following ports are nolearning for loop:                                        
    NULL                                                                            
    Following ports are trapped for loop:                                           
    NULL                                                                            
    Following ports are quitvlan for loop:                                          
    NULL

    # 查看GE1/0/1接口的环路检测运行情况。

    [Switch] display loop-detection interface gigabitethernet 1/0/1
    The port is enabled.                                                            
    The port's status list:                                                         
    Status              WorkMode            Recovery-time       EnabledVLAN         
    -----------------------------------------------------------------------         
    Shutdown           Shutdown            255                 10                  
    Normal              Shutdown            255                 11                  
    Normal              Shutdown            255                 12                  
    Normal              Shutdown            255                 13                  
    Normal              Shutdown            255                 14                  
    Normal              Shutdown            255                 15                  
    Normal              Shutdown            255                 16                  
    Normal              Shutdown            255                 17                  
    Normal              Shutdown            255                 18                  
    Normal              Shutdown            255                 19                  
    Normal              Shutdown            255                 20                  

    可以看到,VLAN 10~20使能了Loop Detection功能,接口GE1/0/1在VLAN 10上被执行了Shutdown动作,说明VLAN 10检测到了环路。

    说明:

    对于Shutdown处理动作,系统检测到某个或某些VLAN环路后会Shutdown接口,环路就会消失,因而可能无法检测到所有成环VLAN。

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 to 20
#
loop-detection enable
loop-detection interval-time 10
loop-detection enable vlan 10 to 20
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10 to 20
 stp disable
#
snmp-agent
snmp-agent local-engineid 800007DB03020000000211
snmp-agent sys-info version v3 
snmp-agent trap enable feature-name LDTTRAP
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85328

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页