所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RRPP相切环示例

配置RRPP相切环示例

组网需求

在以太网组网中,主要会采用两级环网架构:

  • 一级为汇聚层,处于PE-AGG汇聚设备之间,如图18-37中的RRPP Domain 1。

  • 一级为接入层,处于PE-AGG与UPE之间,如图18-37中的RRPP Domain 2和RRPP Domain 3。

图18-37  RRPP相切环应用示例

图18-37所示,这种网络结构需要当环网完整时,可以避免报文成环;当环网发生故障时,可以实现快速收敛迅速恢复环网上各节点间的通信。RRPP可以很好地满足这两个需求。并且RRPP支持配置多个RRPP环,我们可以把汇聚层和接入层均配置为RRPP环,两者以相切的方式相连,使得组网配置更为简洁。

为了更好地介绍RRPP的配置,我们将图18-37组网中设备PE-AGG1、PE-AGG2、PE-AGG3、UPE1、UPE2抽象出来,对应图18-38中的SwitchE、SwitchD、SwitchC、SwitchA和SwitchB。下面将以图18-38中所示组网为例,为大家介绍RRPP单实例相切环的相关配置。

图18-38  配置RRPP相切环组网图

配置思路

采用如下的思路配置RRPP相切环示例:

  1. 创建不同的RRPP域和控制VLAN,为后续配置RRPP环做好准备。

  2. 将RRPP环Ring1上需要通过的VLAN数据映射到实例1,包括数据VLAN和控制VLAN,为后续配置保护VLAN做好准备。

    将RRPP环Ring2上需要通过的VLAN数据映射到实例2,包括数据VLAN和控制VLAN,为后续配置保护VLAN做好准备。

  3. 配置不同RRPP域的定时器。

    说明:

    因为两个相切环处于不同的域内,所以相切点的定时器可以针对性地配置两个。

  4. 配置设备上将要加入RRPP的各接口,使其可以通过RRPP环上需要通过的VLAN数据,并去使能与RRPP相冲突的功能(例如STP功能)。

  5. 在各RRPP域中,配置保护VLAN并创建RRPP环。
    1. SwitchA、SwitchB和SwitchC配置为域为2的环2。

    2. SwitchC、SwitchE和SwitchD配置为域为1的环1。

    3. 配置SwitchA为环2的主节点,SwitchB和SwitchC为环2的传输节点。

    4. 配置SwitchE为环1的主节点,SwitchC和SwitchD为环1的传输节点。

  6. 在各设备上使能RRPP环和RRPP协议,使得RRPP功能生效。

操作步骤

  1. 创建实例2,映射允许通过的数据VLAN和控制VLAN。

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA类似,此处省略,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 2 vlan 20 to 21
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

  2. 创建RRPP域,同时创建域的控制VLAN和保护VLAN

    # 配置SwitchE。SwitchB、SwitchC、SwitchD和SwitchA的配置与SwitchE类似,此处省略,详见配置文件。

    [SwitchE] rrpp domain 1
    [SwitchE-rrpp-domain-region1] control-vlan 10
    [SwitchE-rrpp-domain-region1] protected-vlan reference-instance 1 
    [SwitchE-rrpp-domain-region1] quit

  3. 设置RRPP域定时器的值

    # 配置环1主节点SwitchE的定时器。

    [SwitchE] rrpp domain 1
    [SwitchE-rrpp-domain-region1] timer hello-timer 2 fail-timer 7
    [SwitchE-rrpp-domain-region1] quit

    # 配置环1传输节点SwitchD的定时器。

    [SwitchD] rrpp domain 1
    [SwitchD-rrpp-domain-region1] timer hello-timer 2 fail-timer 7
    [SwitchD-rrpp-domain-region1] quit

    # 配置环1传输节点SwitchC的定时器。

    [SwitchC] rrpp domain 1
    [SwitchC-rrpp-domain-region1] timer hello-timer 2 fail-timer 7
    [SwitchC-rrpp-domain-region1] quit

    # 配置环2主节点SwitchA的定时器。

    [SwitchA] rrpp domain 2
    [SwitchA-rrpp-domain-region2] timer hello-timer 3 fail-timer 10
    [SwitchA-rrpp-domain-region2] quit

    # 配置环2传输节点SwitchB的定时器。

    [SwitchB] rrpp domain 2
    [SwitchB-rrpp-domain-region2] timer hello-timer 3 fail-timer 10
    [SwitchB-rrpp-domain-region2] quit

    # 配置环2传输节点SwitchC的定时器。

    [SwitchC] rrpp domain 2
    [SwitchC-rrpp-domain-region2] timer hello-timer 3 fail-timer 10
    [SwitchC-rrpp-domain-region2] quit

  4. 将即将加入RRPP环的接口配置为Trunk类型接口,并去使能接口的STP功能

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相同,此处省略,详见配置文件。

    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit

  5. 创建并使能RRPP环

    • 配置环2上的节点,步骤如下:

      # 配置SwitchA为RRPP环2的主节点,并指定主副接口。

      [SwitchA] rrpp domain 2
      [SwitchA-rrpp-domain-region2] ring 2 node-mode master primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchA-rrpp-domain-region2] ring 2 enable
      [SwitchA-rrpp-domain-region2] quit

      # 配置SwitchB为RRPP主环2的传输节点,并指定主副接口。

      [SwitchB] rrpp domain 2
      [SwitchB-rrpp-domain-region2] ring 2 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchB-rrpp-domain-region2] ring 2 enable
      [SwitchB-rrpp-domain-region2] quit

      # 配置SwitchC为RRPP环2的传输节点,并指定主副接口。

      [SwitchC] rrpp domain 2
      [SwitchC-rrpp-domain-region2] ring 2 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchC-rrpp-domain-region2] ring 2 enable
      [SwitchC-rrpp-domain-region2] quit
    • 配置环1上的节点,步骤如下:

      # 配置SwitchE为RRPP主环1的主节点,并指定主副接口。

      [SwitchE] rrpp domain 1
      [SwitchE-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchE-rrpp-domain-region1] ring 1 enable
      [SwitchE-rrpp-domain-region1] quit

      # 配置SwitchC为RRPP环1的传输节点,并指定主副接口。

      [SwitchC] rrpp domain 1
      [SwitchC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchC-rrpp-domain-region1] ring 1 enable
      [SwitchC-rrpp-domain-region1] quit

      # 配置SwitchD为RRPP环1的传输节点,并指定主副接口。

      [SwitchD] rrpp domain 1
      [SwitchD-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchD-rrpp-domain-region1] ring 1 enable
      [SwitchD-rrpp-domain-region1] quit

  6. 使能RRPP协议

    # 配置SwitchA。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相同,此处省略,详见配置文件。

    [SwitchA] rrpp enable

  7. 检查配置结果

    经过以上配置,在网络计算稳定后,执行以下操作,验证配置结果。以相切点SwitchC为例。

    # 在SwitchC上执行display rrpp brief命令,查看结果如下:

    [SwitchC] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status: Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 2 sec(default is 1 sec)  Fail Timer : 7 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    1     0      T     GigabitEthernet1/0/1     GigabitEthernet1/0/2     Yes
    
    Domain Index   : 2
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 2
    Hello Timer    : 3 sec(default is 1 sec)  Fail Timer : 10 sec(default is 6 sec)
    
    Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
    ID    Level  Mode  Port                     Port                     Enabled
    ----------------------------------------------------------------------------
    2     0      T     GigabitEthernet2/0/1    GigabitEthernet2/0/2     Yes
    

    可以看到SwitchC的RRPP协议状态使能了,在域1中的主控制VLAN为10,子控制Vlan为11,SwitchC为主环1中的传输节点。主端口为GigabitEthernet1/0/1,副端口为GigabitEthernet1/0/2

    同时,SwitchC在域2中的主控制Vlan为20,子控制Vlan为21,SwitchC为主环2中的传输节点。主端口为GigabitEthernet2/0/1,副端口为GigabitEthernet2/0/2

    在SwitchC上执行display rrpp verbose domain命令,查看结果如下:

    # 查看SwitchC上域1中的详细信息。

    [SwitchC] display rrpp verbose domain 1
    Domain Index  : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1 
    Hello Timer    : 2 sec(default is 1 sec)  Fail Timer : 7 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/1         Port status: UP
    Secondary port : GigabitEthernet1/0/2         Port status: UP

    # 查看SwitchC上域2中的详细信息。

    [SwitchC] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 2 
    Hello Timer    : 3 sec(default is 1 sec)  Fail Timer : 10 sec(default is 6 sec) 
    
    RRPP Ring      : 2
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/1         Port status: UP
    Secondary port : GigabitEthernet2/0/2         Port status: UP

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 20 to 21
    #
    rrpp enable
    #
    stp region-configuration
     instance 2 vlan 20 to 21
     active region-configuration
    #
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     timer hello-timer 3 fail-timer 10
     ring 2 node-mode master primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    rrpp enable
    #
    stp region-configuration
     instance 2 vlan 20 to 21
     active region-configuration
    #
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     timer hello-timer 3 fail-timer 10
     ring 2 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10 to 11 20 to 21
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11
     instance 2 vlan 20 to 21
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     timer hello-timer 2 fail-timer 7
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     timer hello-timer 3 fail-timer 10
     ring 2 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10 to 11
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     timer hello-timer 2 fail-timer 7
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 10 to 11
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     timer hello-timer 2 fail-timer 7
     ring 1 node-mode master primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85691

下载量:1003

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页