所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置灵活QinQ示例-VLAN Mapping接入

配置灵活QinQ示例-VLAN Mapping接入

组网需求

图10-11所示,家庭网关连接的用户业务有PC上网业务、IPTV业务、VoIP业务。

楼道交换机分配各种业务的VLAN为:

  • PC上网业务独立的VLAN:VLAN1000~VLAN1100
  • IPTV业务共享的VLAN:VLAN1101
  • VoIP业务共享的VLAN:VLAN1102
  • 家庭网关共享的VLAN:VLAN1103

每个小区交换机下行与50个楼道交换机相连,对楼道交换机上送的PC上网业务VLAN分别映射为VLAN101、VLAN102、VLAN103、……VLAN150。

运营商的汇聚交换机下行与50个小区交换机相连,对小区交换机上送的报文添加外层VLAN,分别为:VLAN21、VLAN22、VLAN23、……VLAN70。

图10-11  配置灵活QinQ-VLAN Mapping接入组网图

配置思路

采用如下的思路配置灵活QinQ以及VLAN Mapping:

  1. 在SwitchA和SwitchB上创建相关VLAN。

  2. SwitchB上配置VLAN Mapping功能,并将接口加入VLAN。

  3. SwitchA上配置灵活QinQ功能,并将接口加入VLAN。

  4. SwitchA和SwitchB的其他下行接口配置与GE1/0/0类似,此处不再赘述。

  5. SwitchA的其他下行小区交换机配置与SwitchB类似,此处不再赘述。

操作步骤

  1. 配置SwitchA

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 21 to 70 1101 to 1103
    

    # 配置接口加入VLAN

    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/0] port hybrid untagged vlan 21
    [SwitchA-GigabitEthernet1/0/0] port hybrid tagged vlan 1101 to 1103
    [SwitchA-GigabitEthernet1/0/0] quit
    

    # 配置接口灵活QinQ功能

    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port vlan-stacking vlan 101 to 150 stack-vlan 21
    [SwitchA-GigabitEthernet1/0/0] quit
    

  2. 配置SwitchB

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 101 to 150 1000 to 1103

    # 配置接口加入VLAN

    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/0] port hybrid tagged vlan 101 1000 to 1103
    [SwitchB-GigabitEthernet1/0/0] quit
    [SwitchB] interface gigabitethernet 2/0/0
    [SwitchB-GigabitEthernet2/0/0] port link-type hybrid
    [SwitchB-GigabitEthernet2/0/0] port hybrid tagged vlan 101 to 150 1101 to 1103
    [SwitchB-GigabitEthernet2/0/0] quit
    

    # 配置接口VLAN Mapping功能

    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] port vlan-mapping vlan 1000 to 1100 map-vlan 101
    [SwitchB-GigabitEthernet1/0/0] quit
    

  3. 检查配置结果

    PC上网业务、IPTV业务、VoIP业务都可以正常使用。

配置文件

  • SwitchA的配置文件。

    #
    sysname SwitchA
    #
    vlan batch 21 to 70 1101 to 1103
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid tagged vlan 1101 to 1103
     port hybrid untagged vlan 21
     port vlan-stacking vlan 101 to 150 stack-vlan 21 
    #
    return
    
  • SwitchB的配置文件。

    #
    sysname SwitchB
    #
    vlan batch 101 to 150 1000 to 1103
    #
    interface GigabitEthernet1/0/0
     port link-type hybrid
     port hybrid tagged vlan 101 1000 to 1103
     port vlan-mapping vlan 1000 to 1100 map-vlan 101
    #
    interface GigabitEthernet2/0/0
     port link-type hybrid
     port hybrid tagged vlan 101 to 150 1101 to 1103
    #
    return
    
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84687

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页