所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置灵活QinQ示例-流策略接入

配置灵活QinQ示例-流策略接入

组网需求

图10-12所示,用户侧所有低端交换机通过Switch连接网络。

用户侧主要业务有IPTV业务和PC上网业务,ME60-A供上网的PC机获取IP地址,ME60-B供IPTV的机顶盒获取IP地址。

在DSLAM上对用户不同类型的报文打上不同的VLAN Tag,从而控制PC机不从ME60-B获取IP地址。

运营商规划PPPoE报文为VLAN100~VLAN999,DHCP报文为VLAN1000~VLAN1999。

机顶盒为运营商统一赠送,所以机顶盒的MAC地址运营商可获得,而PC机的MAC地址运营商不可获得。机顶盒的MAC地址段为:00e0-8e00-0000 ffff-ff00-0000。

用户PC开机时会发送DHCP报文获取IP地址,需要将此请求拒绝,等用户使用PPPoE拨号时再获取IP地址。

图10-12  配置灵活QinQ-流策略接入组网图

配置思路

采用如下的思路配置灵活QinQ以及VLAN+MAC过滤:

  1. Switch上创建相关VLAN。

  2. Switch上配置接口GE1/0/0、GE2/0/0的类型为Hybrid,并配置灵活QinQ功能。

  3. Switch上配置基于VLAN+MAC过滤的流分类、流行为、流策略。

  4. Switch上配置接口GE1/0/0、GE2/0/0的入方向应用流策略,阻止PC机的DHCP报文获取IP地址。

操作步骤

  1. 配置灵活QinQ

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # 配置接口加入VLAN

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type hybrid
    [Switch-GigabitEthernet1/0/0] port hybrid untagged vlan 10 20
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] port link-type hybrid
    [Switch-GigabitEthernet2/0/0] port hybrid untagged vlan 10 20
    [Switch-GigabitEthernet2/0/0] quit
    [Switch] interface gigabitethernet 3/0/0
    [Switch-GigabitEthernet3/0/0] port link-type hybrid
    [Switch-GigabitEthernet3/0/0] port hybrid tagged vlan 10
    [Switch-GigabitEthernet3/0/0] quit
    [Switch] interface gigabitethernet 4/0/0
    [Switch-GigabitEthernet4/0/0] port link-type hybrid
    [Switch-GigabitEthernet4/0/0] port hybrid tagged vlan 20
    [Switch-GigabitEthernet4/0/0] quit
    

    # 配置接口灵活QinQ

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port vlan-stacking vlan 100 to 999 stack-vlan 10
    [Switch-GigabitEthernet1/0/0] port vlan-stacking vlan 1000 to 1999 stack-vlan 20
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] port vlan-stacking vlan 100 to 999 stack-vlan 10
    [Switch-GigabitEthernet2/0/0] port vlan-stacking vlan 1000 to 1999 stack-vlan 20
    [Switch-GigabitEthernet2/0/0] quit
    

  2. 配置流策略

    # 配置MAC地址过滤

    [Switch] acl number 4001
    [Switch-acl-L2-4001] rule 1 permit source-mac 00e0-8e00-0000 ffff-ff00-0000
    [Switch-acl-L2-4001] quit
    

    # 配置流分类

    [Switch] traffic classifier STB operator and
    [Switch-classifier-STB] if-match vlan-id 20
    [Switch-classifier-STB] if-match acl 4001
    [Switch-classifier-STB] quit
    

    # 配置流行为

    [Switch] traffic behavior PermitMAC
    [Switch-behavior-PermitMAC] permit
    [Switch-behavior-PermitMAC] quit
    

    # 配置流策略

    [Switch] traffic policy PermitMAC
    [Switch-trafficpolicy-PermitMAC] classifier STB behavior PermitMAC
    [Switch-trafficpolicy-PermitMAC] quit
    

    # 配置接口入方向应用流策略

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] traffic-policy PermitMAC inbound
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] traffic-policy PermitMAC inbound 
    [Switch-GigabitEthernet2/0/0] quit
    

  3. 检查配置结果

    IPTV业务和PC上网业务都可以正常使用,并且机顶盒的IP地址从ME60-B上获取,PC机的IP地址从ME60-A上获取。

配置文件

以下仅给出Switch的配置文件。

Switch的配置文件。

#
sysname Switch
#
vlan batch 10 20
#
acl number 4001
 rule 1 permit source-mac 00e0-8e00-0000 ffff-ff00-0000
#
traffic classifier STB operator and precedence 5
 if-match vlan-id 20 
 if-match acl 4001
#
traffic behavior PermitMAC
 permit
#
traffic policy PermitMAC match-order config
 classifier STB behavior PermitMAC
#
interface GigabitEthernet1/0/0
 port link-type hybrid
 port hybrid untagged vlan 10 20
 port vlan-stacking vlan 100 to 999 stack-vlan 10
 port vlan-stacking vlan 1000 to 1999 stack-vlan 20
 traffic-policy PermitMAC inbound
#
interface GigabitEthernet2/0/0
 port link-type hybrid
 port hybrid untagged vlan 10 20
 port vlan-stacking vlan 100 to 999 stack-vlan 10
 port vlan-stacking vlan 1000 to 1999 stack-vlan 20
 traffic-policy PermitMAC inbound
#
interface GigabitEthernet3/0/0
 port link-type hybrid
 port hybrid tagged vlan 10
#
interface GigabitEthernet4/0/0
 port link-type hybrid
 port hybrid tagged vlan 20
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85139

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页