所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SEP+MSTP混合环示例

配置SEP+MSTP混合环示例

组网需求

为了进行链路备份,提高网络可靠性,用户通常会使用冗余链路接入上层网络,但是使用冗余链路会在网络中产生环路。环路会造成报文在环路内不断的循环转发,最终导致广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信质量较差,甚至通信中断。为了阻塞冗余环路,并实现当环网上发生链路故障时,阻塞的冗余链路能够迅速恢复通信,可在环网上部署SEP协议。

说明:

本示例汇聚层以运行MSTP协议为例。

图17-21所示,接入层由多台二层交换设备组成、汇聚层由多台三层设备组成环形网络。汇聚层已经部署MSTP协议以消除冗余链路,接入层与汇聚层相交的两台设备不支持SEP协议,通过在接入层部署SEP协议实现冗余保护倒换,并在SEP段的边缘设备上部署网络拓扑变化通告,实现上级网络及时了解下级网络的拓扑变化。

  • 当环网上没有故障链路时,SEP能够消除以太网冗余环路。

  • 当环网上发生链路故障时,SEP能够迅速恢复本环网上各节点间通信通路。

  • 在SEP段的边缘设备上部署网络拓扑变化通告,实现上级网络及时了解下级网络的拓扑变化。

    当上级网络收到下游网络拓扑变化的消息后,会在本网络内发送TC报文,通知本网络内的所有设备清除MAC地址,重新学习下游网络拓扑变化后的MAC地址,从而保证用户流量不中断。

图17-21  SEP混合环组网图

配置思路

采用如下的思路配置SEP混合环:

  1. 配置SEP基本功能:

    1. LSW1~LSW3上配置Segment ID为1的SEP段和VLAN ID为10的控制VLAN。

    2. 将设备LSW1~LSW3加入SEP段,并配置SEP段边缘设备LSW1和LSW2上接口加入SEP段中的端口角色。

      说明:

      由于PE1和PE2设备不支持SEP协议,故在LSW1和LSW2设备上选择的端口角色必须是无邻居边缘端口。

    3. 在端口角色为无邻居主边缘端口的设备上配置灵活指定阻塞端口方式为阻塞SEP段中间位置的端口。

    4. 配置SEP抢占模式为手工抢占。

    5. 配置SEP拓扑变化通告,将SEP段拓扑变化通知上级使用MSTP协议的网络。

  2. 配置MSTP基本功能:

    1. 将PE1~PE4、LSW1、LSW2配置到一个域内,域名为RG1。

    2. 在PE1~PE4、LSW1、LSW2创建VLAN,并将STP环上接口加入VLAN。

    3. 配置PE3为根桥、PE4为备份根桥。

  3. 配置CE、LSW1~LSW3二层转发功能。

操作步骤

  1. 配置SEP基本功能

    1. LSW1~LSW3上配置Segment ID为1的SEP段和VLAN ID为10的控制VLAN。

      # 配置LSW1。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW1
      [LSW1] sep segment 1
      [LSW1-sep-segment1] control-vlan 10
      [LSW1-sep-segment1] protected-instance all
      [LSW1-sep-segment1] quit
      # 配置LSW2。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW2
      [LSW2] sep segment 1
      [LSW2-sep-segment1] control-vlan 10
      [LSW2-sep-segment1] protected-instance all
      [LSW2-sep-segment1] quit
      # 配置LSW3。
      <HUAWEI> system-view
      [HUAWEI] sysname LSW3
      [LSW3] sep segment 1
      [LSW3-sep-segment1] control-vlan 10
      [LSW3-sep-segment1] protected-instance all
      [LSW3-sep-segment1] quit
      说明:
      • 控制VLAN的ID必须是没有被创建或使用的,但是控制VLAN创建后,在配置文件会自动显示创建普通VLAN的命令。

      • 每个SEP段必须配置控制VLAN,当接口加入已经配置控制VLAN的SEP段后,接口将自动加入控制VLAN。

    2. LSW1~LSW3加入Segmengt 1,并设置端口角色

      说明:

      缺省情况下,二层端口上STP处于使能状态。在将端口加入SEP段之前,请先去使能STP。

      # 配置LSW1。

      [LSW1] interface gigabitethernet 1/0/1
      [LSW1-GigabitEthernet1/0/1] port link-type hybrid
      [LSW1-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor primary
      [LSW1-GigabitEthernet1/0/1] quit
      [LSW1] interface gigabitethernet 1/0/2
      [LSW1-GigabitEthernet1/0/2] port link-type hybrid
      [LSW1-GigabitEthernet1/0/2] stp disable
      [LSW1-GigabitEthernet1/0/2] sep segment 1
      [LSW1-GigabitEthernet1/0/2] quit

      # 配置LSW2。

      [LSW2] interface gigabitethernet 1/0/1
      [LSW2-GigabitEthernet1/0/1] port link-type hybrid
      [LSW2-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor secondary
      [LSW2-GigabitEthernet1/0/1] quit
      [LSW2] interface gigabitethernet 1/0/2
      [LSW2-GigabitEthernet1/0/2] port link-type hybrid
      [LSW2-GigabitEthernet1/0/2] stp disable
      [LSW2-GigabitEthernet1/0/2] sep segment 1
      [LSW2-GigabitEthernet1/0/2] quit

      # 配置LSW3。

      [LSW3] interface gigabitethernet 1/0/1
      [LSW3-GigabitEthernet1/0/1] port link-type hybrid
      [LSW3-GigabitEthernet1/0/1] stp disable
      [LSW3-GigabitEthernet1/0/1] sep segment 1
      [LSW3-GigabitEthernet1/0/1] quit
      [LSW3] interface gigabitethernet 1/0/2
      [LSW3-GigabitEthernet1/0/2] port link-type hybrid
      [LSW3-GigabitEthernet1/0/2] stp disable
      [LSW3-GigabitEthernet1/0/2] sep segment 1
      [LSW3-GigabitEthernet1/0/2] quit
    3. 配置灵活指定阻塞端口

      # 在Segment1中无邻居主边缘端口位于的设备LSW1上配置阻塞端口的方式为依据处于SEP段中间位置的端口为阻塞端口。

      [LSW1] sep segment 1
      [LSW1-sep-segment1] block port middle
    4. 配置抢占模式

      # 在LSW1上配置抢占模式为手工抢占。

      [LSW1-sep-segment1] preempt manual
    5. 配置SEP拓扑变化通告

      # 在Segment1中配置Segment1的拓扑变化通告给MSTP协议。

      # 配置LSW1。

      [LSW1-sep-segment1] tc-notify stp
      [LSW1-sep-segment1] quit

      # 配置LSW2。

      [LSW2] sep segment 1
      [LSW2-sep-segment1] tc-notify stp
      [LSW2-sep-segment1] quit

  2. 配置MSTP基本功能

    1. 配置MST域。

      # 配置PE1。

      <HUAWEI> system-view
      [HUAWEI] sysname PE1
      [PE1] stp region-configuration
      [PE1-mst-region] region-name RG1
      [PE1-mst-region] active region-configuration
      [PE1-mst-region] quit

      # 配置PE2。

      <HUAWEI> system-view
      [HUAWEI] sysname PE2
      [PE2] stp region-configuration
      [PE2-mst-region] region-name RG1
      [PE2-mst-region] active region-configuration
      [PE2-mst-region] quit

      # 配置PE3。

      <HUAWEI> system-view
      [HUAWEI] sysname PE3
      [PE3] stp region-configuration
      [PE3-mst-region] region-name RG1
      [PE3-mst-region] active region-configuration
      [PE3-mst-region] quit

      # 配置PE4。

      <HUAWEI> system-view
      [HUAWEI] sysname PE4
      [PE4] stp region-configuration
      [PE4-mst-region] region-name RG1
      [PE4-mst-region] active region-configuration
      [PE4-mst-region] quit

      # 配置LSW1。

      [LSW1] stp region-configuration
      [LSW1-mst-region] region-name RG1
      [LSW1-mst-region] active region-configuration
      [LSW1-mst-region] quit

      # 配置LSW2。

      [LSW2] stp region-configuration
      [LSW2-mst-region] region-name RG1
      [LSW2-mst-region] active region-configuration
      [LSW2-mst-region] quit
    2. 创建VLAN,并将环上接口加入VLAN。

      # 在PE1上创建VLAN100,并将接口GE1/0/1GE1/0/2GE1/0/3加入VLAN100中。

      [PE1] vlan 100
      [PE1-vlan100] quit
      [PE1] interface gigabitethernet 1/0/1
      [PE1-GigabitEthernet1/0/1] port link-type hybrid
      [PE1-GigabitEthernet1/0/1] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/1] quit
      [PE1] interface gigabitethernet 1/0/2
      [PE1-GigabitEthernet1/0/2] port link-type hybrid
      [PE1-GigabitEthernet1/0/2] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/2] quit
      [PE1] interface gigabitethernet 1/0/3
      [PE1-GigabitEthernet1/0/3] port link-type hybrid
      [PE1-GigabitEthernet1/0/3] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/3] quit

      # 分别在PE2、PE3和PE4上创建VLAN100,并分别将接口GE1/0/1GE1/0/2GE1/0/3加入VLAN100中。

      PE2、PE3、PE4与PE1的配置相同,具体配置过程略。请参见本示例的配置文件。

      # 分别在LSW1和LSW2上创建VLAN100,并将接口GE1/0/1加入VLAN100中。与PE1的配置相同,具体配置过程略。请参见本示例的配置文件。

    3. 启动MSTP。

      # 配置PE1。

      [PE1] stp enable

      # 配置PE2。

      [PE2] stp enable

      # 配置PE3。

      [PE3] stp enable

      # 配置PE4。

      [PE4] stp enable

      # 配置LSW1。

      [LSW1] stp enable

      # 配置LSW2。

      [LSW2] stp enable
    4. 配置PE3为根桥、PE4为备份根桥。

      # 配置PE3在MSTI0中的优先级为0,保证PE3作为根桥。

      [PE3] stp root primary

      # 配置PE4在MSTI0中的优先级为4096,保证PE4作为备份根桥。

      [PE4] stp root secondary

  3. 配置CE和LSW1~LSW3的二层转发功能

    具体配置过程略。请参考本示例中的配置文件。

  4. 验证配置结果

    经过以上配置,在网络计算稳定后,执行以下操作,验证配置结果。以LSW1为例。

    • LSW2上的接口GE1/0/1执行命令shutdown模拟端口故障,在LSW3上执行命令display sep interface查看接口GE1/0/2能否从阻塞状态放开进入转发状态。

      <LSW3> display sep interface gigabitethernet 1/0/2
      SEP segment 1
      ----------------------------------------------------------------
      Interface           Port Role     Neighbor Status     Port Status
      ----------------------------------------------------------------
      GE1/0/2             common        up                  forwarding 

配置文件

  • LSW1的配置文件

    #
    sysname LSW1
    #
    vlan batch 10 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     block port middle
     tc-notify stp
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor primary 
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW2的配置文件

    #
     sysname LSW2
    #
     vlan batch 10 100
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     tc-notify stp
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor secondary
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • LSW3的配置文件

    #
     sysname LSW3
    #
     vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 48
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan vlan 100
    #
    return
  • PE1的配置文件

    #
     sysname PE1
    #
     vlan batch 100
    #
     stp region-configuration
      region-name RG1
      active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return            
  • PE2的配置文件

    #
     sysname PE2
    #
     vlan batch 100
    #
     stp region-configuration
      region-name RG1
      active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return
  • PE3的配置文件

    #
     sysname PE3
    #
     vlan batch 100 200
    #
     stp instance 0 root primary
    #
     stp region-configuration
      region-name RG1
      active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid tagged vlan 100
     port hybrid untagged vlan 200
    #
    return
  • PE4的配置文件

    #
     sysname PE4
    #
     vlan batch 100 200
    #
     stp instance 0 root secondary
    #
     stp region-configuration
      region-name RG1
      active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid tagged vlan 100
     port hybrid untagged vlan 200
    #
    return
  • CE的配置文件
    #
     sysname CE
    #
     vlan batch 100
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid tagged vlan 100
    #
    return

相关信息

视频

如何配置SEP

翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:84128

下载量:1000

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页