所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置RRPP多实例相交环示例(使用华为设备单独组网)

配置RRPP多实例相交环示例(使用华为设备单独组网)

组网需求

图18-41所示,采用环网结构时,为了提高对网络的利用率,希望空闲链路也承担数据流量的转发,不同VLAN数据按照不同路径进行转发,实现业务流量的负载分担。由于组网中全部设备都是华为的设备,选择华为版本。

图18-41  配置RRPP多实例相交环组网图

数据准备

域1和域2中的保护VLAN以及保护VLAN所属实例详见表18-11

表18-11  实例与保护VLAN的映射关系表

Domain ID

Control VLAN ID

Data VLAN ID

Instance ID

域1

VLAN 5、VLAN 6

VLAN 100~200

Instance 1

域2

VLAN 10、VLAN 11

VLAN 201~300

Instance 2

6个环中的主节点以及主节点上的主、副端口详见表18-12

表18-12  主节点以及主、副端口信息表

Ring ID

Master Node

Primary Port

Secondary Port

Ring Type

域1环1

PEAGG

GE1/0/0

GE2/0/0

Major ring

域2环1

PEAGG

GE2/0/0

GE1/0/0

Major ring

域1环2

CE1

GE1/0/0

GE2/0/0

Sub ring

域2环2

CE1

GE2/0/0

GE1/0/0

Sub ring

域1环3

CE2

GE1/0/0

GE2/0/0

Sub ring

域2环3

CE2

GE2/0/0

GE1/0/0

Sub ring

4个子环中的边缘节点、辅助边缘节点、公共端口和边缘端口见表18-13

表18-13  边缘节点、辅助边缘节点以及公共端口、边缘端口信息表

Ring ID

Edge Node

Common Port

Edge Port

Edge-Assistant Node

Common Port

Edge Port

域1环2

UPEB

GE1/0/0

GE3/0/0

UPEC

GE2/0/0

GE3/0/0

域1环3

UPEB

GE1/0/0

GE3/0/1

UPEC

GE2/0/0

GE3/0/1

域2环2

UPEB

GE1/0/0

GE3/0/0

UPEC

GE2/0/0

GE3/0/0

域2环3

UPEB

GE1/0/0

GE3/0/1

UPEC

GE2/0/0

GE3/0/1

配置思路

采用如下的思路配置RRPP多实例相交环示例(华为版本)

  1. 创建不同的RRPP域和控制VLAN,为后续配置RRPP环做好准备。

  2. 将RRPP域1上需要通过的VLAN数据映射到实例1,包括数据VLAN和控制VLAN,为后续配置保护VLAN做好准备。

    将RRPP域2上需要通过的VLAN数据映射到实例2,包括数据VLAN和控制VLAN,为后续配置保护VLAN做好准备。

  3. 配置设备上将要加入RRPP的各接口,使其可以通过RRPP环上需要通过的VLAN数据,并去使能与RRPP相冲突的功能(例如STP功能)。

  4. 配置RRPP的工作模式为华为版本。

  5. 在各RRPP域中,配置保护VLAN并创建RRPP环。
    1. 将UPEA、UPEB、UPEC、UPED和PEAGG配置为域1的环1和域2的环1。

    2. 将CE1、UPEB、UPEC配置为域1的环2和域2的环2。

    3. 将CE2、UPEB、UPEC配置为域1的环3和域2的环3。

    4. 配置PEAGG为域1环1和域2环1的主节点,UPEA、UPEB、UPEC、UPED为传输节点。

    5. 配置CE1为域1环2和域2环2的主节点,UPEB为边缘节点、UPEC为辅助边缘节点。

    6. 配置CE2为域1环3和域2环3的主节点,UPEB为边缘节点、UPEC为辅助边缘节点。

  6. 为防止拓扑振荡,在主节点上配置链路Up时延定时器。

  7. 为减少4个子环的Edge-Hello报文都在主环通道中发送,增加有效带宽,配置环组,并将所有子环加入环组。

  8. 在各设备上使能RRPP环和RRPP协议,使得RRPP功能生效。

操作步骤

  1. 创建实例,映射允许通过的数据VLAN和控制VLAN。

    # 配置CE1。CE2、UPEA、UPEB、UPEC、UPED和PEAGG的配置与CE1相同,此处省略,详见配置文件。

    <HUAWEI> system-view
    [HUAWEI] sysname CE1
    [CE1] stp region-configuration 
    [CE1-mst-region] instance 1 vlan 5 6 100 to 200
    [CE1-mst-region] instance 2 vlan 10 11 201 to 300
    [CE1-mst-region] active region-configuration
    [CE1-mst-region] quit

  2. 配置加入RRPP环的端口

    # 配置CE1。CE2、UPEA、UPEB、UPEC、UPED和PEAGG的配置与CE1相同,此处省略,详见配置文件。

    [CE1] vlan batch 100 to 300
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type trunk
    [CE1-GigabitEthernet1/0/0] undo port trunk allow-pass vlan 1
    [CE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100 to 300
    [CE1-GigabitEthernet1/0/0] stp disable
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface gigabitethernet 2/0/0
    [CE1-GigabitEthernet2/0/0] port link-type trunk
    [CE1-GigabitEthernet2/0/0] undo port trunk allow-pass vlan 1
    [CE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 100 to 300
    [CE1-GigabitEthernet2/0/0] stp disable
    [CE1-GigabitEthernet2/0/0] quit

  3. 创建RRPP域,配置保护VLAN和控制VLAN。

    # 配置CE1。CE2、UPEA、UPEB、UPEC、UPED和PEAGG的配置与CE1相同,此处省略,详见配置文件。

    [CE1] rrpp domain 1
    [CE1-rrpp-domain-region1] protected-vlan reference-instance 1
    [CE1-rrpp-domain-region1] control-vlan 5
    [CE1-rrpp-domain-region1] quit
    [CE1] rrpp domain 2
    [CE1-rrpp-domain-region2] protected-vlan reference-instance 2
    [CE1-rrpp-domain-region2] control-vlan 10
    [CE1-rrpp-domain-region2] quit

  4. 创建RRPP环

    # 配置PEAGG为域1环1的主节点,主接口为GE1/0/0,副接口为GE2/0/0

    [PEAGG] rrpp domain 1
    [PEAGG-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [PEAGG-rrpp-domain-region1] ring 1 enable
    [PEAGG-rrpp-domain-region1] quit

    # 配置PEAGG为域2环1的主节点,主接口为GE2/0/0,副接口为GE1/0/0

    [PEAGG] rrpp domain 2
    [PEAGG-rrpp-domain-region2] ring 1 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 0
    [PEAGG-rrpp-domain-region2] ring 1 enable
    [PEAGG-rrpp-domain-region2] quit

    # 配置UPEA为域1环1的传输节点,并指定主、副接口。

    [UPEA] rrpp domain 1
    [UPEA-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region1] ring 1 enable
    [UPEA-rrpp-domain-region1] quit

    # 配置UPEA为域2环1的传输节点,并指定主、副接口。

    [UPEA] rrpp domain 2
    [UPEA-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEA-rrpp-domain-region2] ring 1 enable
    [UPEA-rrpp-domain-region2] quit

    # 配置UPED为域1环1的传输节点,并指定主、副接口。

    [UPED] rrpp domain 1
    [UPED-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPED-rrpp-domain-region1] ring 1 enable
    [UPED-rrpp-domain-region1] quit

    # 配置UPED为域2环1的传输节点,并指定主、副接口。

    [UPED] rrpp domain 2
    [UPED-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPED-rrpp-domain-region2] ring 1 enable
    [UPED-rrpp-domain-region2] quit

    # 配置UPEB为域1环1的传输节点,并指定主、副接口。

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region1] ring 1 enable
    [UPEB-rrpp-domain-region1] quit

    # 配置UPEB为域2环1的传输节点,并指定主、副接口。

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEB-rrpp-domain-region2] ring 1 enable
    [UPEB-rrpp-domain-region2] quit

    # 配置UPEB为域1环2的边缘节点,公共端口为GE1/0/0,边缘端口为GE3/0/0

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 2 node-mode edge common-port gigabitethernet 1/0/0 edge-port gigabitethernet 3/0/0
    [UPEB-rrpp-domain-region1] ring 2 enable
    [UPEB-rrpp-domain-region1] quit

    # 配置UPEB为域2环2的边缘节点,公共端口为GE1/0/0,边缘端口为GE3/0/0

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 2 node-mode edge common-port gigabitethernet 1/0/0 edge-port gigabitethernet 3/0/0
    [UPEB-rrpp-domain-region2] ring 2 enable
    [UPEB-rrpp-domain-region2] quit

    # 配置UPEB为域1环3的边缘节点,公共端口为GE1/0/0,边缘端口为GE3/0/1

    [UPEB] rrpp domain 1
    [UPEB-rrpp-domain-region1] ring 3 node-mode edge common-port gigabitethernet 1/0/0 edge-port gigabitethernet 3/0/1
    [UPEB-rrpp-domain-region1] ring 3 enable
    [UPEB-rrpp-domain-region1] quit

    # 配置UPEB为域2环3的边缘节点,公共端口为GE1/0/0,边缘端口为GE3/0/1

    [UPEB] rrpp domain 2
    [UPEB-rrpp-domain-region2] ring 3 node-mode edge common-port gigabitethernet 1/0/0 edge-port gigabitethernet 3/0/1
    [UPEB-rrpp-domain-region2] ring 3 enable
    [UPEB-rrpp-domain-region2] quit

    # 配置UPEC为域1环1的传输节点,并指定主、副接口。

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region1] ring 1 enable
    [UPEC-rrpp-domain-region1] quit

    # 配置UPEC为域2环1的传输节点,并指定主、副接口。

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 1 node-mode transit primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 0
    [UPEC-rrpp-domain-region2] ring 1 enable
    [UPEC-rrpp-domain-region2] quit

    # 配置UPEC为域1环2的辅助边缘节点,公共端口为GE2/0/0,边缘端口为GE3/0/0

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 2 node-mode assistant-edge common-port gigabitethernet 2/0/0 edge-port gigabitethernet 3/0/0
    [UPEC-rrpp-domain-region1] ring 2 enable
    [UPEC-rrpp-domain-region1] quit

    # 配置UPEC为域2环2的辅助边缘节点,公共端口为GE2/0/0,边缘端口为GE3/0/0

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 2 node-mode assistant-edge common-port gigabitethernet 2/0/0 edge-port gigabitethernet 3/0/0
    [UPEC-rrpp-domain-region2] ring 2 enable
    [UPEC-rrpp-domain-region2] quit

    # 配置UPEC为域1环3的辅助边缘节点,公共端口为GE2/0/0,边缘端口为GE3/0/1

    [UPEC] rrpp domain 1
    [UPEC-rrpp-domain-region1] ring 3 node-mode assistant-edge common-port gigabitethernet 2/0/0 edge-port gigabitethernet 3/0/1
    [UPEC-rrpp-domain-region1] ring 3 enable
    [UPEC-rrpp-domain-region1] quit

    # 配置UPEC为域2环3的辅助边缘节点,公共端口为GE2/0/0,边缘端口为GE3/0/1

    [UPEC] rrpp domain 2
    [UPEC-rrpp-domain-region2] ring 3 node-mode assistant-edge common-port gigabitethernet 2/0/0 edge-port gigabitethernet 3/0/1
    [UPEC-rrpp-domain-region2] ring 3 enable
    [UPEC-rrpp-domain-region2] quit

    # 配置CE1为域1环2的主节点,主接口为GE1/0/0,副接口为GE2/0/0

    [CE1] rrpp domain 1
    [CE1-rrpp-domain-region1] ring 2 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 1
    [CE1-rrpp-domain-region1] ring 2 enable
    [CE1-rrpp-domain-region1] quit

    # 配置CE1为域2环2的主节点,主接口为GE2/0/0,副接口为GE1/0/0

    [CE1] rrpp domain 2
    [CE1-rrpp-domain-region2] ring 2 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 1
    [CE1-rrpp-domain-region2] ring 2 enable
    [CE1-rrpp-domain-region2] quit

    # 配置CE2为域1环3的主节点,主接口为GE1/0/0,副接口为GE2/0/0

    [CE2] rrpp domain 1
    [CE2-rrpp-domain-region1] ring 3 node-mode master primary-port gigabitethernet 1/0/0 secondary-port gigabitethernet 2/0/0 level 1
    [CE2-rrpp-domain-region1] ring 3 enable
    [CE2-rrpp-domain-region1] quit

    # 配置CE2为域2环3的主节点,主接口为GE2/0/0,副接口为GE1/0/0

    [CE2] rrpp domain 2
    [CE2-rrpp-domain-region2] ring 3 node-mode master primary-port gigabitethernet 2/0/0 secondary-port gigabitethernet 1/0/0 level 1
    [CE2-rrpp-domain-region2] ring 3 enable
    [CE2-rrpp-domain-region2] quit

  5. 配置RRPP的工作模式为默认的华为版本

    # 配置CE1。CE2、UPEA、UPEB、UPEC、UPED和PEAGG的配置与CE1相同,此处省略。

    [CE1] rrpp working-mode hw

  6. 使能RRPP协议

    # 配置CE1。CE2、UPEA、UPEB、UPEC、UPED和PEAGG的配置与CE1相同,此处省略,详见配置文件。

    [CE1] rrpp enable

  7. 配置环组

    # 在UPEC上创建环组1,包含4个子环:域1环2、域1环3、域2环2和域2环3。

    [UPEC] rrpp ring-group 1
    [UPEC-rrpp-ring-group1] domain 1 ring 2 to 3
    [UPEC-rrpp-ring-group1] domain 2 ring 2 to 3
    [UPEC-rrpp-ring-group1] quit

    # 在UPEB上创建环组1,包含4个子环:域1环2、域1环3、域2环2和域2环3。

    [UPEB] rrpp ring-group 1
    [UPEB-rrpp-ring-group1] domain 1 ring 2 to 3
    [UPEB-rrpp-ring-group1] domain 2 ring 2 to 3
    [UPEB-rrpp-ring-group1] quit

  8. 配置链路Up时延定时器

    # 设置链路恢复时延为1秒,以CE1为例。CE2和PEAGG的配置与CE1相同,此处省略,详见配置文件。

    [CE1] rrpp linkup-delay-timer 1

  9. 检查配置结果

    经过以上配置,在网络计算稳定后,执行以下操作,验证配置结果。以UPEB和PEAGG为例。

    # 在UPEB上执行display rrpp brief命令,查看结果如下:

    [UPEB] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status:  Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1      0       T        GigabitEthernet1/0/0     GigabitEthernet2/0/0    Yes
     2      1       E        GigabitEthernet1/0/0     GigabitEthernet3/0/0    Yes
     3      1       E        GigabitEthernet1/0/0     GigabitEthernet3/0/1    Yes
    
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1      0       T        GigabitEthernet1/0/0     GigabitEthernet2/0/0    Yes
     2      1       E        GigabitEthernet1/0/0     GigabitEthernet3/0/0    Yes
     3      1       E        GigabitEthernet1/0/0     GigabitEthernet3/0/1    Yes

    可以看到UPEB上已经使能了RRPP协议。

    在域1中:

    主控制VLAN为5,保护VLAN为Instance 1映射的VLAN。

    UPEB为环1的传输节点,主端口为GE1/0/0,副端口为GE2/0/0

    UPEB为环2的边缘节点。公共端口为GE1/0/0,边缘端口为GE3/0/0

    UPEB为环3的边缘节点。公共端口为GE1/0/0,边缘端口为GE3/0/1

    在域2中:

    主控制VLAN为10,保护VLAN为Instance 2映射的VLAN。

    UPEB为环1的传输节点。主端口为GE1/0/0,副端口为GE2/0/0

    UPEB为环2的边缘节点。公共端口为GE1/0/0,边缘端口为GE3/0/0

    UPEB为环3的边缘节点。公共端口为GE1/0/0,边缘端口为GE3/0/1

    # 在PEAGG上执行display rrpp brief命令,查看结果如下:

    [PEAGG] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status:  Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 1 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1      0       M        GigabitEthernet1/0/0     GigabitEthernet2/0/0    Yes
    
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring  Ring   Node  Primary/Common           Secondary/Edge           Is
     ID    Level  Mode  Port                     Port                     Enabled
     ----------------------------------------------------------------------------
     1      0       M        GigabitEthernet2/0/0     GigabitEthernet1/0/0    Yes

    可以看到PEAGG上已经使能了RRPP协议,链路Up时延设置为2秒。

    在域1中的主控制VLAN为5,保护VLAN为Instance 1映射的VLAN,PEAGG为环1的主节点。主端口为GE1/0/0,副端口为GE2/0/0

    在域2中的主控制VLAN为10,保护VLAN为Instance 2映射的VLAN,PEAGG为环1的主节点。主端口为GE2/0/0,副端口为GE1/0/0

    在UPEB上执行display rrpp verbose domain命令,查看结果如下:

    # 查看UPEB在域1中的详细信息。

    [UPEB] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/0         Port status: UP
    Secondary port : GigabitEthernet2/0/0         Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Common port    : GigabitEthernet1/0/0         Port status: UP
    Edge port      : GigabitEthernet3/0/0         Port status: UP
    
    RRPP Ring      : 3
    Ring Level     : 1
    Node Mode      : Edge
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Common port    : GigabitEthernet1/0/0         Port status: UP
    Edge port      : GigabitEthernet3/0/1         Port status: UP
    

    可以看到域1的控制VLAN是VLAN5,保护VLAN是Instance 1映射的VLAN。

    UPEB在域1环1中是传输节点,节点状态为LinkUp。

    UPEB在域1环2中是边缘节点,节点状态为LinkUp。公共端口是GE1/0/0,边缘端口是GE3/0/0

    UPEB在域1环3中是边缘节点,节点状态为LinkUp。公共端口是GE1/0/0,边缘端口是GE3/0/1

    # 查看UPEB在域2中的详细信息。

    [UPEB] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/0         Port status: UP
    Secondary port : GigabitEthernet2/0/0         Port status: UP
    
    RRPP Ring      : 2
    Ring Level     : 1
    Node Mode      : Edge
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Common port    : GigabitEthernet1/0/0         Port status: UP
    Edge port      : GigabitEthernet3/0/0         Port status: UP
    
    RRPP Ring      : 3
    Ring Level     : 1
    Node Mode      : Edge
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Common port    : GigabitEthernet1/0/0         Port status: UP
    Edge port      : GigabitEthernet3/0/1         Port status: UP

    可以看到域2的控制VLAN是VLAN10,保护VLAN是Instance 2映射的VLAN。

    UPEB在域2环1中是传输节点,节点状态为LinkUp。

    UPEB在域2环2中是边缘节点,节点状态为LinkUp。公共端口是GE1/0/0,边缘端口是GE3/0/0

    UPEB在域2环3中是边缘节点,节点状态为LinkUp。公共端口是GE1/0/0,边缘端口是GE3/0/1

    在PEAGG上执行display rrpp verbose domain命令,查看结果如下:

    # 查看PEAGG在域1中的详细信息。

    [PEAGG] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 5    sub 6
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/0         Port status: UP
    Secondary port : GigabitEthernet2/0/0         Port status: BLOCKED

    可以看到域1的控制VLAN是VLAN5,保护VLAN是Instance 1映射的VLAN。

    PEAGG在域1中是主节点,节点状态为Complete。

    主端口是GE1/0/0,副端口是GE2/0/0

    # 查看PEAGG在域2中的详细信息。

    [PEAGG] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/0         Port status: UP
    Secondary port : GigabitEthernet1/0/0         Port status: BLOCKED

    可以看到域2的控制VLAN是VLAN10,保护VLAN是Instance 2映射的VLAN。

    PEAGG在域2中是主节点,节点状态为Complete。

    主端口是GE2/0/0,副端口是GE1/0/0

    在UPEB上执行display rrpp ring-group命令,查看环组设置结果。

    # 显示环组1的配置。

    [UPEB] display rrpp ring-group 1
     Ring Group 1:
     domain 1 ring 2 to 3
     domain 2 ring 2 to 3
     domain 1 ring 2 send Edge-Hello packet

配置文件

  • CE1的配置文件

    #
    sysname CE1
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 2 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 1
     ring 2 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 2 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 1
     ring 2 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
    
  • CE2的配置文件

    #
    sysname CE2
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 3 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 3 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 1
     ring 3 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
    
  • UPEA的配置文件

    #
    sysname UPEA
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
    
  • UPEB的配置文件

    #
    sysname UPEB
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode edge common-port GigabitEthernet1/0/0 edge-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode edge common-port GigabitEthernet1/0/0 edge-port GigabitEthernet3/0/1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode edge common-port GigabitEthernet1/0/0 edge-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode edge common-port GigabitEthernet1/0/0 edge-port GigabitEthernet3/0/1
     ring 3 enable
    #
    rrpp ring-group 1
     domain 1 ring 2 to 3
     domain 2 ring 2 to 3
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
    
  • UPEC的配置文件

    #
    sysname UPEC
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode assistant-edge common-port GigabitEthernet2/0/0 edge-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode assistant-edge common-port GigabitEthernet2/0/0 edge-port GigabitEthernet3/0/1
     ring 3 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
     ring 2 node-mode assistant-edge common-port GigabitEthernet2/0/0 edge-port GigabitEthernet3/0/0
     ring 2 enable
     ring 3 node-mode assistant-edge common-port GigabitEthernet2/0/0 edge-port GigabitEthernet3/0/1
     ring 3 enable
    #
    rrpp ring-group 1
     domain 1 ring 2 to 3
     domain 2 ring 2 to 3
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    interface GigabitEthernet3/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6 11 100 to 300
     stp disable
    #
    return
    
  • UPED的配置文件

    #
    sysname UPED
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode transit primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
    
  • PEAGG的配置文件

    #
    sysname PEAGG
    #
    vlan batch 5 to 6 10 to 11 100 to 300
    #
    rrpp enable
    rrpp linkup-delay-timer 1
    #
    stp region-configuration
     instance 1 vlan 5 to 6 100 to 200
     instance 2 vlan 10 to 11 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 5
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/0 secondary-port GigabitEthernet2/0/0 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 10
     protected-vlan reference-instance 2
     ring 1 node-mode master primary-port GigabitEthernet2/0/0 secondary-port GigabitEthernet1/0/0 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5 to 6 10 to 11 100 to 300
     stp disable
    #
    return
    
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85243

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页