所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Dot1q终结子接口实现跨设备VLAN间通信示例

配置Dot1q终结子接口实现跨设备VLAN间通信示例

组网需求

图8-8所示,SwitchA和SwitchB分别下挂VLAN 10和VLAN 20的二层网络,SwitchA和SwitchB之间通过三层网络互通,三层网络采用OSPF协议。

要求两个二层网络的PC实现二层隔离三层互通。

图8-8  配置Dot1q终结子接口实现跨设备VLAN间通信示例组网图

配置思路

采用如下的思路配置通过子接口跨越三层网络通信:

  1. 配置接口所属的VLAN。

  2. 配置VLANIF接口的IP地址。

  3. 配置子接口的封装方式。

  4. 配置子接口允许通过的VLAN。

  5. 配置子接口的IP地址。

  6. 配置OSPF基本功能。

说明:
  • 子接口允许通过的VLAN不能在全局创建。
  • VCMP的角色是Client时,不能配置VLAN终结子接口。

操作步骤

  1. 配置SwitchA

    # 创建VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 30
    

    # 配置接口加入VLAN。

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet1/0/2] quit
    

    # 配置VLANIF接口的IP地址。

    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.10.30.1 24
    [SwitchA-Vlanif30] quit

    # 创建并配置子接口GE1/0/1.1。

    [SwitchA] vcmp role silent
    [SwitchA] interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/1.1
    [SwitchA-GigabitEthernet1/0/1.1] dot1q termination vid 10
    [SwitchA-GigabitEthernet1/0/1.1] ip address 10.10.10.1 24
    [SwitchA-GigabitEthernet1/0/1.1] arp broadcast enable
    [SwitchA-GigabitEthernet1/0/1.1] quit
    

    # 配置OSPF基本功能。

    [SwitchA] router id 1.1.1.1
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] return
    

  2. 配置SwitchB

    # 创建VLAN。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 30
    

    # 配置接口加入VLAN。

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 30
    [SwitchB-GigabitEthernet1/0/1] quit
    

    # 配置VLANIF接口的IP地址。

    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] ip address 10.10.30.2 24
    [SwitchB-Vlanif30] quit
    

    # 创建并配置子接口GE1/0/2.1。

    [SwitchB] vcmp role silent
    [SwitchB] interface gigabitethernet1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface gigabitethernet 1/0/2.1
    [SwitchB-GigabitEthernet1/0/2.1] dot1q termination vid 20
    [SwitchB-GigabitEthernet1/0/2.1] ip address 10.10.20.1 24
    [SwitchB-GigabitEthernet1/0/2.1] arp broadcast enable
    [SwitchB-GigabitEthernet1/0/2.1] quit
    

    # 配置OSPF基本功能。

    [SwitchB] router id 2.2.2.2
    [SwitchB] ospf
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.10.20.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] return
    

  3. 检查配置结果

    SwitchA下挂的二层网络中PC上配置缺省网关为GE1/0/1.1接口的IP地址10.10.10.1/24。SwitchA下挂的交换机允许VLAN 10通过。

    SwitchB下挂的二层网络中PC上配置缺省网关为GE1/0/2.1接口的IP地址10.10.20.1/24。SwitchB下挂的交换机允许VLAN 20通过。

    配置完成后,两个二层网络的PC实现二层隔离三层互通。

配置文件

SwitchA的配置文件

#
sysname SwitchA
# 
router id 1.1.1.1
#
vcmp role silent                                                                
#
vlan batch 30
#
interface Vlanif30
 ip address 10.10.30.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type hybrid
#
interface GigabitEthernet1/0/1.1
 dot1q termination vid 10
 ip address 10.10.10.1 255.255.255.0
 arp broadcast enable
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 30
#
ospf 1
 area 0.0.0.0
  network 10.10.10.0 0.0.0.255 
  network 10.10.30.0 0.0.0.255
#
return

SwitchB的配置文件

#
sysname SwitchB
# 
router id 2.2.2.2
#
vcmp role silent                                                                
#
vlan batch 30
#
interface Vlanif30
 ip address 10.10.30.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 30
# 
interface GigabitEthernet1/0/2
 port link-type hybrid
#
interface GigabitEthernet1/0/2.1
 dot1q termination vid 20
 ip address 10.10.20.1 255.255.255.0
 arp broadcast enable 
#
ospf 1
 area 0.0.0.0
  network 10.10.20.0 0.0.0.255
  network 10.10.30.0 0.0.0.255
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85695

下载量:1003

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页