所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN协议透传示例

配置VLAN协议透传示例

组网需求

某公司拥有多个子公司,子公司与总部之间通信通过核心交换机转发时,核心交换机需要先对数据进行处理。如果多个子公司同时和总部通信,将导致核心交换机处理能力下降,从而影响通信效果,也增加了通信成本。为了解决此问题,可在核心交换机上部署VLAN透传功能。

图4-36所示,在Switch上使能VLAN透传功能后,指定VLAN内的数据到达Switch后直接被转发出去,而不上送CPU处理,从而提高了设备的运行性能、降低了通信成本、也减少了设备受到恶意数据攻击。

图4-36  配置VLAN协议透传组网图

配置思路

采用如下的思路配置VLAN协议透传功能:

  1. 创建相关VLAN。

  2. 使能VLAN协议透传功能。

  3. 配置各以太网接口以正确的方式加入VLAN。

操作步骤

  1. 配置Switch

    # 创建VLAN

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # 使能VLAN协议透传功能

    [Switch] vlan 20
    [Switch-vlan20] protocol-transparent
    [Switch-vlan20] quit
    

    # 配置接口加入VLAN

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid tagged vlan 10 20
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type hybrid
    [Switch-GigabitEthernet1/0/3] port hybrid tagged vlan 20
    [Switch-GigabitEthernet1/0/3] quit
    

  2. 配置SwitchA和SwitchB。在SwitchA、SwitchB上配置上行接口分别以tagged方式加入VLAN10、VLAN20,下行接口分别以缺省方式加入VLAN10、VLAN20,配置过程略。
  3. 检查配置结果

    配置完成后,进入VLAN20视图,使用命令display this可以查看到该VLAN是否已经使能了VLAN协议透传功能。

    [Switch] vlan 20
    [Switch-vlan20] display this
    #
    vlan 20
     protocol-transparent
    #
    return
    

配置文件

Switch的配置文件。

#
sysname Switch
#
vlan batch 10 20
#
vlan 20
 protocol-transparent
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid tagged vlan 10 20
#
interface GigabitEthernet1/0/3
 port link-type hybrid
 port hybrid tagged vlan 20
#
return
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:85103

下载量:1001

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页