所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级
S7700, S9700 V200R010C00 配置指南-以太网交换

本文档针对设备的以太网业务,主要包括链路聚合配置、VLAN配置、Voice VLAN配置、VLAN mapping配置、QinQ配置、GVRP配置、MAC表配置、STP/RSTP/MSTP配置和SEP配置等。

评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置通过VLANIF实现跨设备VLAN内通信示例

配置通过VLANIF实现跨设备VLAN内通信示例

组网需求

图4-31所示,Switch_1和Switch_2分别下挂VLAN10的二层网络,Switch_1和Switch_2之间通过三层网络互通,三层网络采用OSPF协议。

要求两个二层网络的PC实现二层隔离三层互通。

图4-31  配置通过VLANIF实现跨设备VLAN内通信组网图

配置思路

采用如下的思路配置通过VLANIF接口跨越三层网络通信:

  1. 配置接口所属的VLAN,允许VLAN通过当前接口。

  2. 配置VLANIF接口的IP地址,实现三层互通。

  3. 配置OSPF基本功能,实现路由互通。

操作步骤

  1. 配置Switch_1

    # 创建VLAN10和VLAN30。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 10 30
    

    # 配置接口GE1/0/1加入VLAN10,GE1/0/2加入VLAN30。

    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port link-type trunk
    [Switch_1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch_1-GigabitEthernet1/0/1] quit
    [Switch_1] interface gigabitethernet 1/0/2
    [Switch_1-GigabitEthernet1/0/2] port link-type trunk
    [Switch_1-GigabitEthernet1/0/2] port trunk allow-pass vlan 30
    [Switch_1-GigabitEthernet1/0/2] quit
    

    # 配置VLANIF10的IP地址为10.10.10.1/24,VLANIF30的IP地址为10.10.30.1/24。

    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address 10.10.10.1 24
    [Switch_1-Vlanif10] quit
    [Switch_1] interface vlanif 30
    [Switch_1-Vlanif30] ip address 10.10.30.1 24
    [Switch_1-Vlanif30] quit
    

    # 配置OSPF基本功能。

    [Switch_1] router id 1.1.1.1
    [Switch_1] ospf
    [Switch_1-ospf-1] area 0
    [Switch_1-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
    [Switch_1-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255
    [Switch_1-ospf-1-area-0.0.0.0] quit
    

  2. 配置Switch_2

    # 创建VLAN10和VLAN30。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 10 30
    

    # 配置接口GE1/0/1加入VLAN10,GE1/0/2加入VLAN30。

    [Switch_2] interface gigabitethernet 1/0/1
    [Switch_2-GigabitEthernet1/0/1] port link-type trunk
    [Switch_2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch_2-GigabitEthernet1/0/1] quit
    [Switch_2] interface gigabitethernet 1/0/2
    [Switch_2-GigabitEthernet1/0/2] port link-type trunk
    [Switch_2-GigabitEthernet1/0/2] port trunk allow-pass vlan 30
    [Switch_2-GigabitEthernet1/0/2] quit
    

    # 配置VLANIF10的IP地址为10.10.20.1/24,VLANIF30的IP地址为10.10.30.2/24。

    [Switch_2] interface vlanif 10
    [Switch_2-Vlanif10] ip address 10.10.20.1 24
    [Switch_2-Vlanif10] quit
    [Switch_2] interface vlanif 30
    [Switch_2-Vlanif30] ip address 10.10.30.2 24
    [Switch_2-Vlanif30] quit
    

    # 配置OSPF基本功能。

    [Switch_2] router id 2.2.2.2
    [Switch_2] ospf
    [Switch_2-ospf-1] area 0
    [Switch_2-ospf-1-area-0.0.0.0] network 10.10.20.0 0.0.0.255
    [Switch_2-ospf-1-area-0.0.0.0] network 10.10.30.0 0.0.0.255
    [Switch_2-ospf-1-area-0.0.0.0] quit
    

  3. 配置Switch_3

    # 创建VLAN10,并配置接口GE1/0/1以Untagged方式加入VLAN10,接口GE1/0/2以Tagged方式加入VLAN10。Switch_4的配置与Switch_3类似,不再赘述。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_3
    [Switch_3] vlan batch 10
    [Switch_3] interface gigabitethernet 1/0/1
    [Switch_3-GigabitEthernet1/0/1] port link-type access
    [Switch_3-GigabitEthernet1/0/1] port default vlan 10
    [Switch_3-GigabitEthernet1/0/1] quit
    [Switch_3] interface gigabitethernet 1/0/2
    [Switch_3-GigabitEthernet1/0/2] port link-type trunk
    [Switch_3-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [Switch_3-GigabitEthernet1/0/2] quit
    

  4. 检查配置结果

    Switch_1下挂的二层网络中PC上配置缺省网关为VLANIF10接口的IP地址10.10.10.1。

    Switch_2下挂的二层网络中PC上配置缺省网关为VLANIF10接口的IP地址10.10.20.1。

    配置完成后,两个二层网络的PC实现二层隔离三层互通。

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    # 
    router id 1.1.1.1
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 10.10.10.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.10.30.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.10.0 0.0.0.255 
      network 10.10.30.0 0.0.0.255
    #
    return
    
  • Switch_2的配置文件

    #
    sysname Switch_2
    # 
    router id 2.2.2.2
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 10.10.20.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.10.30.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.20.0 0.0.0.255 
      network 10.10.30.0 0.0.0.255
    #
    return
    
  • Switch_3的配置文件

    #
    sysname Switch_3
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    # 
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
  • Switch_4的配置文件

    #
    sysname Switch_4
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    # 
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
翻译
下载文档
更新时间:2019-12-27

文档编号:EDOC1000141467

浏览量:90774

下载量:1017

平均得分:
本文档适用于这些产品

相关版本

相关文档

Share
上一页 下一页